Error loading KDE Connect

kde-connect

garuda-inxi



System:
Kernel: 6.9.3-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=9d683ebc-1357-48ee-90a3-0a4b624aed18 rw rootflags=subvol=@
quiet rd.luks.uuid=86e187cf-f6ed-4383-8e9d-5eff9252472f
rd.luks.uuid=da5fd6b9-1fae-4223-8d57-784ee60c961d
resume=/dev/mapper/luks-da5fd6b9-1fae-4223-8d57-784ee60c961d loglevel=3
ibt=off
Desktop: KDE Plasma v: 6.0.5 tk: Qt v: N/A info: frameworks v: 6.2.0
wm: kwin_wayland vt: 1 dm: SDDM Distro: Garuda base: Arch Linux
Machine:
Type: Laptop System: SAMSUNG product: 300E4C/300E5C/300E7C v: 0.1
serial: <superuser required> Chassis: type: 9 v: 0.1
serial: <superuser required>
Mobo: SAMSUNG model: NP300E5C-A09US v: FAB1 serial: <superuser required>
uuid: <superuser required> UEFI: Phoenix v: P09RAP date: 11/01/2013
Battery:
ID-1: BAT1 charge: 7.8 Wh (100.0%) condition: 7.8/48.8 Wh (15.9%)
volts: 11.9 min: 11.1 model: SAMSUNG Electronics type: Li-ion serial: N/A
status: full cycles: 895
CPU:
Info: model: Intel Core i3-3110M bits: 64 type: MT MCP arch: Ivy Bridge
gen: core 3 level: v2 built: 2012-15 process: Intel 22nm family: 6
model-id: 0x3A (58) stepping: 9 microcode: 0x21
Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
L3: 3 MiB desc: 1x3 MiB
Speed (MHz): avg: 2286 high: 2400 min/max: 1200/2400 scaling:
driver: intel_cpufreq governor: performance cores: 1: 2400 2: 2116 3: 2279
4: 2349 bogomips: 19156
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: Intel 3rd Gen Core processor Graphics vendor: Samsung Co
driver: i915 v: kernel arch: Gen-7 process: Intel 22nm built: 2012-13 ports:
active: LVDS-1 empty: DP-1,HDMI-A-1,VGA-1 bus-ID: 00:02.0
chip-ID: 8086:0166 class-ID: 0300
Device-2: Silicon Motion WebCam SC-13HDL11939N driver: uvcvideo type: USB
rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 2-1.4:3
chip-ID: 2232:1029 class-ID: 0e02 serial: <filter>
Display: wayland server: X.org v: 1.21.1.13 with: Xwayland v: 24.1.0
compositor: kwin_wayland driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: crocus gpu: i915 display-ID: 0
Monitor-1: LVDS-1 res: 1366x768 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: intel crocus platforms: device: 0 drv: crocus
device: 1 drv: swrast surfaceless: drv: crocus wayland: drv: crocus x11:
drv: crocus inactive: gbm
API: OpenGL v: 4.5 compat-v: 4.2 vendor: intel mesa v: 24.1.0-arch1.1
glx-v: 1.4 direct-render: yes renderer: Mesa Intel HD Graphics 4000 (IVB
GT2) device-ID: 8086:0166 memory: 1.46 GiB unified: yes display-ID: :1.0
API: Vulkan v: 1.3.279 layers: 3 device: 0 type: integrated-gpu name: Intel
HD Graphics 4000 (IVB GT2) driver: mesa intel v: 24.1.0-arch1.1
device-ID: 8086:0166 surfaces: xcb,xlib,wayland device: 1 type: cpu
name: llvmpipe (LLVM 17.0.6 256 bits) driver: mesa llvmpipe
v: 24.1.0-arch1.1 (LLVM 17.0.6) device-ID: 10005:0000
surfaces: xcb,xlib,wayland
Audio:
Device-1: Intel 7 Series/C216 Family High Definition Audio
vendor: Samsung Co NP300E5C driver: snd_hda_intel v: kernel bus-ID: 00:1b.0
chip-ID: 8086:1e20 class-ID: 0403
API: ALSA v: k6.9.3-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Qualcomm Atheros AR9485 Wireless Network Adapter
vendor: Samsung Co driver: ath9k v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 bus-ID: 01:00.0 chip-ID: 168c:0032 class-ID: 0280
IF: wlp1s0 state: down mac: <filter>
Device-2: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
vendor: Samsung Co RTL8168 on a NP300E5C series laptop driver: r8169
v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 2000 bus-ID: 02:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Info: services: NetworkManager, smbd, systemd-timesyncd
Bluetooth:
Device-1: Qualcomm Atheros AR3012 Bluetooth 4.0 driver: btusb v: 0.8
type: USB rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-1.4:5
chip-ID: 0cf3:3004 class-ID: e001 serial: <filter>
Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: <filter> bt-v: 4.0 lmp-v: 6
status: discoverable: no pairing: no
Drives:
Local Storage: total: 704.24 GiB used: 477.3 GiB (67.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 model: TURBO JET SSD SATA 256G
size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
tech: SSD serial: <filter> fw-rev: 9A0 scheme: GPT
ID-2: /dev/sdb maj-min: 8:16 vendor: Hitachi model: HTS545050A7E380
size: 465.76 GiB block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s
tech: HDD rpm: 5400 serial: <filter> fw-rev: A7A0 scheme: GPT
Partition:
ID-1: / raw-size: 229.37 GiB size: 229.37 GiB (100.00%)
used: 69.33 GiB (30.2%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-86e187cf-f6ed-4383-8e9d-5eff9252472f
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 728 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 229.37 GiB size: 229.37 GiB (100.00%)
used: 69.33 GiB (30.2%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-86e187cf-f6ed-4383-8e9d-5eff9252472f
ID-4: /var/log raw-size: 229.37 GiB size: 229.37 GiB (100.00%)
used: 69.33 GiB (30.2%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-86e187cf-f6ed-4383-8e9d-5eff9252472f
ID-5: /var/tmp raw-size: 229.37 GiB size: 229.37 GiB (100.00%)
used: 69.33 GiB (30.2%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-86e187cf-f6ed-4383-8e9d-5eff9252472f
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/dm-1 maj-min: 254:1
mapped: luks-da5fd6b9-1fae-4223-8d57-784ee60c961d
ID-2: swap-2 type: zram size: 7.47 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 80.0 C mobo: N/A
Fan Speeds (rpm): N/A
Info:
Memory: total: 8 GiB note: est. available: 7.47 GiB used: 3.82 GiB (51.1%)
Processes: 271 Power: uptime: 3m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 2.97 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: pm: pacman pkgs: 1892 libs: 481 tools: octopi,pamac,paru
Compilers: gcc: 14.1.1 Shell: garuda-inxi default: fish v: 3.7.1
running-in: yakuake inxi: 3.3.34
Garuda (2.6.26-1):
System install date:     2024-03-30
Last full system update: 2024-06-06
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       Probably (Run as root to verify)
Failed units:            vncserver-x11-serviced.service

First troubleshooting step is to reboot.
This symbol ↻ menas that a reboot is pending after the last update.

Rebooted. The issue persists.

I will not have access to my PC for the whole day.
You could try checking if the issue persists selecting x11 instead of Wayland at login, but it’s just a shot in the dark.
At a quick check, I haven’t found anything in the KDE bug tracker:
https://bugs.kde.org/buglist.cgi?bug_status=__open__&no_redirect=1&order=changeddate%20DESC%2Cpriority%2Cbug_severity&product=kdeconnect&query_format=specific
It would have been there if it is so blocking…
Another shot in the dark, checking the Arch wiki, this suggestion is for Gnome users using KDE apps, but you never can say, just try:
https://wiki.archlinux.org/title/KDE#KDE_applications_fail_to_start_in_GNOME_after_upgrade_to_KDE_6
From terminal:

QT_QPA_PLATFORM=xcb kdeconnect

or whatever the name of the app…

1 Like

Thursday, Jun  6, 2024, 15-57-06

The issue is present even on x11.

Please, no pictures from terminal output.

They are not searchable if they are pictures, and can be hard to see across different devices.
Please select the text in the terminal, copy the text and paste the text into the post.
Select the newly pasted text in the post.
Click the </> icon in the post toolbar

This creates nicely formatted text that we can use by forum search.

Thank you :slight_smile:

4 Likes

Try reinstalling kdeconnect

2 Likes

Still the same, reinstalled & rebooted.

The error message in your screenshot points to the KDE Connect widget in the system tray widget. There have been a lot of problems with these widgets lately.
Try removing the system tray widget and creating a new one:
Top Panel → Enter Edit Mode → Mouse over system tray widget → remove.
Reboot.
Top Panel → Add Widgets → System Tray.

4 Likes

I did this process, issue same as before.

It looks like a KDE bug report was opened and confirmed.
https://bugs.kde.org/show_bug.cgi?id=487904
Hopefully it will be fixed soon.
For the moment, (from the linked Arch fr discussion) try deleting (keep a backup) ~/.config/plasma-org.kde.plasma.desktop-appletsrc and reboot.

4 Likes

Thank you for sharing the link. The fix will be provided in the update, right? I don’t need to do anything.

1 Like

Just edited my post above, sorry…

I don’t seem to have the backup file, will need to wait for the fix.

No, I meant make a copy somewhere of that file and delete it.
If it doesn’t work (after a reboot possibly), restore the file.
The exact name should be (but I’m not at my Garuda machine):
~/.config/plasma-org.kde.plasma.desktop-appletsrc

1 Like

Oh, okay. I apologize for that. Hopefully, all goes well and I’ll update you on this.

Sorry, I just don’t have time to read the details today… :slight_smile:
If you deleted that file, probably the panel afterwards will have to be all reset.
If you have already deleted, restore the file and follow the last comment (#7) of the bug report (only one line to be deleted).

I followed your solution to this. The only method that worked was deleting the file, the last comment provided there didn’t seem to help. However, there are few widgets that still have the issue, I don’t use them. As of now, this is the solution.

Thank you for your help.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.