Encrypted btrfs raid0 root

I've tried for many days to get 2 nvme drives setup as btrfs raid0 luks encrypted. I followed this tutorial:

I've tried a few times now but wound up at grub rescue complaining about:

No such device:
error: unknown filesystem.

What I did can mostly (Except the file edits mentioned in the tutorial) be boiled down to this:

#!/bin/bash
pacman --noconfirm -Sy
cryptsetup open /dev/nvme1n1p4 cryptroot
cryptsetup open /dev/nvme0n1p1 cryptroot2
cryptsetup open /dev/nvme1n1p2 cryptboot
mkdir /mnt/cryptroot
mkdir /mnt/cryptboot
mkdir /mnt/newroot
mount -o compress=zstd /dev/mapper/cryptroot /mnt/cryptroot
mount -o [email protected] /dev/mapper/cryptroot /mnt/newroot
mount /dev/mapper/cryptboot /mnt/cryptboot
for i in /dev /dev/pts /proc /sys /run; do sudo mount --bind $i /mnt/newroot$i; done
mount /dev/mapper/cryptboot /mnt/newroot/boot
mount /dev/nvme1n1p1 /mnt/newroot/boot/efi
mount --bind /sys/firmware/efi/efivars /mnt/newroot/sys/firmware/efi/efivars 
chroot /mnt/newroot
cp /usr/lib/initcpio/install/encrypt /etc/initcpio/install/encrypt2
cp /usr/lib/initcpio/hooks/encrypt  /etc/initcpio/hooks/encrypt2
sed -i "s/cryptdevice/cryptdevice2/" /etc/initcpio/hooks/encrypt2
sed -i "s/cryptkey/cryptkey2/" /etc/initcpio/hooks/encrypt2
sed -i "s/rm -f \${ckeyfile}//" /etc/initcpio/hooks/encrypt2
mkinitcpio -p linux
chmod 600 /boot/initramfs-linux-zen-fallback.img
chmod 600 /boot/initramfs-linux-zen.img

I have since given up because I needed a working install on this machine. If anyone can get an experimental setup like this working and fix the steps, please post.