EFI entry is missing

After inserting a pendrive.
My garuda efi entry is now not visible.
I ran update-grub in ububtu . but garuda is not detecting :frowning:
Plz help

Hi @ajucodz, I've moved this issue to a new topic so it doesn't get lost in that other thread.

It's not visible where?

Are you dual-booting, or what do you mean by this? Also I believe Ubuntu has os-prober disabled by default, so you'll have to edit etc/default/grub if you want that function to work.

2 Likes

I have windows ubuntu and garuda installed.
Yesterday i plugged my pendrive in and booted up.
But in the boot menu, garuda efi entry was not there. Ubuntu was there and i booted into ubuntu and ran update grub but it doesn't detect garuda.
I had the same prob in endeavor os so i fixed that by entering grub command line and typing like

linux (hdo, 12)/boot/vmlinuz.....
initrd (hdo, 12)/boot/initr......
boot

I ran this for garuda but something like this is showing.

What is on the pendrive?

What boot menu?

First you would have to enable os-prober. Have you done that? It would be helpful to see the output of your "update-grub" command.

Yeah that is enabled. It is detecting the other(windows and another os).
Not garuda.

The efi entry menu. :face_in_clouds:

What is on the pendrive?

This is still unclear. Are you making your boot selection from the BIOS menu? Or grub?

Please boot into the live environment and post the output of garuda-inxi and also lsblk -f.

Songs and somethin like that.....

Hey man,
The grub efi is missing i think.

It may have deleted.

I don't have enough details to be helpful.

1 Like

The problem got fixed. I used the garuda boot repair from the live iso.
Thanks

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.