Eduroam internet connections not working


I have just moved back to my dorm and I tried to connect Garuda to the school wifi connections, but they do not work. I also tried to use an ethernet connection, but that didn't work either. I know that these connections work and are valid because I also have Windows on this computer and it can connect easily to either ethernet or to a network, but it doesn't work on Garuda.

Whenever I connect to a wired or a wireless connection, it shows as connected, but the speed it shows is extremely low (a maybe a few hundred B/s), and I am unable to connect to any website. For the wireless connections, I have to log in with a username and password, which I already put in under "Configure" but it still doesn't work.

I'm not sure why it's not working, since my Wifi connection at home worked just fine with Garuda. Could someone help me with this?

1 Like

Is your school's system using Eduroam. If so, search the Archwiki for information regarding connecting to an eduroam network on Linux.

You may need to contact your schools IT dept for full instructions on how to connect to their system using Linux. Many people have difficulties connecting to Eduroam systems using Linux if unfamiliar with the procedures involved.


Yes, my school is using Eduroam. I will contact the IT department and ask them how to set it up, but I'm not sure how much they will be able to help. On Debian, I was able to connect fairly easily, but I guess it is different with Arch based distros. Thank you.


Just to reiterate that if the connection works at home then it's something specific to your dorm (e.g. they have a captive portal or use MAC address authentication), so don't start randomly changing settings which are otherwise working fine.

There's nothing worse than changing settings and software and just breaking things more... :pensive:


And here, I had thought the whole purpose of Linux was to 'fix' stuff until it's broken. All these years--wasted! :frowning:

1 Like

Thread is deemed abandoned.

Thread is now closed.

PM a mod if you are the OP and wish the issue reopened.