Dual Monitor Linux Bug

System:
  Kernel: 5.13.0-7614-generic x86_64 bits: 64 compiler: gcc v: 10.2.1 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.13.0-7614-generic 
  root=UUID=ba8e9f9d-79ff-4357-bdc8-a8a807970369 ro quiet splash 
  vt.handoff=7 
  Desktop: GNOME 3.38.4 tk: GTK 3.24.25 wm: gnome-shell dm: GDM3 3.38.2.1 
  Distro: Pop!_OS 21.04 base: Ubuntu 21.04 Hirsute 
Machine:
  Type: Desktop Mobo: ASUSTeK model: PRIME A320M-K v: Rev X.0x 
  serial: <filter> UEFI [Legacy]: American Megatrends v: 5602 
  date: 07/14/2020 
CPU:
  Info: Quad Core model: AMD Ryzen 5 3400G with Radeon Vega Graphics 
  bits: 64 type: MT MCP arch: Zen/Zen+ note: check family: 17 (23) 
  model-id: 18 (24) stepping: 1 microcode: 8108109 L2 cache: 2 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 59087 
  Speed: 1258 MHz min/max: 1400/3700 MHz boost: enabled Core speeds (MHz): 
  1: 1258 2: 1258 3: 1258 4: 1259 5: 1259 6: 1258 7: 1264 8: 1260 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: AMD Navi 23 vendor: Sapphire Limited driver: amdgpu v: kernel 
  bus ID: 03:00.0 chip ID: 1002:73ff class ID: 0300 
  Device-2: AMD Picasso vendor: ASUSTeK driver: amdgpu v: kernel 
  bus ID: 0a:00.0 chip ID: 1002:15d8 class ID: 0300 
  Display: x11 server: X.Org 1.20.11 compositor: gnome-shell driver: 
  loaded: amdgpu,ati unloaded: fbdev,modesetting,radeon,vesa display ID: :1 
  screens: 1 
  Screen-1: 0 s-res: 2688x1468 s-dpi: 96 s-size: 711x388mm (28.0x15.3") 
  s-diag: 810mm (31.9") 
  Monitor-1: DisplayPort-3 res: 768x1366 hz: 60 
  Monitor-2: HDMI-A-1-0 res: 1920x1080 dpi: 90 size: 542x305mm (21.3x12.0") 
  diag: 622mm (24.5") 
  OpenGL: renderer: AMD Radeon Vega 11 Graphics (RAVEN DRM 3.41.0 
  5.13.0-7614-generic LLVM 12.0.0) 
  v: 4.6 Mesa 21.2.1 direct render: Yes 
Audio:
  Device-1: AMD driver: snd_hda_intel v: kernel bus ID: 03:00.1 
  chip ID: 1002:ab28 class ID: 0403 
  Device-2: AMD Raven/Raven2/Fenghuang HDMI/DP Audio 
  vendor: ASUSTeK PRIME B450M-A driver: snd_hda_intel v: kernel 
  bus ID: 0a:00.1 chip ID: 1002:15de class ID: 0403 
  Device-3: AMD Family 17h HD Audio vendor: ASUSTeK PRIME B450M-A 
  driver: snd_hda_intel v: kernel bus ID: 0a:00.6 chip ID: 1022:15e3 
  class ID: 0403 
  Sound Server: ALSA v: k5.13.0-7614-generic 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel port: e000 
  bus ID: 08:00.0 chip ID: 10ec:8168 class ID: 0200 
  IF: enp8s0 state: up speed: 100 Mbps duplex: full mac: <filter> 
Drives:
  Local Storage: total: 2.38 TiB used: 169.08 GiB (6.9%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: Kingston model: SA400S37480G 
  size: 447.13 GiB block size: physical: 512 B logical: 512 B 
  speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: 0107 scheme: GPT 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital 
  model: WDS120G2G0B-00EPW0 size: 111.8 GiB block size: physical: 512 B 
  logical: 512 B speed: 6.0 Gb/s rotation: SSD serial: <filter> rev: 0000 
  scheme: MBR 
  ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: Western Digital 
  model: WD My Passport 0827 size: 1.82 TiB block size: physical: 512 B 
  logical: 512 B serial: <filter> rev: 1012 scheme: MBR 
  ID-4: /dev/sdd maj-min: 8:48 type: USB vendor: SanDisk model: USB 3.2Gen1 
  size: 14.61 GiB block size: physical: 512 B logical: 512 B 
  serial: <filter> rev: 1.00 scheme: MBR 
Partition:
  ID-1: / raw size: 107.79 GiB size: 105.6 GiB (97.97%) 
  used: 6.38 GiB (6.0%) fs: ext4 dev: /dev/sdb1 maj-min: 8:17 
Swap:
  Kernel: swappiness: 10 (default 60) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 4 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/dm-0 maj-min: 253:0 mapped: cryptswap 
Sensors:
  Message: No sensors data was found. Is sensors configured? 
Info:
  Processes: 311 Uptime: 11m wakeups: 0 Memory: 13.59 GiB 
  used: 1.82 GiB (13.4%) Init: systemd v: 247 runlevel: 5 Compilers: 
  gcc: 10.3.0 alt: 10 Packages: apt: 1744 lib: 875 flatpak: 0 Shell: Bash 
  v: 5.1.4 running in: gnome-terminal inxi: 3.3.01

==================================================

Hello again, a few hours ago I was struggling with an issue regarding geruda and my dual monitor setup. I gave up and tried a few other distros resulting in me going back to Pop OS and having the exact same issue. I am running two monitors, one of them is unusable (My main one) when using certain applications like firefox or typing in any application.

If I can fix this I will just revert back to geruda, so if anyone has any idea about how to fix this, I'd appreciate the help. Couldn't find anything online. Thanks.

No one can help you without more detailed information. What specifically makes it unusable? What happens when you try to use it?

Because many of us run 2-3 monitors all day without any issues.

1 Like

Thanks for the response.

When using geruda, the entire OS would drop to less than 2fps when interacting with any of the GUI. For example, trying to open software via the task bar took incredibly long. Attempting to shut the system down via the top left corner also would take an incredibly long amount of time.

Using Firefox would crash the system if I attempted to use it on that specific monitor. Typing any amount of characters would have an input delay of about 5 seconds. The other monitor works fine, when moving the Firefox tab over I can type absolutely fine.

Are both monitors connected to the graphics card or is one connected to the motherboard?

Have you tried switching to Wayland?

The working monitor is connected to the motherboard
The non-working monitor is connected to the GPU

I will look into Wayland now. Thank you.

Are you using notebook or desktop ? Maybe you have to try hybrid

Desktop. How would i enable hybrid?

Can you plug them both into the dedicated GPU so you aren't using two different GPUs?

Maybe use

Garuda Linux :smiley: and not geruda!

You post your inxi from another OS.
If you are asking for help here, you should also have Garuda installed.

Can I assume that you have asked the same question in other forums?

Did you try also KDE, Xfce?

5 Likes

You have to download a software for hybrid gpu. I dont know if this will resolve your issue . But you can try optimus-manager

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.