Dual Monitor blank except mouse

So basically, I have a laptop with a 3050ti nvidia ti. Recently I've installed garuda KDE and for some reason my 2nd monitor is simply blank but the mouse.

Now, I once fixed this EXACT issue with ubuntu drivers, but seeing how it's unavailable on arch, I have zero idea on how to fix it.

System settings,
and in termial/konsole use

nvidia-settings

1 Like
Kernel: 5.18.16-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=6464841b-1a24-4fcd-b5ce-1ac83240fa55 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.25.4 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: Dell product: Dell G15 5515 v: 1.7.1
serial: <superuser required> Chassis: type: 10 v: 1.7.1
serial: <superuser required>
Mobo: Dell model: 0PGC5N v: A00 serial: <superuser required> UEFI: Dell
v: 1.7.1 date: 06/01/2022
Battery:
ID-1: BAT1 charge: 53.1 Wh (100.0%) condition: 53.1/56.0 Wh (94.8%)
volts: 12.5 min: 11.4 model: Simplo 0x50,0x39,0x35,0x41,0x0B,0x0A,0x000F
type: Li-ion serial: <filter> status: full
CPU:
Info: model: AMD Ryzen 5 5600H with Radeon Graphics bits: 64 type: MT MCP
arch: Zen 3 gen: 4 built: 2021-22 process: TSMC n7 (7nm) family: 0x19 (25)
model-id: 0x50 (80) stepping: 0 microcode: 0xA50000C
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 1585 high: 2246 min/max: 1200/4280 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 2158 2: 1397
3: 1396 4: 1780 5: 2246 6: 1678 7: 1395 8: 1397 9: 1396 10: 1396 11: 1395
12: 1397 bogomips: 79048
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities:
Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data status: Not affected
Type: retbleed status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: always-on, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA GA107M [GeForce RTX 3050 Mobile] vendor: Dell
driver: nouveau v: kernel non-free: 515.xx+ status: current (as of 2022-07)
arch: Ampere code: GAxxx process: TSMC n7 (7nm) built: 2020-22 pcie:
speed: Unknown lanes: 63 link-max: gen: 6 speed: 64 GT/s ports:
active: none off: HDMI-A-1 empty: none bus-ID: 01:00.0 chip-ID: 10de:25a2
class-ID: 0300
Device-2: AMD Cezanne vendor: Dell driver: amdgpu v: kernel arch: GCN-5.1
code: Vega-2 process: TSMC n7 (7nm) built: 2018-21 pcie: gen: 3
speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s ports:
active: eDP-1 empty: DP-1 bus-ID: 05:00.0 chip-ID: 1002:1638
class-ID: 0300
Device-3: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
bus-ID: 1-4:4 chip-ID: 0c45:6720 class-ID: 0e02
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: amdgpu,nouveau display-ID: :0
screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 res: 1920x1080 hz: 120 dpi: 142
size: 344x194mm (13.54x7.64") diag: 395mm (15.55") modes: N/A
OpenGL: renderer: AMD RENOIR (LLVM 14.0.6 DRM 3.46 5.18.16-zen1-1-zen)
v: 4.6 Mesa 22.1.4 direct render: Yes
Audio:
Device-1: NVIDIA vendor: Dell driver: snd_hda_intel v: kernel pcie:
speed: Unknown lanes: 63 link-max: gen: 6 speed: 64 GT/s bus-ID: 01:00.1
chip-ID: 10de:2291 class-ID: 0403
Device-2: AMD Renoir Radeon High Definition Audio vendor: Dell
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 05:00.1 chip-ID: 1002:1637
class-ID: 0403
Device-3: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: Dell
driver: snd_rn_pci_acp3x v: kernel
alternate: snd_pci_acp3x,snd_pci_acp5x,snd_pci_acp6x,snd_acp_pci,snd_sof_amd_renoir
pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4 speed: 16 GT/s
bus-ID: 05:00.5 chip-ID: 1022:15e2 class-ID: 0480
Device-4: AMD Family 17h/19h HD Audio vendor: Dell driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
speed: 16 GT/s bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403
Sound Server-1: ALSA v: k5.18.16-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
Device-1: Realtek RTL8125 2.5GbE vendor: Dell driver: r8169 v: kernel pcie:
gen: 2 speed: 5 GT/s lanes: 1 port: 2000 bus-ID: 03:00.0 chip-ID: 10ec:8125
class-ID: 0200
IF: enp3s0 state: down mac: <filter>
Device-2: Intel Wi-Fi 6 AX200 vendor: Rivet Networks Killer™
driver: iwlwifi v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1
bus-ID: 04:00.0 chip-ID: 8086:2723 class-ID: 0280
IF: wlp4s0 state: up mac: <filter>
Bluetooth:
Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
bus-ID: 1-3:5 chip-ID: 8087:0029 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
Drives:
Local Storage: total: 476.94 GiB used: 13.24 GiB (2.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: BC711 NVMe
512GB size: 476.94 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 41002131
temp: 42.9 C scheme: GPT
Partition:
ID-1: / raw-size: 233.51 GiB size: 233.51 GiB (100.00%) used: 13.22 GiB
(5.7%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 27.6 MiB
(28.7%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 233.51 GiB size: 233.51 GiB (100.00%) used: 13.22
GiB (5.7%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-4: /var/log raw-size: 233.51 GiB size: 233.51 GiB (100.00%) used: 13.22
GiB (5.7%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
ID-5: /var/tmp raw-size: 233.51 GiB size: 233.51 GiB (100.00%) used: 13.22
GiB (5.7%) fs: btrfs dev: /dev/nvme0n1p5 maj-min: 259:5
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 14.98 GiB used: 768 KiB (0.0%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 60.4 C mobo: N/A gpu: amdgpu temp: 53.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 322 Uptime: 3m wakeups: 2 Memory: 14.98 GiB used: 1.6 GiB
(10.7%) Init: systemd v: 251 default: graphical tool: systemctl
Compilers: gcc: 12.1.1 Packages: pacman: 1747 lib: 502 Shell: fish v: 3.5.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.20
warning: database file for 'garuda' does not exist (use '-Sy' to download)
warning: database file for 'core' does not exist (use '-Sy' to download)
warning: database file for 'extra' does not exist (use '-Sy' to download)
warning: database file for 'community' does not exist (use '-Sy' to download)
warning: database file for 'multilib' does not exist (use '-Sy' to download)
warning: database file for 'chaotic-aur' does not exist (use '-Sy' to download)
Garuda (2.6.5-1):
System install date:     2022-08-22
Last full system update: 2022-08-08
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

Here, have garuda-inx... or something like that

yeah no, the settings don't look anything like that, there is no server x configuration

Check

pacman -Qi nvidia-settings

And do minimum onetime a week

garuda-update -a

No nvidia driver, no settings.

2 Likes

Install propriearty drivers:

sudo pacman -S nvidia-dkms nvidia-settings lib32-nvidia-utils nvidia-utils
1 Like