Dual Boot issue: restart ≠ power off

Hello guys,

So I have recently installed Garuda (KDE Dragonized) and it's working very well. But I have a weird glitch going on.

I am dual booting with windows 10 (which was already installed) and Garuda on separate ssds.

When I power off the pc, it boots perfectly well showing my motherboard logo for like 4 or 5 seconds and then it goes to grub (version 2.04), with all the perfect boot options - Garuda, Windows, etc.

When I am in Windows 10 and I choose to restart, it is just the same - everything OK.

However, if I am in Garuda and I choose to restart, after the motherboard beep, my motherboard logo doesn't show up (sometimes it blinks for 1 second or less). I just see a black screen (sometimes with a few colorful glitches) and then Garuda boots up automatically.

I've already dual booted with many distros and never seen such a "selective" bug before. Usually grub just works or it doesn't, so I have no idea what is happening.

It sort of feels like when I reboot from Garuda everything happens so fast that it just opens grub and picks the first boot option of the list (which is Garuda) but at the same time, the screen goes black during that process with brief blinks that helped me come up with this theory.

Any ideas on how to fix this? Thanks!


Asus TUF 310-Plus Gaming | i5-8400 | Radeon RX580

It's a feature by KDE, if you are in KDE and say reboot it reboot to KDE :smiley:


KDE sometimes feels like Windows - it doesnt seem like it wants to reboot :joy:


No ideas, so check the journal logs, looking to the end of the previous boot and beginning of new boot.
It could relate to the command that is used for restart. Did you use Applications Launcher menu?
Try systemd command from terminal.

systemctl reboot

Ohhh amazing! All the other distros I had never had this new feature. Thanks for including with this one! So cool!

No ideas, so check the journal logs, looking to the end of the previous boot and beginning of new boot.
It could relate to the command that is used for restart. Did you use Applications Launcher menu?
Try systemd command from terminal.

systemctl reboot

Thanks petsam. I rebooted using the Applications Launcher. Then I started trying different ways of rebooting from the terminal, including the one you mentioned but they all give the same result.

I started reading the journal logs yesterday but I honestly don't know enough to find the problem that fast. I will have to export it and search for known issues.

I'm considering updating my UEFI and reinstalling grub to see if it helps, but the bug still makes no sense to me.

1 Like

Check if you have fastboot enabled in bios
If it is then disable it


@librewish thanks for the tip, but it was already disabled.

So I have tried to update my grub and discovered that it had some stupid syntax error when I tried to run grub-update. Actually GRUB has some serious stupid and frequent if / fi syntax errors that are fixed with a :. So I had to manually edit some /grub files and it finally updated properly. Nice! Fixed the problem? NO!

However, since I haven't found linux results with the same issue as mine I am starting to think that it's microsoft EFI's partition fault. I will digg a little more and reinstall my win EFI and post the results here.

Still, thanks for trying!

1 Like

I believe this is a firmware/hardware issue, about vendor's UEFI implementation.
And/or about framebuffer of efi.
What resolution have you set for Grub?


A post was split to a new topic: Unaceptable language and Image content

I am happy it fixed your issue - but I am now even more confused by mine! I had the same behaviour on a multi-boot system - and generally I don't use grub (except on one Garuda, to enable the Timeshift entries). I have found that one Garuda has this problem, and one doesn't (on the same machine!) - and other places with the same quirk are a Xubuntu, and MX-Linux (different machine) I have tried lots of different boot methods (and MX 19 isn't even systemd!) but only shutdown returns saniity, and a look at the Bios screen and then the bootloader....

Also on 4K screen - and journals so far uninformative....

1 Like

Hello guys.

After some research and lots of attempts to find out the origin of the issue and thanks to @petsam who guessed the issue correctly, I figured out that the problem was indeed with grub's resolution.

In one of the forums that I was reading I noticed some comments about Grub video resolution and the fact that the screen was glitching sometimes on the splash screen made me suspect that this was indeed the problem.

So I shut down the PC, turned it on and then on Grub screen I entered the command prompt (by typing c). Then I tried the command videoinfo which returned the list of acceptable possible resolutions for Grub in my PC. The maximum resolution was 1230x1024. But it was actually configured to auto.

After that I typed videotest and it took me to a grub colorful screen but then it just shut down right after without any input of mine. So I imagined this was indeed the cause of the problem.

So I rebooted into Garuda and edited the file /etc/default/grub in which I looked for the line that said GRUB_GFXMODE which was set to auto. Then I changed it to the value 1230x1024x32.

After this I saved the file and ran the command sudo grub-mkconfig -o /boot/grub/grub.cfg

Note: just a reminder that grub update sometimes does not work (which was my case) because of syntax errors, so it is important to verify if it is running correctly.

Then, after successfully updating grub, I rebooted the pc and my splash screen was properly loaded with the Asus motherboard logo and grub also loaded perfectly right after that.

Note: I am running a 4k monitor in a Radeon RX 580 through HDMI. It seems that grub tried to run on 4k and that caused it to malfunction. I will also report this to Grub developers to see if it helps.

Thanks to all the team members who helped me here! I am very happy that I fixed my boot, seriously.



@freebird54 what I have learned with this is that the OS you are using to reboot seems to push it's own configs to the UEFI sequence. In other words, it is not a clean reboot. When I restarted from Windows everything, including grub, worked perfectly well. Maybe you have to go to every single one of your distros and change their own GRUB resolution until you find the one that works properly for each of them.

Also, keep in mind that I also did other adjustments in my UEFI that have not directly fixed the issue but maybe the solution would not work completely if I had not done them. So I will just list them here in case someone else needs it.

What I did before finding the solution (and how my system is still configured):

  • Disabled fast boot
  • Disabled secure boot
  • Enabled legacy uefi boot

There are other adjustments that some claim that are relevant but they were already default in my UEFI so I have not done anything about them.

And indeed it seems that the main problem is related to high resolutions since you are also on 4k. Let us know later on if it worked and if I can help you with something else do tell me.

Good luck!


@delldiedie first, welcome to Garuda. You did a really good job of working out the problem.



FYI :slight_smile:
install update-grub :wink:

1 Like

Thanks @zoner ! I am relly glad I could learn something with that bug instead of just having to reinstall stuff. Also, I just checked GRUB's bug reporting page and the latest bug reported is exactly the same one I had. So I just commented on it to emphasize the matter.

You work with the Garuda team as well?


No, I am not on the team but I am a strong supporter of what they are doing. I have been at this computer thing for over 55 years. My personal management style is to find people doing good things and giving them support and encouragement. Your work dealing with that issues is what I like to see.

Please take care and stay safe...