Dual Boot Garuda & Linux Mint

Thank you for the dual boot tutorial redirect although I have no windows in my sys.

Thank you petsam for your assistance, noted the advise, and back to the drawing board :cry: :cry:

Btw, I used efibootmgr to change the boot order but (as expected) the system changed it again....now where is that manual :angry:

2 posts were split to a new topic: I also have a boot problem

You booted Garuda in BIOS/Legacy mode rather than UEFI mode.

This is probably why each bootloader can't see the other distro.

The solution is to boot in the same mode for all installed OS.

2 Likes

what is the difference between booting garuda linux zen fallback initamfs or garuda linux zen only can you help

For UEFI understanding which will help you troubleshoot, I advise reading this, it helped me immensely.

This is for the UEFI layer before grub.

Once you have this layer figured out and have all your os booting in uefi mode, then you can use the advice already given to use the grub from Garuda that will actually recognize the btrfs filesystem and see Garuda. Presumably it will also recognize the mint install too and add it to the grub list.

5 Likes

https://h10032.www1.hp.com/ctg/Manual/c03334506.pdf

2 Likes

What has this got to do with this thread?

https://wiki.archlinux.org/index.php/Mkinitcpio#Automated_generation

3 Likes

Thanks, trying to figure this out in my novelty.
Meantime, I notice Garuda 'sees' Mint's partition and lists it at startup (i.e. when login into Garuda and am even able to log into Mint via Garuda's grub) but Mint is totally blind to Garuda's existence.
From your input(s), I believe my problem is very small and I should figure my way out of this forest in due course.
Thanks again ALL for your tips @petsam @Naman @c00ter @jbMacAZ @hall

This issue is solved with the latest grub2 upgrade, but it needs to be upgraded from Mint packages to the newest version.

The relevant setting that solve this is documented in Grub Manual. Search for

GRUB_EARLY_INITRD_LINUX_STOCK
3 Likes