Dual Boot Garuda & Linux Mint

It is the second time I have installed Garuda but same results. Whether I install Mint 1st, then Garuda or Garuda 1st, then Mint, results are the same. When I start my laptop, it boots straight into Mint and does not recognize Garuda's existence. There is no menu to select OS to log into. Currently, am accessing Garuda via Esc key, then F9 (boot options), then Garuda. Once I shutdown or reboot from either OS, it again boots Mint. How do I resolve and have the option/menu to select OS at start up?

Just rearrange boot order in your BIOS
This happen on your hp machine ?

yes, hp 4540s

Follow my step
Go to BIOS by F10
And in your boot order
Change sequence of booting
If don't understand
Send a pic

1 Like

Am in BIOS but sorry, cannot figure out. Will send a pic in just a moment....

Hi there, welcome to the forums.

If you have different drives on which you have Mint and Garuda, you simply have to change boot order.

But if you have both of them on same ssd/hdd then you will have to reinstall Grub.

4 Likes

Use Garuda's GRUB and stick it where it needs to be.

4 Likes

![2|666x500]

Wait, don't post more pics

1 Like

on same ssd/hdd

Then simply boot into live media and run Garuda Boot Manager and install Grub.

1 Like

Thanks, will give it a try and revert

@Jonah in second pic
There is UEFI boot order
Go to OS boot manager by simply down arrow key and hit enter
Now see if your both OS entry is visible
If yes then you can reorder your boot entry by simply F6 and F5 and then for changes press F10

Hi Hall. No success. Once I hit enter, the UEFI Boot Order is activated but the only option available is to move the listed options (OS Boot Manager, USB Hard Drive, etc) up or down, no OS entry visible.

@Naman. Not good either, option to reinstall grub bootloader coming up, then install on MBR (not on root or ESP), then root location (btrfs) results in error
"Installing for i386-pc platform. grub-install: warning this GPT partition label contains no BIOS Boot Partition; embedding won't be possible. grub-install: error: filesystem 'btrfs' doesn't support blocklists,"

Fast boot needs to be off. That may not be the problem, but it is not helping. Did you see the dual boot tutorial? (Substitute Mint for windows) There needs to be a shared ESP (/boot/efi) FAT32 partition for grub to work with btrfs. This requires manual partitioning when installing Garuda. Mint's grub can't see a pure btrfs distro (and mint's grub won't boot Arch distros anyway.) Also, be aware that Mint will reset the boot order whenever its kernel is updated.

3 Likes

Boot to Garuda and provide info from terminal (input and output)

cat /sys/firmware/efi/fw_platform_size
efibootmgr -v
sudo os-prober
inxi -Fxxxza
5 Likes

Your issue root cause is your HW/firmware (UEFI).
Your UEFI most probably includes the functionality to change installed OSes boot order, but you don't know how to do it.
If this function is absent, use efibootmgr from garuda or Mint to change boot order.
If you set the correct boot order and your system changes it again, contact your vendor's support for help, or implement this workaround.

In any case, you should read the laptop User Manual!!!

4 Likes

Read

please :slight_smile:
and post

inxi -Fxxxza

as text!

Even if you personally think it is unnecessary.

and
:slight_smile:

1 Like