Dolphin's AppMenu displays "No text" but clickable to sub-menu items

Hey folks, hoping someone might be able to point me in the right direction. I'm running Garuda Dragonized, and fully up-to-date on system and package updates.

Using latte-dock, the top-bar has a "Window AppMenu" widget which displays the active window's menubar options. Most all other apps play nice, and will display their respective menubar options. FireDragon, for example, displays "File", "Edit", "View", "History", etc when it's the active foreground window. Clicking on each of these menu headings will display the sub-menu with the clickable options. This menu will change for each app that's in the active/focus state.

I recently noticed, however, that Dolphin displays 5 "No text" menu items, followed by "Settings" and "Help". I confirmed that Dolphin's language is set to "U.S. English" as primary (read somewhere that other localized languages may display "No text" if that menu string isn't available in the localized language).

I dug around the "Window AppMenu" widget's config, and didn't see any setting that looked like it would fix this. I also dug around all of Dolphin's configuration settings, and either I'm missing it, or it doesn't exist there.

I just, cannot for the life of me, figure out how to get it to display the proper menubar text for each menu heading, instead of "No text". The "No text" is clickable, and the respective menu items appear in the submenu and can be clicked on.

Here's a screenshot of what it looks like:

Dolphin Menubar Screenshot

inxi -Faz output just in case
❯ inxi -Faz
System:    Kernel: 5.14.8-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=12979374-b0c5-4bc8-8f21-3b53bd02741b rw
           [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
           systemd.unified_cgroup_hierarchy=1 resume=UUID=334332cc-a79e-45e2-b657-65270e259a03 loglevel=3
           sysrq_always_enabled=1 intel_iommu=on iommu=pt acpi_backlight=vendor delayacct
           Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
           Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: LENOVO product: 20175 v: Lenovo IdeaPad Yoga 13 serial: <filter> Chassis:
           type: 10 v: Lenovo IdeaPad Yoga 13 serial: <filter>
           Mobo: LENOVO model: INVALID v: 31900003WIN8 STD MLT serial: <filter> UEFI: LENOVO v: 66CN55WW
           date: 02/28/2013
Battery:   ID-1: BAT1 charge: 38.4 Wh (100.0%) condition: 38.4/49.3 Wh (78.0%) volts: 16.2 min: 14.8
           model: Lenovo IdeaPad Mocca2 type: Unknown serial: <filter> status: Full
CPU:       Info: Dual Core model: Intel Core i7-3537U bits: 64 type: MT MCP arch: Ivy Bridge family: 6
           model-id: 3A (58) stepping: 9 microcode: 21 cache: L2: 4 MiB
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19954
           Speed: 1891 MHz min/max: 800/1900 MHz Core speeds (MHz): 1: 1891 2: 1857 3: 1891 4: 1816
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable
           Type: meltdown mitigation: PTI
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2
           mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
           Type: srbds status: Vulnerable: No microcode
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel 3rd Gen Core processor Graphics vendor: Lenovo driver: i915 v: kernel
           bus-ID: 00:02.0 chip-ID: 8086:0166 class-ID: 0300
           Device-2: Chicony Lenovo EasyCamera type: USB driver: uvcvideo bus-ID: 2-1.7:4 chip-ID: 04f2:b322
           class-ID: 0e02
           Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: intel unloaded: modesetting
           alternate: fbdev,vesa display-ID: :0 screens: 1
           Screen-1: 0 s-res: 1600x900 s-dpi: 96 s-size: 423x238mm (16.7x9.4") s-diag: 485mm (19.1")
           Monitor-1: LVDS1 res: 1600x900 hz: 60 dpi: 140 size: 290x170mm (11.4x6.7") diag: 336mm (13.2")
           OpenGL: renderer: Mesa DRI Intel HD Graphics 4000 (IVB GT2) v: 4.2 Mesa 21.2.3 compat-v: 3.0
           direct render: Yes
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Lenovo driver: snd_hda_intel
           v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20 class-ID: 0403
           Device-2: DisplayLink Kensington SD4000 USB Dock type: USB driver: cdc_ncm,snd-usb-audio
           bus-ID: 4-2.1:3 chip-ID: 17e9:4344 class-ID: 0a00 serial: <filter>
           Sound Server-1: ALSA v: k5.14.8-zen1-1-zen running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: no
           Sound Server-4: PipeWire v: 0.3.38 running: yes
Network:   Message: No device data found.
           IF-ID-1: enp0s20u2u1i5 state: up speed: 100 Mbps duplex: half mac: <filter>
           IF-ID-2: vmnet1 state: unknown speed: N/A duplex: N/A mac: <filter>
           IF-ID-3: vmnet8 state: unknown speed: N/A duplex: N/A mac: <filter>
           IF-ID-4: wlp0s26u1u4i2 state: down mac: <filter>
Bluetooth: Device-1: Realtek RTL8723AU 802.11n WLAN Adapter type: USB driver: btusb,rtl8723au bus-ID: 1-1.4:4
           chip-ID: 0bda:1724 class-ID: e001 serial: <filter>
           Report: bt-adapter ID: hci0 rfk-id: 0 state: down bt-service: enabled,running rfk-block:
           hardware: no software: yes address: <filter>
Drives:    Local Storage: total: 1.14 TiB used: 446.58 GiB (38.2%)
           SMART Message: Unable to run smartctl. Root privileges required.
           ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: MZMTD256HAGM-000L1 size: 238.47 GiB block-size:
           physical: 512 B logical: 512 B speed: 3.0 Gb/s type: SSD serial: <filter> rev: 2L0Q scheme: GPT
           ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Western Digital model: WD My Passport 0820
           size: 931.48 GiB block-size: physical: 512 B logical: 512 B type: N/A serial: <filter> rev: 1007
           scheme: GPT
Partition: ID-1: / raw-size: 922.42 GiB size: 922.42 GiB (100.00%) used: 251.45 GiB (27.3%) fs: btrfs
           dev: /dev/sdb2 maj-min: 8:18
           ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.45%) used: 562 KiB (0.2%) fs: vfat
           dev: /dev/sdb1 maj-min: 8:17
           ID-3: /home raw-size: 922.42 GiB size: 922.42 GiB (100.00%) used: 251.45 GiB (27.3%) fs: btrfs
           dev: /dev/sdb2 maj-min: 8:18
           ID-4: /var/log raw-size: 922.42 GiB size: 922.42 GiB (100.00%) used: 251.45 GiB (27.3%) fs: btrfs
           dev: /dev/sdb2 maj-min: 8:18
           ID-5: /var/tmp raw-size: 922.42 GiB size: 922.42 GiB (100.00%) used: 251.45 GiB (27.3%) fs: btrfs
           dev: /dev/sdb2 maj-min: 8:18
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
           ID-1: swap-1 type: zram size: 7.64 GiB used: 2.85 GiB (37.3%) priority: 100 dev: /dev/zram0
           ID-2: swap-2 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sdb3
           maj-min: 8:19
Sensors:   System Temperatures: cpu: 55.0 C mobo: N/A
           Fan Speeds (RPM): N/A
Info:      Processes: 298 Uptime: 2h 56m wakeups: 1 Memory: 7.64 GiB used: 6 GiB (78.5%) Init: systemd v: 249
           tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: 1785 pacman: 1776 lib: 537 flatpak: 9
           Shell: Zsh v: 5.8 running-in: alacritty inxi: 3.3.06

Anyone have any ideas how to fix this? Thanks in advance!

Really strange! Everything seems to be fine for me, on a similar configuration.
The only suggestion I can think of is try reinstalling Dolphin, since the problem doesn't seem to be on the Window Appmenu widget side...
Here, it seems to have been a problem in a previous version (I have 21.08.1-1):

1 Like

Thanks, just tried renaming the dolphinrc file to see if it was that. No change. Reinstalled Dolphin - didn't fix it either.

So weird. I didn't modify the theme in any way, so not sure how this could have happened. I mean, it's annoying, but still functional....hopefully it'll automagically get fixed in another update - unless someone knows how to fix this :smiley: lol

EDIT: I just noticed that the hamburger menu ALSO displays "No text" when I click on "For 26 more actions" it opens a side-menu, with all "No text" then the last option shows "Settings". So weird..... don't know where to even begin troubleshooting this....

2 Likes

Went to submit a bug to bugs.kde.org and discovered a similar issue with Okular that someone submitted: 387673 – menu headings corrupt, showing "no text"

I did, in fact, configure the dolphin toolbar, but then reverted the changes, but it seemed to have permanently broken this menu display.

Ok, kinda figured out how to fix it. Found in an old reddit thread, that there's a separate file that manages the toolbar located here: ~/.local/share/kxmlgui5/[kde application] in my case it was ~/.local/share/kxmlgui5/dolphin/dolphinui.rc which I backed up and then deleted the dolphinui.rc file and re-ran dolphin and now the menubar appears with the proper heading labels.

This feels like a bizarre issue, as we should be able to modify the toolbar without losing the menu headings.

1 Like

I marked it as solved.
A solution, bizarre but solution :wink:
And a good catch indeed!

1 Like

I mean, I wouldn't call this a solution - it's really just a reset. If one configures their toolbar to anything other than the default toolbar config, this is what happens to the menu heading labels. I can confirm this occurs in Okular as well. Haven't tested other KDE apps, but this seems to be a running issue. Anyone else can confirm a similar issue?

1 Like

I tried to play around a little bit with the toolbars of Dolphin and Okular but the issue didn't occur here.
Never mind, at least we have a workaround for those who might run into the problem in the future.

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.