Dolphin not asking what to do with an executable

Greetings you all!

Just yesterday I switched fully to Garuda from ZorinOS. I am really happy with the performance and the looks are just amazing. I just have one problem at the moment. I put 2 .sh files on my desktop to connect and disconnect from my companies VPN. I already changed the setting in Dolphin that it should ask me what to do with executable files and set it to "Always ask". I also checked the setting in ~/.config/kiorc which is also set to "alwaysAsk". I am out of ideas what to do next, so it asks me what to do when I double click on these files. At the moment they just execute when I double click on them.

Thank you very much for your help!

1 Like

Welcome to Garuda forum :slight_smile:

I am opposit :wink: if I double click I want be asked.

If the system dont like your settings use

for yes / no action.


It seems like the Dolphin setting to Always Ask is not applying to files on the desktop, but it works in folders opened with Dolphin, including the desktop folder. If it's the same for you then you can place the scripts in a folder on your desktop as a workaround.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.