Dolphin Administrator-Action "Open in File-Explorer" does not work

Hey :),

Hi i have a small issue with the Administrator Action "Open in File-Explorer" in Dolphin. It does basically nothing.

This gif demonstates what i mean:

inxi -Faz
inxi -Faz
System:    Kernel: 5.15.6-zen2-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=c7830645-81ec-4575-b78e-6054ff59983c
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 resume=UUID=c1d80959-5bb6-44ff-9bff-7d85ab6c3145 loglevel=3
Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: Acer product: Aspire A515-44 v: V1.12 serial: <superuser required>
Mobo: RO model: Calla_RN v: V1.12 serial: <superuser required> UEFI: INSYDE v: 1.12
date: 03/15/2021
Battery:   ID-1: BAT1 charge: 37.1 Wh (78.4%) condition: 47.3/53.0 Wh (89.3%) volts: 15.5 min: 15.4
model: PANASONIC AP19B5L type: Li-ion serial: <filter> status: Discharging
CPU:       Info: 8-Core model: AMD Ryzen 7 4700U with Radeon Graphics bits: 64 type: MCP arch: Zen 2
family: 17 (23) model-id: 60 (96) stepping: 1 microcode: 8600103 cache: L1: 512 KiB L2: 4 MiB
L3: 8 MiB
flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 31940
Speed: 1397 MHz min/max: 1400/2000 MHz boost: enabled Core speeds (MHz): 1: 1397 2: 1397
3: 1397 4: 1397 5: 1397 6: 1397 7: 1397 8: 1397
Vulnerabilities: Type: itlb_multihit status: Not affected
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP: disabled, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: AMD Renoir vendor: Acer Incorporated ALI driver: amdgpu v: kernel bus-ID: 05:00.0
chip-ID: 1002:1636 class-ID: 0300
Device-2: Quanta HD User Facing type: USB driver: uvcvideo bus-ID: 3-4:2 chip-ID: 0408:a061
class-ID: 0e02
Display: x11 server: X.Org 1.21.1.1 compositor: kwin_x11 driver: loaded: amdgpu,ati
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") s-diag: 582mm (22.9")
Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 142 size: 344x193mm (13.5x7.6") diag: 394mm (15.5")
OpenGL: renderer: AMD RENOIR (DRM 3.42.0 5.15.6-zen2-1-zen LLVM 13.0.0) v: 4.6 Mesa 21.2.5
direct render: Yes
Audio:     Device-1: AMD vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel bus-ID: 05:00.1
chip-ID: 1002:1637 class-ID: 0403
Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Acer Incorporated ALI
driver: N/A alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x bus-ID: 05:00.5
chip-ID: 1022:15e2 class-ID: 0480
Device-3: AMD Family 17h HD Audio vendor: Acer Incorporated ALI driver: snd_hda_intel v: kernel
bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403
Sound Server-1: ALSA v: k5.15.6-zen2-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Acer Incorporated ALI
driver: r8169 v: kernel port: 2000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp3s0 state: down mac: <filter>
Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter vendor: Lite-On
driver: ath10k_pci v: kernel bus-ID: 04:00.0 chip-ID: 168c:003e class-ID: 0280
IF: wlp4s0 state: up mac: <filter>
Bluetooth: Device-1: Lite-On type: USB driver: btusb v: 0.8 bus-ID: 1-3:2 chip-ID: 04ca:3016
class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 2 state: down bt-service: enabled,running rfk-block:
hardware: no software: yes address: <filter>
Drives:    Local Storage: total: 942.7 GiB used: 352.61 GiB (37.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN520 SDAPNUW-512G-1014
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 15.8 Gb/s lanes: 2 type: SSD
serial: <filter> rev: 20110000 temp: 65.8 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Seagate model: ST500LM000-SSHD-8GB size: 465.76 GiB
block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400
serial: <filter> rev: LVD3 scheme: GPT
Partition: ID-1: / raw-size: 467.88 GiB size: 467.88 GiB (100.00%) used: 352.61 GiB (75.4%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 256 MiB size: 252 MiB (98.46%) used: 547 KiB (0.2%) fs: vfat
dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 467.88 GiB size: 467.88 GiB (100.00%) used: 352.61 GiB (75.4%) fs: btrfs
dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 467.88 GiB size: 467.88 GiB (100.00%) used: 352.61 GiB (75.4%)
fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 467.88 GiB size: 467.88 GiB (100.00%) used: 352.61 GiB (75.4%)
fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p3
maj-min: 259:3
ID-2: swap-2 type: zram size: 18.98 GiB used: 4.43 GiB (23.4%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 55.0 C mobo: N/A gpu: amdgpu temp: 54.0 C
Fan Speeds (RPM): N/A
Info:      Processes: 353 Uptime: 38m wakeups: 1 Memory: 18.98 GiB used: 6.08 GiB (32.1%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: 1984 pacman: 1975
lib: 488 snap: 9 Shell: fish v: 3.3.1 running-in: konsole inxi: 3.3.09

That's not a bug, it's a KDE feature. :grinning:

4 Likes

FWIW, working fine for me on Dolphin 21.08.3-1 & rootactions 2.7.3-1 using English(GB).

1 Like

It is a feature that dolphin does not open up when i want to open it as administrator?

He's joking ;p

Hi there, this is not Garuda specific issue, but a general dolphin bug. This has been already solved in KDE forums.
https://forum.kde.org/viewtopic.php?f=289&t=173301&p=450557&hilit=Dolphin+root#p450557

I hope this solves your issue.

4 Likes

Hi @Naman sorry i dont understand how i can fix that issue now. In the KDE Forum he only says that he installed the open as root extension

From link
I first added "open as root" service to dolphin (didn't know it exists),

2 Likes

Dolphin is not made to be used as root.

Maybe, you should use other like thunar as in above example.
Or ask on KDE forums.

1 Like

Midnight Commander is an excellent TUI dual pane terminal based file explorer (with mouse support) capable of operating as root. If you need to operate as root, using a terminal based app is far safer IMO. MC will save your bacon if your GUI becomes unusable for whatever reason. I highly recommend learning to use Midnight Commander on Linux for root operations.

5 Likes

@Naman ok thank you.

This topic has been covered endless times since dolphin devs decided to remove root capabilities from their file explorer.

Time for topic to be put to bed.