Doesn't boot Garuda Dragonized with 5.10.4 kernel

Hi everyone, I have a problem with Garuda Dragonized Gaming 2021.01. Practically once flashed the ISO with balenaEtcher, I insert the USB Stick in my PC and the Live CD does not start. I have found that this happens with all distros (including Debian, Ubuntu, openSUSE and other Arch) that have a Kernel 5.10 or higher.
Kali Linux with Kernel 5.9.1 works, so how can I get an old version of Garuda with kernel 5.9 or earlier?
Thanks a lot and in any case your distro is beautiful and always updated. Happy 2021...

1 Like

Disable secure boot.

Use dd to burn the ISO.

Double check the ISO is not corrupt.


Therefore this is not a Garuda issue - something about your hardware does not like kernel 5.10, so it will be worth finding the root cause rather than asking the Garuda developers to make a special effort just for your system.


Hello! My BIOS has Secure Boot disabled by default. I just tried to use dd to flash the ISO to USB but it still doesn't work. So I think as @jonathon says the problem is in my hardware that doesn't like the 5.10 kernel that Linus Torvalds released. How can I request an old release from the Garuda developers?

Excuse me a lot, being Italian I didn't read that well. I will try to save to buy a notebook with newer hardware and will be using other distros for now. bye bye


I believe the barebones editions use the older LTS kernel (or at least they did before).

1 Like