Dock getting stuck on top of windows periodically

I have been having an issue with the dock where occasionally the dock will be stuck on top of windows. This problem is never happening immediately after login but usually crops up within 30 minutes to an hour of use and can last for just a few minutes or until I get annoyed or hampered enough that I have to logout or restart to fix it. I have not been able to establish a pattern of what causes it to start happening or stop happening, the only guaranteed fix is to logout and sometimes it just comes back very shortly so this is not a real solution. I have also noted that it doesn’t affect full screen applications, I can press F11 in my browser to work around it, but that is not useful for all applications.

I am using the default settings (Windows can cover), and have also tried setting to auto hide. Neither setting seems to have an effect. The problem started happening ever since latte was dropped (understandably). After the first few months of dealing with it I thought maybe a fresh install would fix the problem since I have not seen much discussion about it being a widespread issue, but I see the same behavior on a fresh install. I have tried to tolerate it, but it has gotten to the point of interfering with my productivity (it blocks me from interacting with UI elements that are behind the dock).

garuda-inxi output:

  Kernel: 6.5.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=9dd7ed09-2e24-4a95-868d-b4421ac61afa rw rootflags=subvol=@
    quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=514e3bad-83ef-467f-9a61-2969d7eba865 loglevel=3 ibt=off
  Desktop: KDE Plasma v: 5.27.8 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
    dm: SDDM Distro: Garuda Linux base: Arch Linux
  Type: Desktop System: Gigabyte product: Z390 AORUS ULTRA v: N/A
    serial: <superuser required>
  Mobo: Gigabyte model: Z390 AORUS ULTRA-CF v: x.x
    serial: <superuser required> UEFI: American Megatrends v: F10h
    date: 01/19/2021
  Info: model: Intel Core i7-9700K bits: 64 type: MCP arch: Coffee Lake
    gen: core 9 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 0xC (12) microcode: 0xF4
  Topology: cpus: 1x cores: 8 smt: <unsupported> cache: L1: 512 KiB
    desc: d-8x32 KiB; i-8x32 KiB L2: 2 MiB desc: 8x256 KiB L3: 12 MiB
    desc: 1x12 MiB
  Speed (MHz): avg: 800 min/max: 800/4900 scaling: driver: intel_pstate
    governor: powersave cores: 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800
    8: 800 bogomips: 57600
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
  Device-1: NVIDIA TU104 [GeForce RTX 2080 Rev. A] vendor: Gigabyte
    driver: nvidia v: 535.113.01 alternate: nouveau,nvidia_drm non-free: 535.xx+
    status: current (as of 2023-09) arch: Turing code: TUxxx
    process: TSMC 12nm FF built: 2018-22 pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.0 chip-ID: 10de:1e87 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.2.1
    compositor: kwin_x11 driver: X: loaded: modesetting,nvidia
    alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 5120x1440 s-dpi: 108 s-size: 1204x342mm (47.40x13.46")
    s-diag: 1252mm (49.28")
  Monitor-1: DP-4 pos: primary,left res: 2560x1440 dpi: 109
    size: 598x336mm (23.54x13.23") diag: 686mm (27.01") modes: N/A
  Monitor-2: HDMI-0 pos: right res: 2560x1440 hz: 60 dpi: 109
    size: 597x336mm (23.5x13.23") diag: 685mm (26.97") modes: N/A
  Monitor-3: None-1-1 size-res: N/A modes: N/A
  API: EGL v: 1.5 hw: drv: nvidia platforms: gbm: drv: nvidia
  API: OpenGL v: 4.6.0 vendor: nvidia v: 535.113.01 glx-v: 1.4
    direct-render: yes renderer: NVIDIA GeForce RTX 2080/PCIe/SSE2
    memory: 7.81 GiB
  API: Vulkan v: 1.3.264 layers: 7 device: 0 type: discrete-gpu
    name: NVIDIA GeForce RTX 2080 driver: nvidia v: 535.113.01
    device-ID: 10de:1e87 surfaces: xcb,xlib
  Device-1: Intel Cannon Lake PCH cAVS vendor: Gigabyte driver: snd_hda_intel
    v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
    chip-ID: 8086:a348 class-ID: 0403
  Device-2: NVIDIA TU104 HD Audio vendor: Gigabyte driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.1
    chip-ID: 10de:10f8 class-ID: 0403
  API: ALSA v: k6.5.7-zen1-1-zen status: kernel-api tools: N/A
  Server-1: PipeWire v: 0.3.81 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Intel Cannon Lake PCH CNVi WiFi driver: iwlwifi v: kernel
    bus-ID: 00:14.3 chip-ID: 8086:a370 class-ID: 0280
  IF: wlo1 state: down mac: <filter>
  Device-2: Intel Ethernet I219-V vendor: Gigabyte driver: e1000e v: kernel
    port: N/A bus-ID: 00:1f.6 chip-ID: 8086:15bc class-ID: 0200
  IF: eno2 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-3: Microsoft Xbox Wireless Adapter for Windows driver: xone-dongle
    type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-13.1:12
    chip-ID: 045e:02e6 class-ID: 0000 serial: <filter>
  Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) driver: btusb
    v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-14:9
    chip-ID: 8087:0aaa class-ID: e001
  Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.1
    lmp-v: 10 status: discoverable: no pairing: no class-ID: 7c0104
  Local Storage: total: 10.98 TiB used: 1.16 TiB (10.6%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:6 vendor: Samsung model: SSD 970 EVO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 2B2QEXE7 temp: 26.9 C
    scheme: GPT
  ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: A-Data model: SX8200PNP
    size: 1.86 TiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 tech: SSD serial: <filter> fw-rev: 32B3T8EA temp: 32.9 C
    scheme: GPT
  ID-3: /dev/nvme2n1 maj-min: 259:5 vendor: Samsung model: SSD 980 PRO with
    Heatsink 2TB size: 1.82 TiB block-size: physical: 512 B logical: 512 B
    speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter> fw-rev: 4B2QGXA7
    temp: 36.9 C scheme: GPT
  ID-4: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 PRO 1TB
    size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: <filter> fw-rev: 2B6Q scheme: GPT
  ID-5: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WD60EZRX-00MVLB1 size: 5.46 TiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 5700 serial: <filter>
    fw-rev: 0A80 scheme: GPT
  ID-1: / raw-size: 1.79 TiB size: 1.79 TiB (100.00%) used: 1.16 TiB (65.1%)
    fs: btrfs dev: /dev/nvme2n1p2 maj-min: 259:8
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 580 KiB (0.2%) fs: vfat dev: /dev/nvme2n1p1 maj-min: 259:7
  ID-3: /home raw-size: 1.79 TiB size: 1.79 TiB (100.00%)
    used: 1.16 TiB (65.1%) fs: btrfs dev: /dev/nvme2n1p2 maj-min: 259:8
  ID-4: /var/log raw-size: 1.79 TiB size: 1.79 TiB (100.00%)
    used: 1.16 TiB (65.1%) fs: btrfs dev: /dev/nvme2n1p2 maj-min: 259:8
  ID-5: /var/tmp raw-size: 1.79 TiB size: 1.79 TiB (100.00%)
    used: 1.16 TiB (65.1%) fs: btrfs dev: /dev/nvme2n1p2 maj-min: 259:8
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: partition size: 34.41 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme2n1p3 maj-min: 259:9
  ID-2: swap-2 type: zram size: 31.28 GiB used: 768 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8 dev: /dev/zram0
  System Temperatures: cpu: 34.0 C pch: 50.0 C mobo: N/A gpu: nvidia
    temp: 53 C
  Fan Speeds (rpm): cpu: 0 fan-2: 0 fan-3: 0 gpu: nvidia fan: 0%
  Power: 12v: N/A 5v: N/A 3.3v: 3.36 vbat: 3.23
  Processes: 298 Uptime: 3h 4m wakeups: 54 Memory: total: 32 GiB
  available: 31.28 GiB used: 9.06 GiB (29.0%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 alt: 12
  clang: 16.0.6 Packages: pm: pacman pkgs: 1684 libs: 470
  tools: octopi,pamac,paru Shell: Zsh v: 5.9 running-in: tilix inxi: 3.3.30
Garuda (2.6.17-1):
  System install date:     2023-08-14
  Last full system update: 2023-10-14
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut nvidia-dkms
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:

We understand and knew Plasma Panel wasn’t perfect when we made the swap.

Your issue seems to be pretty similar to what he mentions here Further issues with the ISO

This type of issue is Plasma related and as a first action I would suggest looking for opened bugs at, as a second action to open one yourself.

Also keep in mind there are huge changes to the Plasma Panels coming up in Plasma 6, it is possible this issue would be fixed then. Having an official bug opened would probably help.


Oddly enough I am having the same problem on Windows where taskbar auto-hide has been variously broken for years and comes on top of windows. KDE did a good imitation :thinking:

1 Like

Thanks, I will take a look over there, I think the main difference in the linked thread is that my issue doesn’t seem to be related to specific apps. It is either happening to all applications or no applications and just changes between the 2 states with no logic that I can discern.

1 Like

If it’s a bug, sometimes it doesn’t exactly behave the same from one system to another, but you are correct it could be something different; it could be a second bug related to the same or close root cause. Anything is possible when bugs occur. :smiley:

Did you try Wayland?

1 Like

If you listen around 12m05s, he says KDE dev had to remove Windows Go Below and that he’s bringing it back in Plasma 6.

Maybe that could be related to your issue, but for sure there was something going on with this type of feature (go below, go on top, it’s all similar).

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.