Dock and topbar not present

╰─λ inxi -Fax
System:    Host: guruthecoder-archbtw Kernel: 5.15.5-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=0b9acb98-533d-4f83-8efd-2b67f9bca6bc
rw [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
systemd.unified_cgroup_hierarchy=1 resume=UUID=761face9-a6dc-4ddf-b0d6-c1acb9312ec1 loglevel=3
Desktop: KDE Plasma 5.23.3 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM
Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: Hewlett-Packard product: HP Pavilion g6 Notebook PC
v: 0879110000385D10000610100 serial: <superuser required> Chassis: type: 10
serial: <superuser required>
Mobo: Hewlett-Packard model: 183F v: 56.2C serial: <superuser required> UEFI: Insyde v: F.12
date: 08/30/2012
Battery:   ID-1: BAT0 charge: 11.8 Wh (100.0%) condition: 11.8/11.8 Wh (100.0%) volts: 12.6 min: 10.8
model: Hewlett-Packard Primary type: Li-ion serial: N/A status: Charging
CPU:       Info: Dual Core model: Intel Core i3-3110M bits: 64 type: MT MCP arch: Ivy Bridge family: 6
model-id: 3A (58) stepping: 9 microcode: 21 cache: L1: 128 KiB L2: 512 KiB L3: 3 MiB
flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 19156
Speed: 2016 MHz min/max: 1200/2400 MHz Core speeds (MHz): 1: 2016 2: 2377 3: 2379 4: 2395
Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported
Type: l1tf mitigation: PTE Inversion
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
Type: srbds status: Not affected
Type: tsx_async_abort status: Not affected
Graphics:  Device-1: Intel 3rd Gen Core processor Graphics vendor: Hewlett-Packard driver: i915 v: kernel
bus-ID: 00:02.0 chip-ID: 8086:0166 class-ID: 0300
Device-2: Suyin HP TrueVision HD Integrated Webcam type: USB driver: uvcvideo bus-ID: 2-1.5:3
chip-ID: 064e:e263 class-ID: 0e02 serial: HF1016-T821-SE01-VH-R01.00.05
Display: x11 server: X.Org compositor: kwin_x11 driver: loaded: intel
unloaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.2x8.0") s-diag: 414mm (16.3")
Monitor-1: LVDS1 res: 1366x768 hz: 60 dpi: 102 size: 340x190mm (13.4x7.5") diag: 389mm (15.3")
Message: Unable to show advanced data. Required tool glxinfo missing.
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20 class-ID: 0403
Sound Server-1: ALSA v: k5.15.5-zen1-1-zen running: yes
Sound Server-2: JACK v: 1.9.19 running: no
Sound Server-3: PulseAudio v: 15.0 running: no
Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Ralink RT3290 Wireless 802.11n 1T/1R PCIe vendor: Hewlett-Packard driver: rt2800pci
v: 2.3.0 bus-ID: 01:00.0 chip-ID: 1814:3290 class-ID: 0280
IF: wlo1 state: up mac: 08:3e:8e:71:51:ab
Device-2: Realtek RTL810xE PCI Express Fast Ethernet vendor: Hewlett-Packard driver: r8169
v: kernel port: 3000 bus-ID: 02:00.0 chip-ID: 10ec:8136 class-ID: 0200
IF: eno1 state: down mac: 28:92:4a:47:6b:bd
Bluetooth: Device-1: Ralink RT3290 Bluetooth vendor: Hewlett-Packard driver: N/A bus-ID: 01:00.1
chip-ID: 1814:3298 class-ID: 0d11
Report: bt-service: enabled,stopped note: tool can't run
Drives:    Local Storage: total: 465.76 GiB used: 15.45 GiB (3.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST500LM012 HN-M500MBB size: 465.76 GiB
block-size: physical: 4096 B logical: 512 B speed: 3.0 Gb/s type: HDD rpm: 5400
serial: S2SVJ9DC560800 rev: 0002 scheme: GPT
Partition: ID-1: / raw-size: 452.72 GiB size: 452.72 GiB (100.00%) used: 15.45 GiB (3.4%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 576 KiB (0.2%) fs: vfat
dev: /dev/sda1 maj-min: 8:1
ID-3: /home raw-size: 452.72 GiB size: 452.72 GiB (100.00%) used: 15.45 GiB (3.4%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-4: /var/log raw-size: 452.72 GiB size: 452.72 GiB (100.00%) used: 15.45 GiB (3.4%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
ID-5: /var/tmp raw-size: 452.72 GiB size: 452.72 GiB (100.00%) used: 15.45 GiB (3.4%) fs: btrfs
dev: /dev/sda2 maj-min: 8:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 11.58 GiB used: 2.2 MiB (0.0%) priority: 100 dev: /dev/zram0
ID-2: swap-2 type: partition size: 12.74 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sda3
maj-min: 8:3
Sensors:   System Temperatures: cpu: 63.0 C mobo: N/A
Fan Speeds (RPM): N/A
Info:      Processes: 205 Uptime: 7m wakeups: 2 Memory: 11.58 GiB used: 2.74 GiB (23.7%) Init: systemd
v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: pacman: 1185 lib: 295
Shell: fish v: 3.3.1 default: Bash v: 5.1.12 running-in: konsole inxi: 3.3.09

I opened up my laptop and there isn't a taskbar or a topbar. There's just my Desktop. I can access the terminal by pressing ctr+alt+t . I opened up firedragon to make this post using the terminal. But I can't access my apps as I normally would. I don't even know what settings is called in the terminal.

Report everything you have already attempted to solve your problem.

I've tried :-

  1. Logging out and then logging back in
  2. Restarting

Thank you very much :slightly_smiling_face:

I'm real rusty on my KDE but you can double tap tab to sus this out but the settings should be something like systemsettings5 iirc (fired up a VM to check, yup that's the command.)

1 Like

Hi there, welcome!
Open Krunner (normally shortcuts could be alt+space or alt+F2) and launch Garuda Assistant. From there, reset default settings for latte (flag). Maybe flag also something else if you want.
Then, to logoff or reboot you can right-click on the desktop and select Leave.
If for whatever reason Krunner doesn't start, launch garuda-assistant from the terminal (disregard some error messages there).
Last option, right-click on desktop, add widget and add a menu widget: from there you'll be able to launch Garuda Assistant.


Does latte-dock launch from Terminal?
What's the error?

There is no dock and topbar.

No. Like, everything was fine ; after I restarted, the topbar and the dock disappeared. I don't really know how. I don't know what caused it.

I can't find latte there.

Alt + Space, type latte-dock and press enter.



Wow it worked!!
Thank you so much! Your the best.

Sry for being so ignorant. Thanks a lot.

1 Like

You're very welcome, but the best is the developer who implemented this, or the one who thought of this option... :wink:

1 Like

Remember to export your latte config if you customize it at all so you can restore YOUR settings if there's a problem again.

Right click Latte (dock or panel) -> Layouts -> Edit Layouts -> Export (bottom right) -> Export for Backup.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.