Difficulty installing leetmouse

Hello, I’m a Linux noob who is trying out Linux after being a Windows user for pretty much my whole life. I am trying to set up a custom acceleration curve for my mouse after having gotten used to using Raw Accel on Windows. (This is for gaming if that wasn’t obvious already.)

I came across this program which seems to be the nearest available equivalent to Raw Accel on Linux: AUR (en) - leetmouse-driver-dkms

Attempting to install it through both the instructions on the Git page and through the AUR both seem to encounter similar errors.

makepkg -s -i -r -c
==> Making package: leetmouse-driver-dkms 0.9.0-1 (Tue 28 Nov 2023 09:00:47 PM CST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Cloning leetmouse-driver-dkms git repo...
Cloning into bare repository '/home/aidan/AUR/leetmouse-driver-dkms/leetmouse-driver-dkms'...
remote: Enumerating objects: 473, done.
remote: Counting objects: 100% (91/91), done.
remote: Compressing objects: 100% (15/15), done.
remote: Total 473 (delta 84), reused 76 (delta 76), pack-reused 382
Receiving objects: 100% (473/473), 145.00 KiB | 951.00 KiB/s, done.
Resolving deltas: 100% (276/276), done.
-> Found leetmouse-driver-dkms.install
==> Validating source files with sha256sums...
leetmouse-driver-dkms ... Skipped
leetmouse-driver-dkms.install ... Passed
==> Extracting sources...
-> Creating working copy of leetmouse-driver-dkms git repo...
Cloning into 'leetmouse-driver-dkms'...
done.
==> Entering fakeroot environment...
==> Starting package()...
install: creating directory '/home/aidan/AUR/leetmouse-driver-dkms/pkg/leetmouse-driver-dkms/usr/src/leetmouse-driver-0.9.0'
'Makefile' -> '/home/aidan/AUR/leetmouse-driver-dkms/pkg/leetmouse-driver-dkms/usr/src/leetmouse-driver-0.9.0/Makefile'
'install_files/dkms/dkms.conf' -> '/home/aidan/AUR/leetmouse-driver-dkms/pkg/leetmouse-driver-dkms/usr/src/leetmouse-driver-0.9.0/dkms.conf'
install: creating directory '/home/aidan/AUR/leetmouse-driver-dkms/pkg/leetmouse-driver-dkms/usr/src/leetmouse-driver-0.9.0/driver'
'driver/Makefile' -> '/home/aidan/AUR/leetmouse-driver-dkms/pkg/leetmouse-driver-dkms/usr/src/leetmouse-driver-0.9.0/driver/Makefile'
'driver/accel.c' -> '/home/aidan/AUR/leetmouse-driver-dkms/pkg/leetmouse-driver-dkms/usr/src/leetmouse-driver-0.9.0/driver/accel.c'
'driver/usbmouse.c' -> '/home/aidan/AUR/leetmouse-driver-dkms/pkg/leetmouse-driver-dkms/usr/src/leetmouse-driver-0.9.0/driver/usbmouse.c'
'driver/util.c' -> '/home/aidan/AUR/leetmouse-driver-dkms/pkg/leetmouse-driver-dkms/usr/src/leetmouse-driver-0.9.0/driver/util.c'
'driver/accel.h' -> '/home/aidan/AUR/leetmouse-driver-dkms/pkg/leetmouse-driver-dkms/usr/src/leetmouse-driver-0.9.0/driver/accel.h'
'driver/config.sample.h' -> '/home/aidan/AUR/leetmouse-driver-dkms/pkg/leetmouse-driver-dkms/usr/src/leetmouse-driver-0.9.0/driver/config.sample.h'
'driver/float.h' -> '/home/aidan/AUR/leetmouse-driver-dkms/pkg/leetmouse-driver-dkms/usr/src/leetmouse-driver-0.9.0/driver/float.h'
'driver/util.h' -> '/home/aidan/AUR/leetmouse-driver-dkms/pkg/leetmouse-driver-dkms/usr/src/leetmouse-driver-0.9.0/driver/util.h'
==> Tidying install...
-> Removing libtool files...
-> Purging unwanted files...
-> Removing static library files...
-> Stripping unneeded symbols from binaries and libraries...
-> Compressing man and info pages...
==> Checking for packaging issues...
==> Creating package "leetmouse-driver-dkms"...
-> Generating .PKGINFO file...
-> Generating .BUILDINFO file...
-> Adding install file...
-> Generating .MTREE file...
-> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: leetmouse-driver-dkms 0.9.0-1 (Tue 28 Nov 2023 09:00:51 PM CST)
==> Installing package leetmouse-driver-dkms with pacman -U...
[sudo] password for aidan:
loading packages...
resolving dependencies...
looking for conflicting packages...

Package (1)            New Version  Net Change

leetmouse-driver-dkms  0.9.0-1        0.05 MiB

Total Installed Size:  0.05 MiB

:: Proceed with installation? [Y/n] y
(1/1) checking keys in keyring                                     [------------------------------------] 100%
(1/1) checking package integrity                                   [------------------------------------] 100%
(1/1) loading package files                                        [------------------------------------] 100%
(1/1) checking for file conflicts                                  [------------------------------------] 100%
(1/1) checking available disk space                                [------------------------------------] 100%
:: Running pre-transaction hooks...
(1/1) Performing snapper pre snapshots for the following configurations...
==> root: 37
:: Processing package changes...
(1/1) installing leetmouse-driver-dkms                             [------------------------------------] 100%
:: Running post-transaction hooks...
( 1/10) Reloading device manager configuration...
Timed out for waiting the udev queue being empty.
error: command failed to execute correctly
( 2/10) Arming ConditionNeedsUpdate...
( 3/10) Install DKMS modules
==> dkms install --no-depmod leetmouse-driver/0.9.0 -k 6.6.2-zen1-1-zen
==> depmod 6.6.2-zen1-1-zen
==> ERROR: Missing 6.6.2-arch1-1 kernel modules tree for module leetmouse-driver/0.9.0.
( 4/10) Updating initramfs...
:: Building initramfs for linux-zen (6.6.2-zen1-1-zen)
:: Building fallback initramfs for linux-zen (6.6.2-zen1-1-zen)
( 5/10) Updating linux initcpios...
( 6/10) Foreign/AUR package notification
leetmouse-driver-dkms 0.9.0-1
( 7/10) Orphaned package notification...
kdsoap-ws-discovery-client 0.3.0-2
libinput-gestures-qt 0.4-1
wayland-protocols 1.32-1
( 8/10) Checking for .pacnew and .pacsave files...
( 9/10) Performing snapper post snapshots for the following configurations...
==> root: 38
(10/10) Syncing all file systems...
==> Cleaning up...

Here is my output from garuda-inxi:

System:
Kernel: 6.6.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=0c56ec49-20ad-4aa0-a88b-55b47e733bc9 rw rootflags=subvol=@
quiet rd.luks.uuid=d79b9435-2941-4ab1-b7b1-6436232809f7
rd.luks.uuid=49c27010-0fe7-452f-b43e-2b305ff69240
resume=/dev/mapper/luks-49c27010-0fe7-452f-b43e-2b305ff69240 loglevel=3
ibt=off
Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_wayland vt: 1
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: ASRock model: 970M Pro3 serial: <superuser required>
UEFI-[Legacy]: American Megatrends v: P1.50 date: 01/11/2016
CPU:
Info: model: AMD FX-4350 bits: 64 type: MT MCP arch: Piledriver level: v2
built: 2012-13 process: GF 32nm family: 0x15 (21) model-id: 2 stepping: 0
microcode: 0x6000852
Topology: cpus: 1x cores: 4 smt: enabled cache: L1: 192 KiB
desc: d-4x16 KiB; i-2x64 KiB L2: 4 MiB desc: 2x2 MiB L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 1560 high: 2000 min/max: 1400/4200 boost: enabled
scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1400 2: 1400
3: 2000 4: 1443 bogomips: 33526
Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: AMD Baffin [Radeon RX 460/560D / Pro
450/455/460/555/555X/560/560X] vendor: Tul / PowerColor driver: amdgpu
v: kernel arch: GCN-4 code: Arctic Islands process: GF 14nm built: 2016-20
pcie: gen: 2 speed: 5 GT/s lanes: 8 link-max: gen: 3 speed: 8 GT/s ports:
active: HDMI-A-1 empty: DP-1,DVI-D-1 bus-ID: 01:00.0 chip-ID: 1002:67ef
class-ID: 0300 temp: 46.0 C
Display: wayland server: X.org v: 1.21.1.9 with: Xwayland v: 23.2.2
compositor: kwin_wayland driver: X: loaded: amdgpu
unloaded: modesetting,radeon alternate: fbdev,vesa dri: radeonsi
gpu: amdgpu display-ID: 0
Monitor-1: HDMI-A-1 res: 1920x1080 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: amd radeonsi platforms: device: 0 drv: radeonsi
device: 1 drv: swrast surfaceless: drv: radeonsi wayland: drv: radeonsi x11:
drv: radeonsi inactive: gbm
API: OpenGL v: 4.6 compat-v: 4.5 vendor: amd mesa v: 23.2.1-arch1.2
glx-v: 1.4 direct-render: yes renderer: AMD Radeon RX 560 Series (polaris11
LLVM 16.0.6 DRM 3.54 6.6.2-zen1-1-zen) device-ID: 1002:67ef
memory: 3.91 GiB unified: no display-ID: :1.0
API: Vulkan v: 1.3.269 layers: 13 device: 0 type: discrete-gpu name: AMD
Radeon RX 560 Series (RADV POLARIS11) driver: mesa radv v: 23.2.1-arch1.2
device-ID: 1002:67ef surfaces: xcb,xlib,wayland device: 1 type: cpu
name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe
v: 23.2.1-arch1.2 (LLVM 16.0.6) device-ID: 10005:0000
surfaces: xcb,xlib,wayland
Audio:
Device-1: AMD SBx00 Azalia vendor: ASRock driver: snd_hda_intel v: kernel
bus-ID: 00:14.2 chip-ID: 1002:4383 class-ID: 0403
Device-2: AMD Baffin HDMI/DP Audio [Radeon RX 550 640SP / 560/560X]
vendor: Tul / PowerColor driver: snd_hda_intel v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 8 link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.1
chip-ID: 1002:aae0 class-ID: 0403
API: ALSA v: k6.6.2-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Broadcom BCM4360 802.11ac Wireless Network Adapter driver: wl
v: kernel modules: bcma pcie: gen: 1 speed: 2.5 GT/s lanes: 1
bus-ID: 04:00.0 chip-ID: 14e4:43a0 class-ID: 0280
IF: wlp4s0 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASRock driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
port: d000 bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp5s0 state: down mac: <filter>
Bluetooth:
Device-1: TP-Link UB500 Adapter driver: btusb v: 0.8 type: USB rev: 1.1
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-4:3 chip-ID: 2357:0604
class-ID: e001 serial: <filter>
Report: btmgmt ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: <filter> bt-v: 5.1 lmp-v: 10
status: discoverable: no pairing: no
Drives:
Local Storage: total: 931.51 GiB used: 22.19 GiB (2.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 870 EVO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
tech: SSD serial: <filter> fw-rev: 3B6Q scheme: MBR
Partition:
ID-1: / raw-size: 922.71 GiB size: 922.71 GiB (100.00%)
used: 22.19 GiB (2.4%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-d79b9435-2941-4ab1-b7b1-6436232809f7
ID-2: /home raw-size: 922.71 GiB size: 922.71 GiB (100.00%)
used: 22.19 GiB (2.4%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-d79b9435-2941-4ab1-b7b1-6436232809f7
ID-3: /var/log raw-size: 922.71 GiB size: 922.71 GiB (100.00%)
used: 22.19 GiB (2.4%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-d79b9435-2941-4ab1-b7b1-6436232809f7
ID-4: /var/tmp raw-size: 922.71 GiB size: 922.71 GiB (100.00%)
used: 22.19 GiB (2.4%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
mapped: luks-d79b9435-2941-4ab1-b7b1-6436232809f7
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/dm-1 maj-min: 254:1
mapped: luks-49c27010-0fe7-452f-b43e-2b305ff69240
ID-2: swap-2 type: zram size: 7.73 GiB used: 1.46 GiB (18.9%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 10.4 C mobo: N/A gpu: amdgpu temp: 46.0 C
Fan Speeds (rpm): N/A gpu: amdgpu fan: 547
Info:
Processes: 271 Uptime: 2h 15m wakeups: 1 Memory: total: 8 GiB
available: 7.73 GiB used: 4.62 GiB (59.7%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
Packages: pm: pacman pkgs: 1978 libs: 568 tools: octopi,paru,yay Shell: fish
v: 3.6.1 running-in: konsole inxi: 3.3.31
Garuda (2.6.19-2):
System install date:     2023-11-27
Last full system update: 2023-11-28 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       <superuser required>
Failed units:

If anyone can give me any advice with this issue, it would be greatly appreciated. I’ll be happy to provide any additional information that might be needed.

Thanks.

First thing I would check which kernels are installed and make sure they all have their headers too.

2 Likes

Have you tried also with a helper?

paru leetmouse

You’ll be presented with a pkgbuild preview, skip with button q and confirm installation.

1 Like

Can a reboot be the answer ?

2 Likes

Not sure how to do that but I tried this:

pacman -Q | grep linux
archlinux-keyring 20231113-1
garuda-video-linux-config 2:1.1.6-1
lib32-util-linux 2.39.2-1
linux-api-headers 6.4-1
linux-firmware 20231110.74158e7a-1
linux-firmware-whence 20231110.74158e7a-1
linux-headers 6.6.2.arch1-1
linux-wifi-hotspot 4.6.0-1
linux-zen 6.6.2.zen1-1
linux-zen-headers 6.6.2.zen1-1
linuxconsole 1.8.1-1
util-linux 2.39.2-2
util-linux-libs 2.39.2-2

After using paru in Octopi the error in the first hook is gone but the error in the third is still there.

I’ve restarted the computer a few times now but I don’t think it’s helped.

Yes that is it.
I see there is linux-headers 6.6.2.arch1-1 but not linux 6.6.2.arch1-1.
I guess that explains why only

:: Building initramfs for linux-zen (6.6.2-zen1-1-zen)
:: Building fallback initramfs for linux-zen (6.6.2-zen1-1-zen)

and

Missing 6.6.2-arch1-1 kernel modules tree

I’d try either installing linux or removing linux-headers before trying to install leetmouse again.

Running the AUR through Octopi with both the linux and linux-headers packages already installed seemed to work, though it was hard to tell at first because the default settings for leetmouse don’t seem to add much acceleration.

Tweeking the settings through leetmouse-gui confirmed that leetmouse was working, although getting that installed and working was also a little tricky. Running
paru pysimpleguiqt
in the terminal allowed me to get it working, though that might not be the most kosher way to do it.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.