Destop Environment Switcher?

Hey guyz. I was checking out Arco Linux L Version in a VM. I love their session switcher that lets you switch between desktops. Does anyone know what does that? It's apparently the same one that's in Blackarch. I want to run KDE and Xfce to play one game that won't load in KDE. Its a pretty rockin 1st Person Space Shooter if anyone wants to check it out. But it doesn't work in KDE or Gnome....does work in Xfce and Deepin.

Are you sure it's not just Wayland? The DE shouldn't matter, but Wayland can be broken depending on your drivers (you posted no garuda-inxi :man_shrugging: ). You can run KDE or Gnome in X instead of Wayland, that might solve your problem right there.

If you still want to install an extra desktop environment, you can do so through the normal package manager and switch between installed DEs at the login screen.


Yes, that's exactly what I want. Sorry about no inxi. I didn't mean to ask a help question... more of a shoot the shit question. I'll post it in just a second (I'm on my phone now.)

 ╭─[email protected] in ~/.work took 2h29m55s
[🔴] × garuda-inxi
  Kernel: 5.16.15-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=dfacdddb-42b3-448d-ba1f-7b7b8c8f1f0c rw [email protected]
    quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
  Desktop: KDE Plasma 5.24.3 tk: Qt 5.15.3 info: latte-dock wm: kwin_x11
    vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 427639U v: ThinkPad W520
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: LENOVO model: 427639U serial: <superuser required> UEFI: LENOVO
    v: 8BET62WW (1.42 ) date: 07/26/2013
  ID-1: BAT0 charge: 64.8 Wh (98.8%) condition: 65.6/71.3 Wh (92.1%)
    volts: 12.3 min: 10.8 model: SANYO 42T4763 type: Li-ion serial: <filter>
    status: Not charging
  Info: model: Intel Core i7-2820QM bits: 64 type: MT MCP arch: Sandy Bridge
    family: 6 model-id: 0x2A (42) stepping: 7 microcode: 0x2F
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
    L3: 8 MiB desc: 1x8 MiB
  Speed (MHz): avg: 878 high: 1212 min/max: 800/3400 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 815 2: 924 3: 798
    4: 887 5: 797 6: 797 7: 1212 8: 797 bogomips: 36683
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics
    vendor: Lenovo driver: i915 v: kernel ports: active: LVDS-1 empty: VGA-1
    bus-ID: 00:02.0 chip-ID: 8086:0126 class-ID: 0300
  Device-2: NVIDIA GF108GLM [Quadro 1000M] vendor: Lenovo driver: nvidia
    v: 390.147 alternate: nouveau,nvidia_drm pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 link-max: lanes: 16 ports: active: none
    empty: DP-1, DP-2, DP-3, LVDS-2, VGA-2 bus-ID: 01:00.0 chip-ID: 10de:0dfa
    class-ID: 0300
  Device-3: Chicony Lenovo Integrated Camera (0.3MP) type: USB
    driver: uvcvideo bus-ID: 1-1.6:6 chip-ID: 04f2:b217 class-ID: 0e02
  Display: x11 server: X.Org v: compositor: kwin_x11 driver: X:
    loaded: modesetting failed: nvidia gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
    s-diag: 582mm (22.9")
  Monitor-1: LVDS-1 model: Lenovo built: 2009 res: 1920x1080 hz: 60
    dpi: 142 gamma: 1.2 size: 344x193mm (13.5x7.6") diag: 394mm (15.5")
    ratio: 16:9 modes: 1920x1080
  OpenGL: renderer: N/A v: N/A direct render: N/A
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
    vendor: Lenovo ThinkPad T520 driver: snd_hda_intel v: kernel
    bus-ID: 00:1b.0 chip-ID: 8086:1c20 class-ID: 0403
  Device-2: NVIDIA GF108 High Definition Audio vendor: Lenovo
    driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    link-max: lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:0bea class-ID: 0403
  Sound Server-1: ALSA v: k5.16.15-zen1-1-zen running: yes
  Sound Server-2: PulseAudio v: 15.0 running: no
  Sound Server-3: PipeWire v: 0.3.48 running: yes
  Device-1: Intel 82579LM Gigabit Network vendor: Lenovo ThinkPad T520
    driver: e1000e v: kernel port: 6080 bus-ID: 00:19.0 chip-ID: 8086:1502
    class-ID: 0200
  IF: enp0s25 state: down mac: <filter>
  Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 bus-ID: 03:00.0
    chip-ID: 8086:0085 class-ID: 0280
  IF: wlp3s0 state: down mac: <filter>
  Device-3: Qualcomm Atheros AR9271 802.11n type: USB driver: ath9k_htc
    bus-ID: 1-1.2:3 chip-ID: 0cf3:9271 class-ID: ff00 serial: <filter>
  IF: wlp0s26u1u2 state: up mac: <filter>
  Device-1: Broadcom BCM2045B (BDC-2.1) type: USB driver: btusb v: 0.8
    bus-ID: 1-1.4:5 chip-ID: 0a5c:217f class-ID: fe01 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 2 state: up address: <filter>
  Local Storage: total: 582.24 GiB used: 294.73 GiB (50.6%)
  ID-1: /dev/mmcblk0 maj-min: 179:0 model: SD size: 116.48 GiB block-size:
    physical: 512 B logical: 512 B type: SSD serial: <filter> scheme: GPT
  SMART Message: Unknown smartctl error. Unable to generate data.
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-2: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD5000LPCX-75VHAT1 size: 465.76 GiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
    rev: 1A05 scheme: GPT
  ID-1: / raw-size: 64 GiB size: 64 GiB (100.00%) used: 10.08 GiB (15.8%)
    fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 100 MiB size: 98.4 MiB (98.42%)
    used: 562 KiB (0.6%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 401.66 GiB size: 401.66 GiB (100.00%)
    used: 284.65 GiB (70.9%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
  ID-4: /var/log raw-size: 64 GiB size: 64 GiB (100.00%)
    used: 10.08 GiB (15.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-5: /var/tmp raw-size: 64 GiB size: 64 GiB (100.00%)
    used: 10.08 GiB (15.8%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 23.36 GiB used: 0 KiB (0.0%) priority: 100
    dev: /dev/zram0
  System Temperatures: cpu: 44.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 2546
  Processes: 287 Uptime: 8h 2m wakeups: 1 Memory: 23.36 GiB
  used: 3.14 GiB (13.5%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 clang: 13.0.1 Packages: pacman: 1290 lib: 314 Shell: fish
  v: 3.3.1 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.13
Garuda (2.5.6-2):
  System install date:     2022-03-16
  Last full system update: 2022-03-22
  Is partially upgraded:   Yes
  Relevant software:       NetworkManager
  Windows dual boot:       No/Undetected
  Snapshots:               Snapper
  Failed units:

It may be a Wayland issue, but to switch to X would cost a lot of the effects that I love so much about Garuda Dragonized, I think. I did see the xwayland solution, but my laptop is too old to try it. It uses nvidia 390xx driver. Thanks for your answer. I learned quite a bit because of it.

1 Like

Glad to hear it!

You can always use a Wayland session for your normal stuff, then log out/change the session to X/log back in to play the games that are getting broken on Wayland. That would save you having to install a hundred extra packages or whatever to have an extra DE (since KDE supports both protocols).


I'm curious about something....My KDE sessions are called something like "Plasma (X11)". Does that mean I'm already running in X?

Looking at the included garuda-inxi , it confirms your observation.

So it is running X.

I guess that means it isn't Wayland causing the issue.

Hmm...plot twist!

Are you getting an error message, or what is happening when this game is not loading?

I'm trying to think what would allow a game to load in XFCE but not KDE, but I'm stumped. Is the compositor in KDE getting disabled when you start the game?

1 Like

As BluishHumility has pointed out, the DE normally doesn't matter. You can use Alt+Shift+F12 to toggle the compositor manually in KDE before launching the game as a test. You may want to make sure you are familiar with magic sysrq, just in case.

I have one question also, the tests with XFCE, Gnome, and Deepin were all done on this laptop? Or other machine(s) you have?

It tries to set it's screen resolution and then crashes. It, on 2 other laptops, would leave the system display resolution so low after the crash that it took some work figuring out how to get the pointer to areas of the screen to get it proper again. On this laptop, though, the resolution recovers after the crash. It has a crash report box that I've sent in to the devs many times but have never gotten a response.

I've tried in multiple desktops on about 6 (maybe more) laptops, always arch based, except for Deepin, which I installed because it's known to be the most beautiful Linux, but I thought Garuda had it beat, and Garuda does have it beat. Garuda is the best looking Linux around.

Anyway, it always works in Garuda and Manjaro Xfce and never works in Garuda nor Manjaro KDE. I once installed Garuda Gnome to test it and it crashed in the same manner as in KDE.

I actually would be okay with switching sessions and I'm going to make a script to deal with some autostart issues, but I haven't been able to test it yet because the Xfce Session has no Network Setting to connect Wifi. I tried the one on the Latte Panel and it shows all the wireless networks but the Connect Buttons don't work. I tried USB tethering and had internet in a terminal, but the game said it wasn't connected and wouldn't even start to load, so I really don't even know if a 2nd Xfce session will actually work yet.

1 Like

That definitely seems to point to some conflict with KDE, my thoughts when I asked were probably long shots anyway.

I would agree with those comments on Garuda, I had it on a laptop for 3 mo, and it is now on my desktop.

I haven't used XFCE for more than an hour 3 times, so I can't even help with your current direction either. Since you mention terminal though, have you tried nmcli? If that works, you might have a start point to work back to a GUI.

1 Like

changing the desktop enviroment can cause issues but if you really want to switch try another edition of garuda linux

1 Like

Again, your comment here betrays the fact that you did not bother to read the thread.

If you can't be bothered to read more than the title of the post, it is unlikely your contribution to the discussion will be valuable or even relevant.


Just wanted to give you guys the scoop...I went back and looked in my Arco Linux VM and only the default Xfce session has the Network Settings in the System Tray. Looks like it's a Linux thing, not just a Garuda Dragonized thing. I tried DDG searching but when you mention session it seems to think I'm talking about cloud computing. I haven't found an answer yet on how to get the networking systray icon to appear other sessions than the default. I may make a new thread about it. I bet someone around here knows the answer.

1 Like

Multi-booting and multiple desktops are unsupported by Garuda.

This thread has been marked as solved, so I think we can close this out now.