Desktop screen full black with dock, wallpaper, panel all gone but still somewhat functional


Everything was working perfectly fine till yesterday night but when I booted into my Garuda linux today, desktop was pitch black with nothing related to it working. When I first booted, the grub was working fine, the login screen worked too and even the lock screen. However, the desktop is full black with all docks, panels, widgets, wallpapers gone. It shows for a blink after login but disappears. The strange thing is that cursor is visible and works. I can also run apps with the help of krunner.

But the windows key, brightness, audio volume, and things related to desktop doesn’t work. I don’t know what the problem is. I haven’t really tinkered with the settings at all these past few days. All I did was update the system yesterday night after finishing my work and shut it down after update. Is this a bug or something?

P.S.: I do doubt that the problem is with the plasma but I’m not sure. I think so because the plasma notifications are not working either and I see that desktop session: plasma x11 options at the bottom left corner of my login screen which I’m not sure if it was always there.

This is my main machine and I am having a bit of trouble here. So I really appreciate your help. Thanks!

You could try restoring the latest working snapshot but I doubt it will help, because this looks like when something got corrupted in your home folder. But you could try…
Then you should try reapplying the theme: go to the Plasma System Settings with krunner and apply the Global theme Dr460nized from the appearance menu.

Then logoff/logon
By-the-way, you forgot posting your garuda-inxi!


Thank you for such a detailed help but I tried both restoring snapshots and switching global theme, but that didn’t work.

Is this not due to garuda update because I haven’t done anything that drastic.? Do I have to perform full reset to solve this? Is there no other way? Sorry but I’m panicking.

Here is the output of garuda-inxi:

Kernel: 6.5.3-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=25a52fbb-0a18-444f-9298-e208ddd7e44e rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
snd_hda_intel.dmic_detect=0 ibt=off DEEPIN_GFXMODE= DEEPIN_GFXMODE=
Desktop: KDE Plasma v: 5.27.8 tk: Qt v: 5.15.10 wm: kwin_x11 dm:
1: LightDM v: 1.32.0 note: stopped 2: SDDM Distro: Garuda Linux
base: Arch Linux
Type: Laptop System: LENOVO product: 81H7 v: Lenovo ideapad 130-15IKB
serial: <filter> Chassis: type: 10 v: Lenovo ideapad 130-15IKB
serial: <filter>
Mobo: LENOVO model: LNVNB161216 v: No DPK serial: <filter> UEFI: LENOVO
v: 8QCN28WW(V1.16) date: 08/19/2021
ID-1: BAT1 charge: 23.1 Wh (99.1%) condition: 23.3/30.0 Wh (77.6%)
volts: 8.4 min: 7.6 model: 0x4C 0x47 0x43 0x00 0x31 PABAS0241231
type: Li-ion serial: <filter> status: not charging cycles: 1124
Info: model: Intel Core i5-8250U socket: BGA1356 (U3E1) note: check bits: 64
type: MT MCP arch: Coffee Lake gen: core 8 level: v3 note: check built: 2017
process: Intel 14nm family: 6 model-id: 0x8E (142) stepping: 0xA (10)
microcode: 0xF4
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 6 MiB desc: 1x6 MiB
Speed (MHz): avg: 800 min/max: 400/3400 base/boost: 2800/8300 scaling:
driver: intel_pstate governor: powersave volts: 0.9 V ext-clock: 100 MHz
cores: 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800
bogomips: 28800
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel UHD Graphics 620 vendor: Lenovo driver: i915 v: kernel
arch: Gen-9.5 process: Intel 14nm built: 2016-20 ports: active: eDP-1
empty: HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:5917 class-ID: 0300
Device-2: Syntek EasyCamera driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-5:3 chip-ID: 174f:241a
class-ID: 0e02
Display: server: X.Org v: 21.1.8 with: Xwayland v: 23.2.1
compositor: kwin_x11 driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: :0 screens: 1
Screen-1: 0 s-res: 1366x768 s-dpi: 96 s-size: 361x203mm (14.21x7.99")
s-diag: 414mm (16.31")
Monitor-1: eDP-1 model: ChiMei InnoLux 0x15db built: 2015 res: 1366x768
hz: 60 dpi: 101 gamma: 1.2 size: 344x193mm (13.54x7.6") diag: 394mm (15.5")
ratio: 16:9 modes: 1366x768
API: OpenGL v: 4.6 Mesa 23.1.7-arch1.1 renderer: Mesa Intel UHD Graphics
620 (KBL GT2) direct-render: Yes
Device-1: Intel Sunrise Point-LP HD Audio vendor: Lenovo
driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_soc_avs
bus-ID: 00:1f.3 chip-ID: 8086:9d71 class-ID: 0403
API: ALSA v: k6.5.3-zen1-1-zen status: kernel-api
tools: alsactl,alsamixer,amixer
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 0.3.80 status: n/a (root, process) with:
1: wireplumber status: active 2: pw-jack type: plugin
tools: pw-cat,pw-cli,wpctl
Server-3: PulseAudio v: 16.1 status: active (root, process) with:
1: pulseaudio-alsa type: plugin 2: pulseaudio-jack type: module
tools: pacat,pactl
Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: Lenovo
driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000
bus-ID: 01:00.0 chip-ID: 10ec:8136 class-ID: 0200
IF: enp1s0 state: down mac: <filter>
Device-2: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
vendor: Lenovo driver: ath10k_pci v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 bus-ID: 02:00.0 chip-ID: 168c:0042 class-ID: 0280
IF: wlp2s0 state: up mac: <filter>
Device-1: Qualcomm Atheros driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-7:4 chip-ID: 0cf3:e500
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 1 state: up address: <filter> bt-v: 4.2
lmp-v: 8 status: discoverable: yes pairing: yes class-ID: 7c010c
Local Storage: total: 223.57 GiB used: 112.08 GiB (50.1%)
ID-1: /dev/sda maj-min: 8:0 vendor: Hikvision model: HS-SSD-C100 240G
size: 223.57 GiB block-size: physical: 512 B logical: 512 B sata: 3.2
speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: Hf10 temp: 43 C
scheme: GPT
SMART: yes state: enabled health: PASSED on: 238d 5h cycles: 5203
read: 451.2 MiB written: 270.5 MiB Old-Age: UDMA CRC errors: 79 Pre-Fail:
reallocated sector: 100 threshold: 50
ID-1: / raw-size: 143.36 GiB size: 143.36 GiB (100.00%)
used: 112.08 GiB (78.2%) fs: btrfs block-size: 4096 B dev: /dev/sda4
maj-min: 8:4
ID-2: /home raw-size: 143.36 GiB size: 143.36 GiB (100.00%)
used: 112.08 GiB (78.2%) fs: btrfs block-size: 4096 B dev: /dev/sda4
maj-min: 8:4
ID-3: /var/log raw-size: 143.36 GiB size: 143.36 GiB (100.00%)
used: 112.08 GiB (78.2%) fs: btrfs block-size: 4096 B dev: /dev/sda4
maj-min: 8:4
ID-4: /var/tmp raw-size: 143.36 GiB size: 143.36 GiB (100.00%)
used: 112.08 GiB (78.2%) fs: btrfs block-size: 4096 B dev: /dev/sda4
maj-min: 8:4
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 7.63 GiB used: 2.15 GiB (28.2%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8
dev: /dev/zram0
System Temperatures: cpu: 52.0 C pch: 47.5 C mobo: N/A
Fan Speeds (rpm): N/A
Processes: 316 Uptime: 1h 59m wakeups: 58274 Memory: total: 8 GiB
available: 7.63 GiB used: 5.07 GiB (66.5%) igpu: 64 MiB Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
Packages: 1639 pm: pacman pkgs: 1631 libs: 417
tools: octopi,pamac,paru,trizen,yay pm: flatpak pkgs: 8
Shell: garuda-inxi (sudo) default: Bash v: 5.1.16 running-in: konsole
inxi: 3.3.29
Garuda (2.6.16-1):
System install date:     2023-08-19
Last full system update: 2023-09-21
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       Yes
Failed units:            archlinux-keyring-wkd-sync.service

Try creating a new user.
It’s not Ideal but might get you back on track until the problem is found and fixed.

This is not standard, although stopped.
And this is strange…


Restore settings with garuda-assistant.

But you did something :slight_smile:

Remove deepin and use X11


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.