Desktop reset, lost all saved passwords after reboot

So this happened. I was switching my GPU with optimus-manager, like I do every day, but it got hanged so I had to force reboot. After the reboot Garuda booted up, but the desktop loaded without any of my settings, without any background image, panel located in the bottom like in default KDE, all of my passwords are forgotton, including my wifi password.

I tried using snapshots, booting with the LTS kernel, all that jazz, but that didn't help. I tried running update on terminal and got a message that system was only partially updated. I tried running update again, everything went well and I rebooted. Didn't fix the problem.

I'm going to set it all up again, a bit of a chore.

Here is my inxi -Faz (after I updated):

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "en_GB:en_US:fi:pt_BR",
        LC_ALL = (unset),
        LC_ADDRESS = "fi_FI.UTF-8",
        LC_COLLATE = "fi_FI.UTF-8",
        LC_CTYPE = "fi_FI.UTF-8",
        LC_IDENTIFICATION = "fi_FI.UTF-8",
        LC_MEASUREMENT = "fi_FI.UTF-8",
        LC_MONETARY = "fi_FI.UTF-8",
        LC_NAME = "fi_FI.UTF-8",
        LC_NUMERIC = "fi_FI.UTF-8",
        LC_PAPER = "fi_FI.UTF-8",
        LC_TELEPHONE = "fi_FI.UTF-8",
        LC_TIME = "fi_FI.UTF-8",
        LANG = "en_FI.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
System:    Kernel: 5.15.5-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=33b92acc-eae1-4daf-86a1-a400c31bc857 rw
           [email protected] splash intel_iommu=on rd.udev.log_priority=3 vt.global_cursor_default=0
           systemd.unified_cgroup_hierarchy=1 loglevel=3
           Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:   Type: Desktop Mobo: ASRock model: Z370 Gaming-ITX/ac serial: <superuser required> UEFI: American Megatrends
           v: P4.30 date: 11/01/2019
Battery:   Device-1: hidpp_battery_0 model: Logitech MX Keys Wireless Keyboard serial: <filter>
           charge: 55% (should be ignored) rechargeable: yes status: Discharging
CPU:       Info: 6-Core model: Intel Core i7-8700K bits: 64 type: MT MCP arch: Kaby Lake note: check family: 6
           model-id: 9E (158) stepping: A (10) microcode: EA cache: L1: 384 KiB L2: 1.5 MiB L3: 12 MiB
           flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 88796
           Speed: 4435 MHz min/max: 800/5000 MHz Core speeds (MHz): 1: 4435 2: 4464 3: 4600 4: 4600 5: 4292 6: 4461 7: 4248
           8: 4601 9: 4600 10: 4600 11: 4600 12: 4602
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled
           Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable
           Type: meltdown mitigation: PTI
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling
           Type: srbds mitigation: Microcode
           Type: tsx_async_abort mitigation: TSX disabled
Graphics:  Device-1: Intel CometLake-S GT2 [UHD Graphics 630] vendor: ASRock driver: i915 v: kernel bus-ID: 00:02.0
           chip-ID: 8086:3e92 class-ID: 0300
           Device-2: NVIDIA GP104 [GeForce GTX 1070] vendor: Gigabyte driver: nvidia v: 470.62.02
           alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1b81 class-ID: 0300
           Display: x11 server: X.Org 1.21.1.1 compositor: kwin_x11 driver: loaded: modesetting,nvidia display-ID: :0
           screens: 1
           Screen-1: 0 s-res: 3440x1440 s-dpi: 96 s-size: 910x381mm (35.8x15.0") s-diag: 987mm (38.8")
           Monitor-1: DP-1-3 res: 3440x1440 dpi: 107 size: 819x346mm (32.2x13.6") diag: 889mm (35")
           OpenGL: renderer: NVIDIA GeForce GTX 1070/PCIe/SSE2 v: 4.6.0 NVIDIA 470.62.02 direct render: Yes
Audio:     Device-1: Intel 200 Series PCH HD Audio vendor: ASRock driver: snd_hda_intel v: kernel bus-ID: 00:1f.3
           chip-ID: 8086:a2f0 class-ID: 0403
           Device-2: NVIDIA GP104 High Definition Audio vendor: Gigabyte driver: snd_hda_intel v: kernel bus-ID: 01:00.1
           chip-ID: 10de:10f0 class-ID: 0403
           Device-3: SteelSeries ApS Arctis Pro Wireless type: USB driver: hid-generic,snd-usb-audio,usbhid bus-ID: 1-5.3:6
           chip-ID: 1038:1297 class-ID: 0300
           Sound Server-1: ALSA v: k5.15.5-zen1-1-zen running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: yes
           Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:   Device-1: Intel Ethernet I219-V vendor: ASRock driver: e1000e v: kernel port: N/A bus-ID: 00:1f.6
           chip-ID: 8086:15b8 class-ID: 0200
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Device-2: Broadcom BCM4360 802.11ac Wireless Network Adapter vendor: Apple driver: wl v: kernel modules: bcma
           bus-ID: 04:00.0 chip-ID: 14e4:43a0 class-ID: 0280
           IF: wlp4s0 state: dormant mac: <filter>
           IF-ID-1: virbr0 state: down mac: <filter>
Bluetooth: Device-1: Apple Bluetooth USB Host Controller type: USB driver: btusb v: 0.8 bus-ID: 1-14.3:11 chip-ID: 05ac:828f
           class-ID: fe01
           Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:    Local Storage: total: 2.56 TiB used: 2.27 TiB (89.0%)
           SMART Message: Unable to run smartctl. Root privileges required.
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: A-Data model: SX8200PNP size: 476.94 GiB block-size: physical: 512 B
           logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: R0906I temp: 44.9 C scheme: GPT
           ID-2: /dev/sda maj-min: 8:0 vendor: Samsung model: SSD 850 EVO 250GB size: 232.89 GiB block-size: physical: 512 B
           logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 2B6Q scheme: GPT
           ID-3: /dev/sdb maj-min: 8:16 vendor: A-Data model: SU800 size: 1.86 TiB block-size: physical: 512 B logical: 512 B
           speed: 6.0 Gb/s type: SSD serial: <filter> rev: 7A
Partition: ID-1: / raw-size: 39.26 GiB size: 39.26 GiB (100.00%) used: 31.76 GiB (80.9%) fs: btrfs dev: /dev/nvme0n1p2
           maj-min: 259:2
           ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%) used: 560 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1
           maj-min: 259:1
           ID-3: /home raw-size: 437.18 GiB size: 437.18 GiB (100.00%) used: 379.87 GiB (86.9%) fs: btrfs dev: /dev/nvme0n1p3
           maj-min: 259:3
           ID-4: /var/log raw-size: 39.26 GiB size: 39.26 GiB (100.00%) used: 31.76 GiB (80.9%) fs: btrfs dev: /dev/nvme0n1p2
           maj-min: 259:2
           ID-5: /var/tmp raw-size: 39.26 GiB size: 39.26 GiB (100.00%) used: 31.76 GiB (80.9%) fs: btrfs dev: /dev/nvme0n1p2
           maj-min: 259:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
           ID-1: swap-1 type: zram size: 31.03 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0
Sensors:   System Temperatures: cpu: 48.0 C mobo: N/A gpu: nvidia temp: 43 C
           Fan Speeds (RPM): N/A gpu: nvidia fan: 43%
Info:      Processes: 391 Uptime: 6m wakeups: 2 Memory: 31.03 GiB used: 5.73 GiB (18.5%) Init: systemd v: 249 tool: systemctl
           Compilers: gcc: 11.1.0 clang: 13.0.0 Packages: note: see --pkg pacman: 1781 lib: 557 Shell: Zsh v: 5.8
           running-in: konsole inxi: 3.3.09

User settings and config files in the user's home directory are not saved by default in system snapshots. It is really not recommended to include the home directory in your snapshots.

You can use a dedicated utility such as Back in Time to manage backups of your home directory.

1 Like

Sounds like your home directory is broken somehow - hopefully you have a backup? Right? :pray:

Boot, log in to a TTY as root, and check the presence and ownership of your home directory,

ls -l /home/his_turdniess

If all the files you'd expect are not present, you'll need to restore from a backup.

If files are present, try resetting permissions:

chown -R his_turdniess: /home/his_turdniess

Though this probably won't make any difference if settings have been overwritten...

2 Likes

Well that explains why the settings were not restored. But doesn't explain why they were lost. :thinking:

Most likely, filesystem corruption caused by:

5 Likes

Everything is there, as far as I know and permissions are correct. Checked with Dolphin.

Just noticed that my transmission downloads are not getting processed by some services. Transmission's settings had reset among others, so maybe the downloaded items permissions have as well. Changing the umask should fix it. So anybody else with similar issues, go check it out.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.