Desktop Misaligned, timing unknown

I’m on KDE in dr460nized. I assume that this happened after an update, and you guessed it, I’m not sure when it happened because i haven’t been on my computer very much. My main monitor’s kde desktop is misaligned with respect to the monitor. I did first notice this behavior after connecting a third monitor to my graphics card, but reactivating that monitor and disabling it again, the issue persists.

I haven’t poked around in any config files, truth is I’d do it, but I’m really sick and have not the energy to put into it so I need some help.

╭─meredith@dragonfruit in ~
╰─λ garuda-inxi
System:
Kernel: 6.8.9-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=47e881e9-7adb-48dc-8263-4f88266918af rw rootflags=subvol=@
quiet loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.0.4 tk: Qt v: N/A info: frameworks v: 6.1.0
wm: kwin_x11 vt: 2 dm: SDDM Distro: Garuda base: Arch Linux
Machine:
Type: Desktop System: Gigabyte product: X570 AORUS ELITE v: -CF
serial: <superuser required>
Mobo: Gigabyte model: X570 AORUS ELITE v: x.x serial: <superuser required>
uuid: <superuser required> BIOS: American Megatrends LLC. v: F34
date: 06/10/2021
Battery:
ID-1: hidpp_battery_0 charge: 72% condition: N/A volts: 3.9 min: N/A
model: Logitech G502 LIGHTSPEED Wireless Gaming Mouse type: N/A
serial: <filter> status: discharging
CPU:
Info: model: AMD Ryzen 9 3950X bits: 64 type: MT MCP arch: Zen 2 gen: 3
level: v3 note: check built: 2020-22 process: TSMC n7 (7nm)
family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
Topology: cpus: 1x cores: 16 tpc: 2 threads: 32 smt: enabled cache:
L1: 1024 KiB desc: d-16x32 KiB; i-16x32 KiB L2: 8 MiB desc: 16x512 KiB
L3: 64 MiB desc: 4x16 MiB
Speed (MHz): avg: 3526 high: 4251 min/max: 2200/4761 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3500 2: 3500
3: 3500 4: 3500 5: 3500 6: 3500 7: 3500 8: 3500 9: 4251 10: 3500 11: 3500
12: 3500 13: 3500 14: 3500 15: 3500 16: 3592 17: 3500 18: 3500 19: 3500
20: 3500 21: 3500 22: 3500 23: 3500 24: 3500 25: 3500 26: 3500 27: 3500
28: 3500 29: 3500 30: 3500 31: 3500 32: 3500 bogomips: 223578
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: NVIDIA TU104 [GeForce RTX 2070 SUPER] vendor: Micro-Star MSI
driver: nvidia v: 550.78 alternate: nouveau,nvidia_drm non-free: 550.xx+
status: current (as of 2024-04; EOL~2026-12-xx) arch: Turing code: TUxxx
process: TSMC 12nm FF built: 2018-2022 pcie: gen: 1 speed: 2.5 GT/s
lanes: 16 link-max: gen: 3 speed: 8 GT/s ports: active: none
off: DP-2,DP-3,HDMI-A-1 empty: DP-1 bus-ID: 0a:00.0 chip-ID: 10de:1e84
class-ID: 0300
Device-2: Logitech C922 Pro Stream Webcam driver: snd-usb-audio,uvcvideo
type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 7-3.4:5
chip-ID: 046d:085c class-ID: 0102 serial: <filter>
Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 23.2.6
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia,nvidia-nvswitch
display-ID: :0 screens: 1
Screen-1: 0 s-res: 5120x1440 s-dpi: 107 s-size: 1216x342mm (47.87x13.46")
s-diag: 1263mm (49.73")
Monitor-1: DP-2 note: disabled pos: left model: Dell S2716DG
serial: <filter> built: 2016 res: 2560x1440 dpi: 109 gamma: 1.2
size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
max: 2560x1440 min: 640x480
Monitor-2: DP-3 mapped: DP-4 note: disabled pos: primary,right
model: VG27A serial: <filter> built: 2020 res: 2560x1440 dpi: 109 gamma: 1.2
size: 597x336mm (23.5x13.23") diag: 685mm (27") ratio: 16:9 modes:
max: 2560x1440 min: 640x480
Monitor-3: HDMI-A-1 mapped: HDMI-0 note: disabled model: E261VA
serial: <filter> built: 2011 res: 2560x1440 dpi: 60 gamma: 1.2
size: 575x323mm (22.64x12.72") diag: 660mm (26") ratio: 16:9 modes:
max: 1360x768 min: 640x480
API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
drv: swrast gbm: drv: nvidia surfaceless: drv: nvidia x11: drv: nvidia
inactive: wayland,device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 550.78
glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 2070
SUPER/PCIe/SSE2 memory: 7.81 GiB
API: Vulkan v: 1.3.279 layers: 11 device: 0 type: discrete-gpu name: NVIDIA
GeForce RTX 2070 SUPER driver: nvidia v: 550.78 device-ID: 10de:1e84
surfaces: xcb,xlib
Audio:
Device-1: NVIDIA TU104 HD Audio vendor: Micro-Star MSI driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 0a:00.1
chip-ID: 10de:10f8 class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0c:00.4 chip-ID: 1022:1487 class-ID: 0403
Device-3: Logitech C922 Pro Stream Webcam driver: snd-usb-audio,uvcvideo
type: USB rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 7-3.4:5
chip-ID: 046d:085c class-ID: 0102 serial: <filter>
API: ALSA v: k6.8.9-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 1.0.5 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Intel I211 Gigabit Network vendor: Gigabyte driver: igb v: kernel
pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 05:00.0
chip-ID: 8086:1539 class-ID: 0200
IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: Intel 82575EB Gigabit Network driver: igb v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 link-max: lanes: 4 port: d020 bus-ID: 06:00.0
chip-ID: 8086:10a7 class-ID: 0200
IF: enp6s0f0 state: down mac: <filter>
Device-3: Intel 82575EB Gigabit Network driver: igb v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 link-max: lanes: 4 port: d000 bus-ID: 06:00.1
chip-ID: 8086:10a7 class-ID: 0200
IF: enp6s0f1 state: down mac: <filter>
Info: services: NetworkManager, smbd, sshd, systemd-timesyncd
Bluetooth:
Device-1: TP-Link UB500 Adapter driver: btusb v: 0.8 type: USB rev: 1.1
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-3.4:5 chip-ID: 2357:0604
class-ID: e001 serial: <filter>
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.1
lmp-v: 10 status: discoverable: no pairing: no class-ID: 6c0104
Drives:
Local Storage: total: 3.66 TiB used: 801.76 GiB (21.4%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:2 vendor: A-Data model: SX6000PNP
size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: V9002s85 temp: 35.9 C
scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Western Digital
model: WDS100T1XHE-00AFY0 size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 614600WD temp: 39.9 C scheme: MBR
ID-3: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD20EARX-00ZUDB0 size: 1.82 TiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 5400 serial: <filter>
fw-rev: 0A80 scheme: GPT
Partition:
ID-1: / raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
used: 301.78 GiB (32.4%) fs: btrfs dev: /dev/nvme1n1p1 maj-min: 259:1
ID-2: /home raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
used: 301.78 GiB (32.4%) fs: btrfs dev: /dev/nvme1n1p1 maj-min: 259:1
ID-3: /var/log raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
used: 301.78 GiB (32.4%) fs: btrfs dev: /dev/nvme1n1p1 maj-min: 259:1
ID-4: /var/tmp raw-size: 931.51 GiB size: 931.51 GiB (100.00%)
used: 301.78 GiB (32.4%) fs: btrfs dev: /dev/nvme1n1p1 maj-min: 259:1
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 31.28 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 32 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 46.0 C mobo: 29.0 C gpu: nvidia temp: 38 C
Fan Speeds (rpm): N/A gpu: nvidia fan: 23%
Info:
Memory: total: 32 GiB available: 31.28 GiB used: 7.83 GiB (25.0%)
Processes: 623 Power: uptime: 11m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 12.47 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: pm: pacman pkgs: 2123 libs: 587 tools: octopi,paru Compilers:
clang: 17.0.6 gcc: 13.2.1 Shell: garuda-inxi default: fish v: 3.7.1
running-in: konsole inxi: 3.3.34
Garuda (2.6.26-1):
System install date:     2023-11-12
Last full system update: 2024-05-05
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       <superuser required>
Failed units:

I updated it again today and it randomly fixed itself. How unsatisfying.

3 Likes

Get well soon. :slight_smile:

Master of Self-Solution :grin:

7 Likes

LOL. I rarely post here anymore because there’s usually someone on here or the arch or manjaro forums who’s had the same issues.

Guess i’m only half as dumb as i look. :rofl:

3 Likes

You are also welcome without having issues with Garuda :wink:

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.