Desktop, latte and settings are broken

Hi guys!

inxi -Faz
System:    Kernel: 5.14.6-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=d79dfe17-6443-4139-8ade-59a1d507c8b5 rw 
           [email protected] splash rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 
           loglevel=3 mitigations=off sysrq_always_enabled=1 
           Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux 
           base: Arch Linux 
Machine:   Type: Desktop Mobo: Micro-Star model: B560M PRO-VDH (MS-7D18) v: 1.0 serial: <filter> 
           UEFI: American Megatrends LLC. v: 1.00 date: 03/01/2021 
CPU:       Info: 6-Core model: 11th Gen Intel Core i5-11500 bits: 64 type: MT MCP arch: Rocket Lake family: 6 
           model-id: A7 (167) stepping: 1 microcode: 40 cache: L2: 12 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 65088 
           Speed: 4573 MHz min/max: 800/4600 MHz Core speeds (MHz): 1: 4573 2: 4542 3: 4595 4: 4571 5: 4569 6: 4600 7: 4600 
           8: 4548 9: 4341 10: 4559 11: 4600 12: 4600 
           Vulnerabilities: Type: itlb_multihit status: Not affected 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass status: Vulnerable 
           Type: spectre_v1 status: Vulnerable: __user pointer sanitization and usercopy barriers only; no swapgs barriers 
           Type: spectre_v2 status: Vulnerable, IBPB: disabled, STIBP: disabled 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: Intel RocketLake-S GT1 [UHD Graphics 750] vendor: Micro-Star MSI driver: i915 v: kernel bus-ID: 00:02.0 
           chip-ID: 8086:4c8a class-ID: 0300 
           Device-2: Logitech Webcam C170 type: USB driver: snd-usb-audio,uvcvideo bus-ID: 1-3:2 chip-ID: 046d:082b 
           class-ID: 0102 
           Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: intel unloaded: modesetting 
           alternate: fbdev,vesa display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 3840x2160 s-dpi: 96 s-size: 1016x571mm (40.0x22.5") s-diag: 1165mm (45.9") 
           Monitor-1: HDMI1 res: 3840x2160 hz: 60 dpi: 155 size: 630x360mm (24.8x14.2") diag: 726mm (28.6") 
           OpenGL: renderer: Mesa Intel Graphics (RKL GT1) v: 4.6 Mesa 21.2.2 direct render: Yes 
Audio:     Device-1: Intel Tiger Lake-H HD Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel 
           alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3 chip-ID: 8086:43c8 class-ID: 0403 
           Device-2: Logitech Webcam C170 type: USB driver: snd-usb-audio,uvcvideo bus-ID: 1-3:2 chip-ID: 046d:082b 
           class-ID: 0102 
           Sound Server-1: ALSA v: k5.14.6-zen1-1-zen running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: yes 
           Sound Server-4: PipeWire v: 0.3.35 running: no 
Network:   Device-1: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8169 v: kernel port: 3000 bus-ID: 02:00.0 
           chip-ID: 10ec:8125 class-ID: 0200 
           IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           IF-ID-1: anbox0 state: down mac: <filter> 
Drives:    Local Storage: total: 494.82 GiB used: 32 GiB (6.5%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO Plus 500GB size: 465.76 GiB block-size: 
           physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 2B2QEXM7 temp: 38.9 C 
           scheme: GPT 
           ID-2: /dev/sda maj-min: 8:0 type: USB vendor: SanDisk model: Cruzer Glide 3.0 size: 29.06 GiB block-size: 
           physical: 512 B logical: 512 B type: N/A serial: <filter> rev: 1.00 scheme: MBR 
           SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
Partition: ID-1: / raw-size: 465.5 GiB size: 465.5 GiB (100.00%) used: 32 GiB (6.9%) fs: btrfs dev: /dev/nvme0n1p2 
           maj-min: 259:2 
           ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 562 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 
           maj-min: 259:1 
           ID-3: /home raw-size: 465.5 GiB size: 465.5 GiB (100.00%) used: 32 GiB (6.9%) fs: btrfs dev: /dev/nvme0n1p2 
           maj-min: 259:2 
           ID-4: /var/log raw-size: 465.5 GiB size: 465.5 GiB (100.00%) used: 32 GiB (6.9%) fs: btrfs dev: /dev/nvme0n1p2 
           maj-min: 259:2 
           ID-5: /var/tmp raw-size: 465.5 GiB size: 465.5 GiB (100.00%) used: 32 GiB (6.9%) fs: btrfs dev: /dev/nvme0n1p2 
           maj-min: 259:2 
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) 
           ID-1: swap-1 type: zram size: 15.45 GiB used: 0 KiB (0.0%) priority: 100 dev: /dev/zram0 
Sensors:   System Temperatures: cpu: 27.8 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 294 Uptime: 1m wakeups: 0 Memory: 15.45 GiB used: 2.07 GiB (13.4%) Init: systemd v: 249 tool: systemctl 
           Compilers: gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1665 lib: 502 Shell: fish v: 3.3.1 default: Bash v: 5.1.8 
           running-in: konsole inxi: 3.3.06 

I have an issue with Garuda.
I had made a big blunder and wrote in console 'sudo rm -r /var/lib/pacman/db.lck' and then my dekstop stoped working and all of my backups have been deleted.
I booted my computer again and then even live version was working bad: wallpaper after clicking became black, settings didn't work: i can't see what i am clicking on - some kind of freeze but i can change settings, latte doesn't work too and windows of applications seems to be broken - blinking fast and it is not possible to click anywhere.
If it is needed I pin journalctl log from starting of system.

I tried already reset settings in garuda assistance, updating system.

This is my first post and I am writing it because I couldn't find any answer to this, if this is simillar to other posts, sorry but I really gave up in searching.

And lastly I want to admit that you guys are making a really great job. This is amazing how configurable from GUI level this system is, how it feels using it and how this community and your team works. Great job guys.

Hi, welcome.

-r, -R, --recursive
....... Remove directories and their contents recursively

db.lck is a file, not a directory. Did you interrupt the deletion process, or did it run through?

Who knows already exactly what everything was deleted?

Try to back up important data first if you have not already done so.

Maybe you have interrupted an update process. Removing the db.lck otherwise cannot create such a mess.
Are you sure you cannot even restore a previous working snapshot?
If not, are you sure also the live USB is not working? I really can see no relations between the 2 things.
If the live USB is working, you could use it to chroot into your system and try to perform a full update.
If not working, you could try to boot to a TTY and do the same.

Huh, I tried but after mounting then updating I had an error: "error: command failed to execute correctly" and second error: "error: failed to commit transaction (failed to run transaction hooks)"
And i'm sure i cannot recover any snapshot. Like I said before even live usb version is bugging.
But I found maybe main problem - after "fdisk -l" I saw that loops partitions has been made on my ssd. And this is my fault because I had partitioned disk without earlier read if i can partition ssd. Do you think it can making a problem?

I mean the strangest issue is that whenever I boot it with new bootable pendrive, I have the same issues: buggy wallpaper and latte, impossibility to get to the website by firedragon and I cannot see while i am clicking buttons in settings panel.

We need more evidence to be able to debug the issues. Eg. Pacman output, screenshots of the occurrence, etc. :eyes:

2 Likes

3 posts were split to a new topic: Something wrong with conky