Desktop Environment being weird

Hey, I need some help
My LXQT-Kwin is with a strange issue in which it is almost completely irresponsive. Like, the features of the environment don't seem to work at all, but I can still open stuff from the dock, yet ofc with some graphical issues
Also the cairo-dock when it's on it renders the bottom part of the screen black while showing only itself.
No matter how many times I log in/out or even reboot, the issue persists

I've had the same problem before sometimes, but then updating the system worked it out, but last time I had to recover from a snapshot and this time recovering seems a bit of a waste of time I guess.
As a side note tho, the cinnamon environment is working perfectly so I guess it's really an lxqt problem

Any help is much appreciated : 3

Why?
Do it, update, copy the files that will be updated and post it as text.
Also

inxi -Faz

is not a bad idea :slight_smile:

2 Likes

Well, recovering do get the issue solved but, as it comes back, perharps not the problem that causes it

But I'll do it as you say, just give me some time cause I'm working on something rn ~

Alrighty here we go

upd

# Arch Linux mirrorlist generated by Reflector #

# With:       reflector --latest 5 --age 2 --fastest 5 --protocol https --sort rate --save /etc/pacman.d/mirrorlist
# When:       2021-06-26 21:47:17 UTC
# From:       https://www.archlinux.org/mirrors/status/json/
# Retrieved:  2021-06-26 21:47:02 UTC
# Last Check: 2021-06-26 20:06:56 UTC

Server = https://arch.mirror.square-r00t.net/$repo/os/$arch
Server = https://archlinux.mailtunnel.eu/$repo/os/$arch
Server = https://mirror.f4st.host/archlinux/$repo/os/$arch
Server = https://mirror.lty.me/archlinux/$repo/os/$arch
Server = https://archlinux.thaller.ws/$repo/os/$arch
:: Synchronizing package databases...
 core                                                                      133,6 KiB  99,8 KiB/s 00:01 [------------------------------------------------------------] 100%
 extra                                                                    1566,6 KiB  2,60 MiB/s 00:01 [------------------------------------------------------------] 100%
 community                                                                   5,6 MiB  7,15 MiB/s 00:01 [------------------------------------------------------------] 100%
 multilib                                                                  149,6 KiB  1018 KiB/s 00:00 [------------------------------------------------------------] 100%
 chaotic-aur                                                              1166,0 KiB   413 KiB/s 00:03 [------------------------------------------------------------] 100%
:: Starting full system upgrade...
warning: balena-etcher: local (2:1.5.119-1) is newer than chaotic-aur (1.5.120-1)
warning: rare-git: local (1.5_beta.r5.gbe25abe-1) is newer than chaotic-aur (1.5_beta2.r24.g4c950aa-1)
resolving dependencies...
looking for conflicting packages...

Packages (65) android-tools-31.0.0-4  ant-dracula-kde-theme-git-v2.0.r36.gceec1c1-1  ant-dracula-kvantum-theme-git-v2.0.r36.gceec1c1-1  appstream-0.14.4-1
              appstream-qt-0.14.4-1  bitwarden-1.26.5-1  bluedevil-1:5.22.2.1-1  brave-1.25.73-1  breeze-5.22.2.1-1  citra-canary-git-r9036.39265312b-1
              downgrade-10.1.0-1  electron-13.1.4-1  electron11-11.4.9-1  evolution-data-server-3.40.2-2  fwupd-1.6.1-2  geoip-database-20210622-1  groff-1.22.4-6
              hypnotix-1.9-1  imagemagick-7.1.0.2-1  kactivitymanagerd-5.22.2.1-1  kde-cli-tools-5.22.2.1-1  kdecoration-5.22.2.1-1  kscreenlocker-5.22.2.1-1
              ksystemstats-5.22.2.1-1  kwayland-server-5.22.2.1-1  kwin-5.22.2.1-1  layer-shell-qt-5.22.2.1-1  lib32-libcanberra-0.30+2+gc0620e4-5
              lib32-libldap-2.4.59-1  lib32-libxcrypt-4.4.23-1  lib32-mesa-21.1.3-1  lib32-vulkan-icd-loader-1.2.182-1  libcanberra-0.30+2+gc0620e4-5
              libkscreen-5.22.2.1-1  libksysguard-5.22.2.1-1  libldap-2.4.59-1  libphonenumber-8.12.25-1  librewolf-89.0.2-1  libxcrypt-4.4.23-1  linux-lts-5.10.46-1
              linux-lts-headers-5.10.46-1  man-db-2.9.4-2  man-pages-5.12-1  mesa-21.1.3-1  milou-5.22.2.1-1  nextcloud-client-3.2.3-1  paru-1.7.3-1
              plasma-integration-5.22.2.1-1  plasma-workspace-5.22.2.1-1  powder-toy-git-snapshot.217.13.g02923443-1  protobuf-3.17.3-1  ptex-2.4.0-1
              python-protobuf-3.17.3-1  qt5-base-5.15.2+kde+r200-1  qt5-declarative-5.15.2+kde+r29-1  ruby-irb-1.3.6-1  sddm-kcm-5.22.2.1-1  sof-firmware-1.8-1
              systemsettings-5.22.2.1-1  totem-pl-parser-3.26.6-1  vlc-3.0.16-2  vulkan-icd-loader-1.2.182-1  vulkan-tools-1.2.182-1  xdg-desktop-portal-kde-5.22.2.1-1
              xf86-input-libinput-1.1.0-1

Total Installed Size:  1723,88 MiB
Net Upgrade Size:        -0,93 MiB

:: Proceed with installation? [Y/n] n

inxi -Faz

System:    Kernel: 5.12.12-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=1409d596-84e3-4768-b0e5-996dc20bb2a5 rw 
           [email protected] quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 
           systemd.unified_cgroup_hierarchy=1 loglevel=3 
           Desktop: LXQt 0.17.1 tk: Qt 5.15.2 info: cairo-dock, lxqt-panel wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux 
           base: Arch Linux 
Machine:   Type: Desktop Mobo: INTEL model: HM65DESK serial: <filter> UEFI: American Megatrends v: 4.6.5 date: 02/23/2019 
CPU:       Info: Dual Core model: Intel Core i7-2620M bits: 64 type: MT MCP arch: Sandy Bridge family: 6 model-id: 2A (42) 
           stepping: 7 microcode: 2F cache: L2: 4 MiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 21552 
           Speed: 847 MHz min/max: 800/3400 MHz Core speeds (MHz): 1: 847 2: 891 3: 970 4: 2290 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported 
           Type: l1tf mitigation: PTE Inversion 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA GM107 [GeForce GTX 750] driver: nvidia v: 465.31 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 
           chip-ID: 10de:1381 class-ID: 0300 
           Display: x11 server: X.Org 1.20.11 compositor: kwin_x11 driver: loaded: nvidia display-ID: :0 screens: 1 
           Screen-1: 0 s-res: 1360x768 s-dpi: 90 s-size: 384x300mm (15.1x11.8") s-diag: 487mm (19.2") 
           Monitor-1: HDMI-0 res: 1360x768 hz: 60 dpi: 49 size: 708x398mm (27.9x15.7") diag: 812mm (32") 
           OpenGL: renderer: NVIDIA GeForce GTX 750/PCIe/SSE2 v: 4.6.0 NVIDIA 465.31 direct render: Yes 
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 
           chip-ID: 8086:1c20 class-ID: 0403 
           Device-2: NVIDIA GM107 High Definition Audio [GeForce 940MX] driver: snd_hda_intel v: kernel bus-ID: 01:00.1 
           chip-ID: 10de:0fbc class-ID: 0403 
           Sound Server-1: ALSA v: k5.12.12-zen1-1-zen running: yes 
           Sound Server-2: JACK v: 1.9.18 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: yes 
           Sound Server-4: PipeWire v: 0.3.30 running: yes 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 v: kernel port: d000 bus-ID: 03:00.0 
           chip-ID: 10ec:8168 class-ID: 0200 
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: Ralink MT7601U Wireless Adapter type: USB driver: mt7601u bus-ID: 2-1.2:3 chip-ID: 148f:7601 
           class-ID: 0000 serial: <filter> 
           IF: wlan0 state: down mac: <filter> 
Drives:    Local Storage: total: 2.78 TiB used: 431.75 GiB (15.1%) 
           SMART Message: Required tool smartctl not installed. Check --recommends 
           ID-1: /dev/sda maj-min: 8:0 model: SATA SSD size: 55.9 GiB block-size: physical: 512 B logical: 512 B 
           speed: 3.0 Gb/s rotation: SSD serial: <filter> rev: Sb10 scheme: GPT 
           ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST3000NM0053 size: 2.73 TiB block-size: physical: 512 B 
           logical: 512 B speed: 3.0 Gb/s rotation: 7200 rpm serial: <filter> rev: G00A scheme: GPT 
Partition: ID-1: / raw-size: 389.6 GiB size: 389.6 GiB (100.00%) used: 184.11 GiB (47.3%) fs: btrfs dev: /dev/sdb1 
           maj-min: 8:17 
           ID-2: /boot/efi raw-size: 5.59 GiB size: 5.58 GiB (99.80%) used: 210.2 MiB (3.7%) fs: vfat dev: /dev/sda2 
           maj-min: 8:2 
           ID-3: /home raw-size: 389.6 GiB size: 389.6 GiB (100.00%) used: 184.11 GiB (47.3%) fs: btrfs dev: /dev/sdb1 
           maj-min: 8:17 
           ID-4: /var/log raw-size: 389.6 GiB size: 389.6 GiB (100.00%) used: 184.11 GiB (47.3%) fs: btrfs dev: /dev/sdb1 
           maj-min: 8:17 
           ID-5: /var/tmp raw-size: 389.6 GiB size: 389.6 GiB (100.00%) used: 184.11 GiB (47.3%) fs: btrfs dev: /dev/sdb1 
           maj-min: 8:17 
Swap:      Kernel: swappiness: 10 (default 60) cache-pressure: 75 (default 100) 
           ID-1: swap-1 type: zram size: 971.3 MiB used: 18.9 MiB (1.9%) priority: 32767 dev: /dev/zram0 
           ID-2: swap-2 type: zram size: 971.3 MiB used: 14.8 MiB (1.5%) priority: 32767 dev: /dev/zram1 
           ID-3: swap-3 type: zram size: 971.3 MiB used: 15 MiB (1.5%) priority: 32767 dev: /dev/zram2 
           ID-4: swap-4 type: zram size: 971.3 MiB used: 14.8 MiB (1.5%) priority: 32767 dev: /dev/zram3 
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 29 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 33% 
Info:      Processes: 240 Uptime: 7m wakeups: 0 Memory: 3.79 GiB used: 2.43 GiB (63.9%) Init: systemd v: 248 tool: systemctl 
           Compilers: gcc: 11.1.0 alt: 10 clang: 12.0.0 Packages: pacman: 2076 lib: 536 flatpak: 0 Shell: fish v: 3.2.2 
           running-in: qterminal inxi: 3.3.04 
1 Like

Please wait a few days with the update :slight_smile:

2 Likes

Okay then.