Davinci Resolve "GPU memory is full" and no menus

I had this issue before re-installing Garuda and wanted to see whether the problem persists. It does persist on a brand new setup.

First, I don’t get access to the application menus.

Second, as soon as I insert a video clip into the timeline, it says “GPU memory is full”.

btw I did try to diagnose this in the past without success, and reported it both here and in BlackMagic forum, with 0 response. And here I’m on clean install so it should be working. I would think it would have been fixed by now but apparently not.

Is DaVinci working fine for others? It’s literally the only real option for video editing on Linux; it sucks to have to revert to Adobe Premiere in a VM as the only option.

Inxi

System:
Kernel: 6.9.2-1-cachyos arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-cachyos
root=UUID=b3842975-a07f-4abe-a1f6-66b8fcf79638 rw rootflags=subvol=@
quiet loglevel=3 intel_iommu=on iommu=pt isolcpus=2-7 nohz_full=2-7
rcu_nocbs=2-7 transparent_hugepage=never rd.driver.pre=vfio-pci vfio
pci.ids=10de:1f15,10de:10f9,10de:1ada,10de:1adb
pcie_acs_override=downstream,multifunction ibt=off
Desktop: KDE Plasma v: 6.0.5 tk: Qt v: N/A info: frameworks v: 6.2.0
wm: kwin_x11 with: krunner vt: 2 dm: SDDM Distro: Garuda base: Arch Linux
Machine:
Type: Laptop System: Acer product: Predator PH315-53 v: V2.04
serial: <superuser required>
Mobo: CML model: QX50_CMS v: V2.04 serial: <superuser required>
part-nu: 0000000000000000 uuid: <superuser required> UEFI: Insyde v: 2.04
date: 08/20/2021
Battery:
ID-1: BAT1 charge: 40.7 Wh (100.0%) condition: 40.7/58.8 Wh (69.2%)
volts: 16.4 min: 15.4 model: SMP AP18E7M type: Li-ion serial: <filter>
status: full
CPU:
Info: model: Intel Core i7-10750H bits: 64 type: MT MCP arch: Comet Lake
gen: core 10 level: v3 note: check built: 2020 process: Intel 14nm family: 6
model-id: 0xA5 (165) stepping: 2 microcode: 0xFA
Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
L3: 12 MiB desc: 1x12 MiB
Speed (MHz): avg: 1798 high: 2800 min/max: 800/5000 scaling:
driver: intel_pstate governor: powersave cores: 1: 2800 2: 2800 3: 800
4: 800 5: 800 6: 800 7: 800 8: 800 9: 2782 10: 2794 11: 2800 12: 2800
bogomips: 62399
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: Intel CometLake-H GT2 [UHD Graphics] vendor: Acer Incorporated ALI
driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
ports: active: none off: eDP-1 empty: HDMI-A-2 bus-ID: 00:02.0
chip-ID: 8086:9bc4 class-ID: 0300
Device-2: NVIDIA TU106M [GeForce RTX 2060 Mobile]
vendor: Acer Incorporated ALI driver: nvidia v: 550.78
alternate: nouveau,nvidia_drm non-free: 550.xx+ status: current (as of
2024-04; EOL~2026-12-xx) arch: Turing code: TUxxx process: TSMC 12nm FF
built: 2018-2022 pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3
speed: 8 GT/s ports: active: none off: HDMI-A-1 empty: DP-1
bus-ID: 01:00.0 chip-ID: 10de:1f15 class-ID: 0300
Device-3: Quanta HD User Facing driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-5:3 chip-ID: 0408:a061
class-ID: 0e02
Display: x11 server: X.Org v: 21.1.13 with: Xwayland v: 24.1.0
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia unloaded: nouveau
alternate: fbdev,intel,nv,vesa dri: iris gpu: i915,nvidia,nvidia-nvswitch
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: HDMI-A-1 mapped: HDMI-1-0 note: disabled pos: primary
model: Samsung serial: <filter> built: 2016 res: 1920x1080 hz: 60 dpi: 40
gamma: 1.2 size: 1210x680mm (47.64x26.77") diag: 1168mm (46") ratio: 16:9
modes: max: 1920x1080 min: 640x480
Monitor-2: eDP-1 note: disabled model: AU Optronics 0x82ed built: 2018
res: 1920x1080 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
diag: 394mm (15.5") ratio: 16:9 modes: 1920x1080
API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
drv: nvidia device: 2 drv: iris device: 3 drv: swrast gbm: drv: nvidia
surfaceless: drv: nvidia x11: drv: iris inactive: wayland,device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 24.1.0-arch1.1.1
glx-v: 1.4 direct-render: yes renderer: Mesa Intel UHD Graphics (CML GT2)
device-ID: 8086:9bc4 memory: 7.54 GiB unified: yes
API: Vulkan v: 1.3.285 layers: 4 device: 0 type: integrated-gpu name: Intel
UHD Graphics (CML GT2) driver: mesa intel v: 24.1.0-arch1.1.1
device-ID: 8086:9bc4 surfaces: xcb,xlib device: 1 type: discrete-gpu
name: NVIDIA GeForce RTX 2060 driver: nvidia v: 550.78
device-ID: 10de:1f15 surfaces: xcb,xlib device: 2 type: cpu name: llvmpipe
(LLVM 17.0.6 256 bits) driver: mesa llvmpipe v: 24.1.0-arch1.1.1 (LLVM
17.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Audio:
Device-1: Intel Comet Lake PCH cAVS vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel alternate: snd_soc_skl, snd_soc_avs,
snd_sof_pci_intel_cnl bus-ID: 00:1f.3 chip-ID: 8086:06c8 class-ID: 0403
Device-2: NVIDIA TU106 High Definition Audio vendor: Acer Incorporated ALI
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:10f9 class-ID: 0403
Device-3: Texas Instruments PCM2900B Audio CODEC
driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 2.0 speed: 12 Mb/s
lanes: 1 mode: 1.1 bus-ID: 1-1.3:6 chip-ID: 08bb:29b0 class-ID: 0300
API: ALSA v: k6.9.2-1-cachyos status: kernel-api tools: N/A
Server-1: PipeWire v: 1.0.7 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Intel Comet Lake PCH CNVi WiFi vendor: Rivet Networks Dual Band
Wi-Fi 6 Killer AX1650i 160MHz 2x2 driver: iwlwifi v: kernel
bus-ID: 00:14.3 chip-ID: 8086:06f0 class-ID: 0280
IF: wlp0s20f3 state: up mac: <filter>
Device-2: Realtek Killer E2600 GbE vendor: Acer Incorporated ALI
driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: 3000
bus-ID: 08:00.0 chip-ID: 10ec:2600 class-ID: 0200
IF: enp8s0 state: down mac: <filter>
Info: services: NetworkManager, smbd, systemd-timesyncd, wpa_supplicant
Bluetooth:
Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-14:5 chip-ID: 8087:0026
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: <filter> bt-v: 5.2 lmp-v: 11
status: discoverable: no pairing: no
Drives:
Local Storage: total: 6.83 TiB used: 873.87 GiB (12.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN730
SDBQNTY-512G-1014 size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 11101100 temp: 24.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:2 vendor: Western Digital
model: WD Blue SN570 2TB size: 1.82 TiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 234200WD temp: 45.9 C scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: HGST (Hitachi) model: HTS721010A9E630
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 7200 serial: <filter> fw-rev: A3J0 scheme: GPT
ID-4: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD40NDZW-11A8JS1 size: 3.64 TiB block-size: physical: 4096 B
logical: 512 B type: USB rev: 3.2 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1
tech: HDD rpm: 5400 serial: <filter> fw-rev: 1023 scheme: GPT
Partition:
ID-1: / raw-size: 781.15 GiB size: 781.15 GiB (100.00%)
used: 198.58 GiB (25.4%) fs: btrfs dev: /dev/nvme1n1p1 maj-min: 259:3
ID-2: /boot/efi raw-size: 301 MiB size: 300.4 MiB (99.79%)
used: 584 KiB (0.2%) fs: vfat dev: /dev/nvme1n1p3 maj-min: 259:5
ID-3: /home raw-size: 781.15 GiB size: 781.15 GiB (100.00%)
used: 198.58 GiB (25.4%) fs: btrfs dev: /dev/nvme1n1p1 maj-min: 259:3
ID-4: /var/log raw-size: 781.15 GiB size: 781.15 GiB (100.00%)
used: 198.58 GiB (25.4%) fs: btrfs dev: /dev/nvme1n1p1 maj-min: 259:3
ID-5: /var/tmp raw-size: 781.15 GiB size: 781.15 GiB (100.00%)
used: 198.58 GiB (25.4%) fs: btrfs dev: /dev/nvme1n1p1 maj-min: 259:3
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.45 GiB used: 52.5 MiB (0.3%)
priority: 100 comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 12
dev: /dev/zram0
ID-2: swap-2 type: partition size: 11.72 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme1n1p2 maj-min: 259:4
Sensors:
System Temperatures: cpu: 71.0 C pch: 72.0 C mobo: N/A
Fan Speeds (rpm): N/A
Info:
Memory: total: 16 GiB available: 15.45 GiB used: 6.33 GiB (41.0%)
Processes: 372 Power: uptime: 5h 17m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 1 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 6.14 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: pm: pacman pkgs: 1637 libs: 445 tools: octopi,paru Compilers:
gcc: 14.1.1 Shell: garuda-inxi default: fish v: 3.7.1 running-in: konsole
inxi: 3.3.34
Garuda (2.6.26-1):
System install date:     2024-05-30
Last full system update: 2024-05-30 ↻
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:

Which Version of Davinci Resolve you wanna run?

You have 2 GPU’s did you set it right up?

Did you read the Documentation about using it on Linux Systems?

Nvidia Driver
Ensure that you have the recommended Nvidia driver downloaded and installed from https://www.nvidia.com/Download/
driverResults.aspx/204837/en-us. For Rocky Linux 8, CentOS 8 and RHEL 8, follow these steps:
1. Download the driver. The file name should look like: NVIDIA-Linux-x86_64-525.116.04.run.
2. Please save your work and exit any applications in use. This process will require a system reboot.
3. Open a Terminal shell.
4. Switch to the root user. Type: su - and enter the 'root' password when prompted.
5. Disable the Linux desktop and switch to a text interface. Type: init 3
6. You will be prompted at the terminal for a username. Type: root and enter the 'root' password when prompted.
7. Navigate to the folder with the downloaded driver. Type: cd /path/to/downloaded/location
8. Run the driver installer. Type: sh NVIDIA-Linux-x86_64-525.116.04.run --silent --no-network
9. Wait for the installer to complete. Reboot the machine by typing: reboot

may this driver helps you out, i found this in 30 sec searching :wink:

There is more good Video editing software for linux but we dont know what you want to do with it.

1 Like

That is also a issue you need maybe more Ram by Davicie Resolve 19 Beta 32GB Ram preffered.

i have 64GB Ram and save for future stuff lol :wink:

i found other Post from you and you would to all the stuff with those lappy loool better build a good Computer and your good with the same price of a Gaming Lappy btw :wink:

1 Like

You can’t bring a desktop PC in a plane.

loool

its your setup of Technics.

i have a Gaming Lappy and its more issues beside my good gaming pc .

did you checked the doc or the new nvidia driver for davinci?

plane too or login on your pc with ssh as remote whatever . lol it was only my setup for davinci btw.

check it and give a result!

I tried installing it on Fedora to see if it would go better. There are a few hoops to go through to install it, but there are guides detailing it very well.

I finally have access to the menus! Which allows me to go in DaVinci Preference, and I can see it is using NVidia card.

Sadly, I am again getting the GPU memory is full error. Others are also reporting the same problem in Linux Mint.

It would be nice to have access to the app menu in Garuda though. It’s probably the special bar at the top that’s not compatible; so perhaps the only way is reverting back to a more standard theme layout?

Try reducing the resolution for the preview in the timeline.
Try switching from OpenCL to CUDA in the DaVinci settings when the Nvidia card is set as default.
Try setting the Intel iGPU as default in the DaVinci settings and check whether the “GPU memory is full” error still occurs.
There is a start parameter for DaVinci that solves this issue for some people, but I can’t remember it - try searching for it on the Internet.

Looks like DaVinci is not compatible with the KDE Plasma Global Menu - try a theme without a Global Menu, for example Breeze.

2 Likes

I’m on Fedora so that I can know what issues are OS-specific and what issues persist.

Intel GPU doesn’t even show up in DaVinci. CUDA is selected by default; manually selecting OpenGL works!

As for KDE Plasma Global Menu… works fine in Fedora + Otto theme. BUT dragging or double-clicking cannot restore from full-screen either, and there’s no button to reduce the window, so I’m locked in full screen.

As for the NVIDIA driver version; the readme says to manually install it in a special way, is that a good idea? Fedora usually installs it with RPM Fusion, Arch with nvidia-all script. I’m not sure installing it in a spcial way for a specific app is a great idea; and I doubt it would auto-update properly.

Try adding the “Window Buttons” widget to the top panel or double click on the window title (DaVinci Resolve) or use “SUPER + Arrow Keys” (left/right/up/down) on your keyboard.

I wouldn’t recommend this on Arch/Archbased, you’ll just unnecessarily introduce new sources of error to your system.

1 Like