Cursor Customization Question

Hello Garuda Linux Forums,

As a new user of Garuda Linux (and Linux distributions in general), I am still trying to learn the basics of how to use and customize Linux. As I was changing my cursor to one of the default themes included in Garuda Linux, I realized that these cursors were often replaced when the cursor hovered over a specific application. For example, if I had switched my cursor theme to Adwaita, and hovered my cursor over Google Chrome, the cursor would revert back to the default cursor (Sweet-cursors) as long as my cursor hovered over the application. A similar case was also shown when hovering the mouse over the Unity Linux Editor, where the cursor would always switch to Adwaita as long as the cursor hovered over the application itself.

From research, this seems to be a recurring issue in Linux, with some sort of issue as to how the cursor themes are handled when entering other applications (from my basic understanding). However, I have not found a specific fix that had worked for me and one that applied to Garuda Linux. Does anyone have any insight as to what the issue might be, or a workaround or how I could resolve this issue (if it can be resolved at all)?

Regards,
Spxctre

Do you always reboot, or at least log out/in between changes? KDE usually needs it.

2 Likes

Probably those are all GTK applications?

4 Likes

I will try that because I have never had to do that previously in Windows.

Well I wouldn't think that would be the issue, because the Unity Editor seems to automatically change the cursor to Adwaita anyway, so I'm not sure if that's just an outlier or not.

Statements like that can get you booted from some Linux forums (not here...I think).

The usual reply to such statements is something like this...

We do not care what happens in Windows. This is Linux!

:smiley:

5 Likes

Think again. :wink:

https://wiki.archlinux.org/index.php/Uniform_look_for_Qt_and_GTK_applications

GTK- and Qt-based applications do not share toolkit settings, hence why the Garuda maintainers spent a lot of time making sure everything looks consistent.

5 Likes

Well thank god, and thanks for the tips! It's not like people using Linux have not once been the ones that were new to it, and I certainly hope people use a user-friendly distribution if they dare use Linux for their first operating system.

Ah, alright, thanks for the clarification!

As a reply to the previous tip to "restart or log-out after style changes", would that help "fix" the issue I'm currently having? As @jonathon mentioned, certain GTK- or Qt- applications have different appearances, so I doubt this would "override" the styles of those applications. I'm just trying to have a consistent cursor appearance regardless of application, but at least from the limited research I've conducted, there doesn't seem to be a "universal style override" or of sorts (at least not one that I've heard of or worked for me).

Check your settings under Settings>Appearance>Configure GNOME/GTK Application Style. Also, you can use Kvantum to help configure non-QT/KDE settingts on a per-application basis.

It is typically easier to decorate such applications in KDE than the reverse is for running non-GNOME/GTK applications in a GNOME environment. In those cases, something like Kvantum is a must.

regards

3 Likes

Thanks for your help! Your tips have helped greatly, I was able to find the issue.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.