Cursor and desktop access issue in dual screen mode

Good evening

Thanks again for your support on other tickets

I have an HP Omen gaming laptop

This is the spec I see when I open Konsole:
OS: Garuda Linux
Host: HP 838F
Kernel: 5.17.5-zen1-2-zen
DE: Plasma 5.24.5
WM: KWin
CPU: Intel i7-7700HQ (8) @ 3.8GHz
GPU: NVIDIA GeForce GTX 1050 Ti Mobile
GPU: Intel HD Graphics 630
Memory: 2.42GiB / 15.50GiB

I currently have the Optimus app set at Nvidia

When I first installed Garuda, my docked external Dell monitor was not recognised

I then installed Displaylink software via your support on another thread and the monitor now appears in Display settings. I have identified both screens and have set the Dell monitor above my laptop, which is how they are set physically

The issue arises when I try to set the Dell as the primary. The laptop screen goes blank but remains backlit. The cursor appears on the blank laptop screen and I can only move it within the parameters of that blank screen,i.e I cannot reach the Dell monitor and menu options thereof. So I can't actually use the software

If I make the laptop primary, the opposite happens and I have a blank backlit Dell monitor and the cursor appears there, but I can't do anything except move the cursor within the confines of that screen, i.e I am unable to access the desktop displayed on the laptop below and once again, can't do anything

Have you seen anything like this before?

Hoping you can help as not having both screens working is a major productivity killer

Cheers
Raaj

Please always provide the output of your garuda-inxi when opening a new topic, as text, formatted with a
~~~
before and after, as instructed by the template.

1 Like

Sure per below

╭─[email protected] in ~  
╰─λ garuda-inxi
System:
Kernel: 5.17.5-zen1-2-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=afb70ee0-c7d2-4f39-bf24-5bdab8fb41b1 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.3 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: HP product: OMEN by HP Laptop 15-ce0xx v: N/A
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: HP model: 838F v: 40.28 serial: <superuser required>
UEFI: American Megatrends v: F.19 date: 04/18/2019
Battery:
ID-1: BAT0 charge: 61.6 Wh (100.0%) condition: 61.6/61.6 Wh (100.0%)
volts: 17.2 min: 15.4 model: HP Primary type: Li-ion serial: N/A
status: full
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master
serial: <filter> charge: 100% (should be ignored) rechargeable: yes
status: discharging
CPU:
Info: model: Intel Core i7-7700HQ bits: 64 type: MT MCP arch: Kaby Lake
family: 6 model-id: 0x9E (158) stepping: 9 microcode: 0xEC
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 6 MiB desc: 1x6 MiB
Speed (MHz): avg: 1037 high: 1100 min/max: 800/3800 scaling:
driver: intel_pstate governor: powersave cores: 1: 909 2: 1000 3: 1000
4: 1062 5: 1100 6: 1087 7: 1072 8: 1073 bogomips: 44798
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX unsupported
Type: l1tf mitigation: PTE Inversion
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel HD Graphics 630 vendor: Hewlett-Packard driver: i915
v: kernel ports: active: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 00:02.0
chip-ID: 8086:591b class-ID: 0300
Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile]
vendor: Hewlett-Packard driver: nvidia v: 510.68.02
alternate: nouveau,nvidia_drm pcie: gen: 3 speed: 8 GT/s lanes: 8
link-max: lanes: 16 ports: active: none empty: DP-2,HDMI-A-2
bus-ID: 01:00.0 chip-ID: 10de:1c8c class-ID: 0300
Device-3: Realtek HP Wide Vision FHD Camera type: USB driver: uvcvideo
bus-ID: 1-6:5 chip-ID: 0bda:58e6 class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia gpu: i915
display-ID: :0 screens: 1
Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
s-diag: 582mm (22.93")
Monitor-1: eDP-1 mapped: eDP-1-1 model: AU Optronics 0x45ed built: 2017
res: 1920x1080 hz: 120 dpi: 142 gamma: 1.2 size: 344x193mm (13.54x7.6")
diag: 394mm (15.5") ratio: 16:9 modes: 1920x1080
OpenGL: renderer: NVIDIA GeForce GTX 1050 Ti/PCIe/SSE2
v: 4.6.0 NVIDIA 510.68.02 direct render: Yes
Audio:
Device-1: Intel CM238 HD Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a171
class-ID: 0403
Device-2: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 8 link-max: lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:0fb9 class-ID: 0403
Sound Server-1: ALSA v: k5.17.5-zen1-2-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.51 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 3b:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: eno1 state: down mac: <filter>
Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 bus-ID: 3c:00.0 chip-ID: 8086:095a class-ID: 0280
IF: wlo1 state: up mac: <filter>
Bluetooth:
Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
bus-ID: 1-7:8 chip-ID: 8087:0a2a class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
Local Storage: total: 1.14 TiB used: 110.71 GiB (9.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba model: N/A
size: 238.47 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: AAHA4102
temp: 35.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: HGST (Hitachi) model: HTS721010A9E630
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: A3T0
scheme: GPT
Partition:
ID-1: / raw-size: 79.17 GiB size: 79.17 GiB (100.00%)
used: 17.99 GiB (22.7%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
used: 48.1 MiB (50.1%) fs: vfat dev: /dev/nvme0n1p2 maj-min: 259:2
ID-3: /home raw-size: 79.17 GiB size: 79.17 GiB (100.00%)
used: 17.99 GiB (22.7%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
ID-4: /var/log raw-size: 79.17 GiB size: 79.17 GiB (100.00%)
used: 17.99 GiB (22.7%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
ID-5: /var/tmp raw-size: 79.17 GiB size: 79.17 GiB (100.00%)
used: 17.99 GiB (22.7%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 2 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/nvme0n1p7 maj-min: 259:7
ID-2: swap-2 type: zram size: 15.5 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 61.0 C pch: 61.0 C mobo: N/A gpu: nvidia
temp: 56 C
Fan Speeds (RPM): cpu: 7680 fan-2: 0
Info:
Processes: 304 Uptime: 52m wakeups: 3 Memory: 15.5 GiB
used: 3.48 GiB (22.4%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 12.1.0 Packages: pacman: 1610 lib: 385 Shell: fish v: 3.4.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.15
Garuda (2.6.2-1):
System install date:     2022-05-07
Last full system update: 2022-05-11 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:
1 Like

Please format this properly like filo literally just said above lol

1 Like

╭─[email protected] in ~ took 416ms
[:mag:] × ~~~
garuda-inxi


find-the-command: "~~~" is not found locally, searching in repositories...

find-the-command: command not found: ~~~
System:
Kernel: 5.17.5-zen1-2-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=afb70ee0-c7d2-4f39-bf24-5bdab8fb41b1 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.3 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: HP product: OMEN by HP Laptop 15-ce0xx v: N/A
serial: <superuser required> Chassis: type: 10 serial: <superuser required>
Mobo: HP model: 838F v: 40.28 serial: <superuser required>
UEFI: American Megatrends v: F.19 date: 04/18/2019
Battery:
ID-1: BAT0 charge: 61.6 Wh (100.0%) condition: 61.6/61.6 Wh (100.0%)
volts: 17.2 min: 15.4 model: HP Primary type: Li-ion serial: N/A
status: full
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse MX Master
serial: <filter> charge: 100% (should be ignored) rechargeable: yes
status: discharging
CPU:
Info: model: Intel Core i7-7700HQ bits: 64 type: MT MCP arch: Kaby Lake
family: 6 model-id: 0x9E (158) stepping: 9 microcode: 0xEC
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 6 MiB desc: 1x6 MiB
Speed (MHz): avg: 2196 high: 2200 min/max: 800/3800 scaling:
driver: intel_pstate governor: powersave cores: 1: 2200 2: 2200 3: 2200
4: 2200 5: 2185 6: 2200 7: 2200 8: 2184 bogomips: 44798
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX unsupported
Type: l1tf mitigation: PTE Inversion
Type: mds mitigation: Clear CPU buffers; SMT vulnerable
Type: meltdown mitigation: PTI
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
STIBP: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: Intel HD Graphics 630 vendor: Hewlett-Packard driver: i915
v: kernel ports: active: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 00:02.0
chip-ID: 8086:591b class-ID: 0300
Device-2: NVIDIA GP107M [GeForce GTX 1050 Ti Mobile]
vendor: Hewlett-Packard driver: nvidia v: 510.68.02
alternate: nouveau,nvidia_drm pcie: gen: 3 speed: 8 GT/s lanes: 8
link-max: lanes: 16 ports: active: none empty: DP-2,HDMI-A-2
bus-ID: 01:00.0 chip-ID: 10de:1c8c class-ID: 0300
Device-3: Razer USA Gaming Webcam [Kiyo] type: USB
driver: snd-usb-audio,uvcvideo bus-ID: 1-1.4.2:20 chip-ID: 1532:0e03
class-ID: 0102
Device-4: Realtek HP Wide Vision FHD Camera type: USB driver: uvcvideo
bus-ID: 1-6:5 chip-ID: 0bda:58e6 class-ID: 0e02 serial: <filter>
Display: x11 server: X.Org v: 21.1.3 with: Xwayland v: 22.1.1
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia gpu: evdi,i915
display-ID: :0 screens: 1
Screen-1: 0 s-res: 2740x4114 s-dpi: 96 s-size: 724x1088mm (28.50x42.83")
s-diag: 1307mm (51.45")
Monitor-1: DVI-I-1 mapped: DVI-I-2-1 pos: primary,top-left
model: Dell U2518D serial: <filter> built: 2019 res: 2560x1440 hz: 60
dpi: 118 gamma: 1.2 size: 553x311mm (21.77x12.24") diag: 634mm (25")
ratio: 16:9 modes: max: 2560x1440 min: 720x400
Monitor-2: eDP-1 mapped: eDP-1-1 pos: bottom-r model: AU Optronics 0x45ed
built: 2017 res: 1920x1080 hz: 120 dpi: 142 gamma: 1.2
size: 344x193mm (13.54x7.6") diag: 394mm (15.5") ratio: 16:9
modes: 1920x1080
OpenGL: renderer: NVIDIA GeForce GTX 1050 Ti/PCIe/SSE2
v: 4.6.0 NVIDIA 510.68.02 direct render: Yes
Audio:
Device-1: Intel CM238 HD Audio vendor: Hewlett-Packard
driver: snd_hda_intel v: kernel bus-ID: 00:1f.3 chip-ID: 8086:a171
class-ID: 0403
Device-2: NVIDIA GP107GL High Definition Audio driver: snd_hda_intel
v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 8 link-max: lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:0fb9 class-ID: 0403
Device-3: GN Netcom Jabra Link 380 type: USB
driver: jabra,snd-usb-audio,usbhid bus-ID: 1-1.2.1:18 chip-ID: 0b0e:24c9
class-ID: 0300 serial: <filter>
Device-4: Razer USA Gaming Webcam [Kiyo] type: USB
driver: snd-usb-audio,uvcvideo bus-ID: 1-1.4.2:20 chip-ID: 1532:0e03
class-ID: 0102
Device-5: DisplayLink dynadock U3.0 type: USB
driver: cdc_ncm,snd-usb-audio,usbfs bus-ID: 2-1.1:6 chip-ID: 17e9:4305
class-ID: 0a00 serial: <filter>
Sound Server-1: ALSA v: k5.17.5-zen1-2-zen running: yes
Sound Server-2: PulseAudio v: 15.0 running: no
Sound Server-3: PipeWire v: 0.3.51 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Hewlett-Packard driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 3b:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: eno1 state: down mac: <filter>
Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 bus-ID: 3c:00.0 chip-ID: 8086:095a class-ID: 0280
IF: wlo1 state: up mac: <filter>
IF-ID-1: enp0s20f0u1u1i5 state: up speed: 1000 Mbps duplex: half
mac: <filter>
Bluetooth:
Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
bus-ID: 1-7:8 chip-ID: 8087:0a2a class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 1 state: up address: <filter>
Drives:
Local Storage: total: 1.14 TiB used: 111.14 GiB (9.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Toshiba model: N/A
size: 238.47 GiB block-size: physical: 512 B logical: 512 B
speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: AAHA4102
temp: 36.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: HGST (Hitachi) model: HTS721010A9E630
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter> rev: A3T0
scheme: GPT
Partition:
ID-1: / raw-size: 79.17 GiB size: 79.17 GiB (100.00%)
used: 18.42 GiB (23.3%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
used: 48.1 MiB (50.1%) fs: vfat dev: /dev/nvme0n1p2 maj-min: 259:2
ID-3: /home raw-size: 79.17 GiB size: 79.17 GiB (100.00%)
used: 18.42 GiB (23.3%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
ID-4: /var/log raw-size: 79.17 GiB size: 79.17 GiB (100.00%)
used: 18.42 GiB (23.3%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
ID-5: /var/tmp raw-size: 79.17 GiB size: 79.17 GiB (100.00%)
used: 18.42 GiB (23.3%) fs: btrfs dev: /dev/nvme0n1p6 maj-min: 259:6
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: partition size: 2 GiB used: 0 KiB (0.0%) priority: -2
dev: /dev/nvme0n1p7 maj-min: 259:7
ID-2: swap-2 type: zram size: 15.5 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
Sensors:
System Temperatures: cpu: 68.0 C pch: 64.5 C mobo: N/A gpu: nvidia
temp: 60 C
Fan Speeds (RPM): cpu: 7680 fan-2: 0
Info:
Processes: 305 Uptime: 26m wakeups: 3 Memory: 15.5 GiB
used: 3.23 GiB (20.9%) Init: systemd v: 250 tool: systemctl Compilers:
gcc: 12.1.0 Packages: pacman: 1610 lib: 385 Shell: fish v: 3.4.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.15
Garuda (2.6.2-1):
System install date:     2022-05-07
Last full system update: 2022-05-11
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:
find-the-command: "~~~" is not found locally, searching in repositories...

find-the-command: command not found: ~~~
fish:

The ~~~ is only for the forum software to make it more readable.
It's a pain in smartphones to scroll through long terminal outputs. :slight_smile:

Reminder, reboot the system after update

Done :slight_smile:

2 Likes

If no software requires a Primary monitor set, don't set anyone primary.
Plasma has issues with multi-monitors. Check upstream KDE bugs to see how many.

Setting a monitor as Primary, is not a personal preference of how the user thinks it should be called. It's a technical configuration. It is an old deprecated setting that is confusing recent software and users, because some developers had used it in a few programs.
So, if a program needs it, we can see if there is an alternative solution or workaround.

4 Likes

Thanks for the advice all

Setting as primary means it becomes my main desktop screen

This is beneficial as it is bigger than the laptop screen

I also have that residual issue that the other screen is affected too and I cannot effectively work either

Noted re bugs

I am returning to Kde after years away - last time I used it I had a regular desktop PC with a single monitor

I moved to a laptop solution as I liked the dual screen capability but was not expecting this sort of issue

As I explained, it is a user conception. Primary is not a label, or a tag.
Even if it was, how is a label or tag beneficial in action?
I am trying to explain that we need a description of your actual problem, not what you think is nicer to have or look at.

I have moved away of KDE because of the problematic performance with special dual monitor setups.
With bspwm I have peace and if I want more, I prefer Gnome.

1 Like

Sorry I thought I had stated problem already and not sure why we are digressing

The use case is the ability to work on 2 screens i.e the laptop and the external monitor attached via the docking station. How they are labelled is not a concern and I was referring to what I see in the actual software

The ability to work on the external monitor as the main screen is a genuine productivity benefit - not sure why that would be difficult to understand. It is an actual user requirement and not an aesthetic. Ultimately, it will determine the extent to which I use Garuda i.e in laptop mode only away from desk but not when docked - because again, I need the productivity boost of being able to work effectively across 2 spaces at once

Noted re KDE bugs and I will factor that in as well

For now though, you can close this thread as I have made some partial progress - I now have access to both screens and can drag and drop windows and documents across both screens so that gives me the productivity benefit I seek

Unfortunately, one screen remains blank but I can live with that as long as I can use it. Can't say what the "solution" was unfortunately as I have been generally googling and tinkering and trying various things

Cheers
R

Closed per user request, without a solution, since the user does not understand how computers work in Archlinux and therefor does not provide answers that would help solve their issue.