CSGO microstutters

I'm experiencing frequent micro-stutters while playing CSGO (I haven't tried other games) which are starting to get really annoying.
I have tried disabling conky, setting the power options to prefer max performance and the card to prefer performance over quality, but I am still experiencing it. This didn't happen in Manjaro so I'm suspecting that it might a tweak of sorts or an installed library.

Please let me know what you need in order to help me out with this issue and again thanks :slight_smile:

Output of
inxi -Fxxxza

1 Like
System:    Kernel: 5.8.13-zen1-2-zen x86_64 bits: 64 compiler: N/A 
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen root=UUID=d2b3cc8d-298f-4a88-ade5-9a65c3e90e32 rw 
           [email protected] quiet splash resume=UUID=36bd1e62-f76c-487b-a5fb-a696bd74aa50 loglevel=3 
           Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4 dm: LightDM 1.30.0 Distro: Garuda Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: ROG STRIX B360-F GAMING v: Rev 1.xx serial: <filter> UEFI: American Megatrends 
           v: 1901 date: 02/20/2020 
CPU:       Info: 8-Core model: Intel Core i7-9700F bits: 64 type: MCP arch: Kaby Lake family: 6 model-id: 9E (158) 
           stepping: D (13) microcode: D6 L2 cache: 12.0 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 48000 
           Speed: 800 MHz min/max: 800/3000 MHz Core speeds (MHz): 1: 800 2: 800 3: 800 4: 800 5: 800 6: 800 7: 800 8: 800 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
           Type: l1tf status: Not affected 
           Type: mds status: Not affected 
           Type: meltdown status: Not affected 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling 
           Type: srbds mitigation: TSX disabled 
           Type: tsx_async_abort mitigation: TSX disabled 
Graphics:  Device-1: NVIDIA TU104 [GeForce RTX 2080 SUPER] vendor: ASUSTeK driver: nvidia v: 455.23.04 
           alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:1e81 
           Display: x11 server: X.Org 1.20.9 driver: nvidia display ID: :0.0 screens: 1 
           Screen-1: 0 s-res: 2560x1440 s-dpi: 96 s-size: 677x381mm (26.7x15.0") s-diag: 777mm (30.6") 
           Monitor-1: DP-0 res: 2560x1440 dpi: 109 size: 597x336mm (23.5x13.2") diag: 685mm (27") 
           OpenGL: renderer: GeForce RTX 2080 SUPER/PCIe/SSE2 v: 4.6.0 NVIDIA 455.23.04 direct render: Yes 
Audio:     Device-1: Intel Cannon Lake PCH cAVS vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           alternate: snd_soc_skl,snd_sof_pci bus ID: 00:1f.3 chip ID: 8086:a348 
           Device-2: NVIDIA TU104 HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel bus ID: 01:00.1 chip ID: 10de:10f8 
           Device-3: SteelSeries ApS SteelSeries Arctis 7 type: USB driver: hid-generic,snd-usb-audio,usbhid bus ID: 1-8:3 
           chip ID: 1038:12ad 
           Sound Server: ALSA v: k5.8.13-zen1-2-zen 
Network:   Device-1: Intel Ethernet I219-V vendor: ASUSTeK driver: e1000e v: 3.2.6-k port: efa0 bus ID: 00:1f.6 
           chip ID: 8086:15bc 
           IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter> 
Drives:    Local Storage: total: 1.14 TiB used: 38.23 GiB (3.3%) 
           SMART Message: Required tool smartctl not installed. Check --recommends 
           ID-1: /dev/nvme0n1 vendor: Kingston model: SA2000M81000G size: 931.51 GiB block size: physical: 512 B 
           logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: S5Z42102 scheme: GPT 
           ID-2: /dev/nvme1n1 vendor: Kingston model: SA2000M8250G size: 232.89 GiB block size: physical: 512 B logical: 512 B 
           speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: S5Z42102 scheme: GPT 
Partition: ID-1: / raw size: 914.11 GiB size: 914.11 GiB (100.00%) used: 38.23 GiB (4.2%) fs: btrfs dev: /dev/nvme0n1p2 
           ID-2: /home raw size: 914.11 GiB size: 914.11 GiB (100.00%) used: 38.23 GiB (4.2%) fs: btrfs dev: /dev/nvme0n1p2 
Swap:      Kernel: swappiness: 10 (default 60) cache pressure: 75 (default 100) 
           ID-1: swap-1 type: partition size: 17.11 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/nvme0n1p3 
           ID-2: swap-2 type: zram size: 497.8 MiB used: 256 KiB (0.1%) priority: 32767 dev: /dev/zram0 
           ID-3: swap-3 type: zram size: 497.8 MiB used: 256 KiB (0.1%) priority: 32767 dev: /dev/zram1 
           ID-4: swap-4 type: zram size: 497.8 MiB used: 256 KiB (0.1%) priority: 32767 dev: /dev/zram2 
           ID-5: swap-5 type: zram size: 497.8 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram3 
           ID-6: swap-6 type: zram size: 497.8 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram4 
           ID-7: swap-7 type: zram size: 497.8 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram5 
           ID-8: swap-8 type: zram size: 497.8 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram6 
           ID-9: swap-9 type: zram size: 497.8 MiB used: 0 KiB (0.0%) priority: 32767 dev: /dev/zram7 
Sensors:   System Temperatures: cpu: 27.8 C mobo: N/A gpu: nvidia temp: 54 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 37% 
Info:      Processes: 301 Uptime: 2h 26m Memory: 15.55 GiB used: 3.01 GiB (19.3%) Init: systemd v: 246 Compilers: gcc: 10.2.0 
           clang: 10.0.1 Packages: pacman: 1788 lib: 552 flatpak: 0 Shell: Zsh v: 5.8 running in: xfce4-terminal inxi: 3.1.06

Run the game

For Steam games, you can add this as a launch option:

mangohud %command%

And check the usage and cpu freq

See

How much is being used

goverlay

Is graphical app to adjust what info gets shown.

2 Likes

Since I can't upload videos here I used YT. Please see video for reference to FPS-drops.

It almost seems as if it slows down and goes fast...

Alright, fellas. After a bit of tinkering I found out what the culprit was: CoreCtl seems to be preset at 'Powersave' - setting this to 'Performance' seemed to solve the problem but I am not sure if that is so safe for the CPU in the long run, so if anyone has got any tips & tricks they might want to share, please do :slight_smile:

2 Likes

What is the output of

systemctl status auto-cpufreq

And

auto-cpufreq --log
1 Like
● auto-cpufreq.service - auto-cpufreq - Automatic CPU speed & power optimizer for Linux
     Loaded: loaded (/usr/lib/systemd/system/auto-cpufreq.service; enabled; vendor preset: disabled)
     Active: active (running) since Mon 2020-10-05 17:34:45 CEST; 2h 5min ago
   Main PID: 2106 (auto-cpufreq)
      Tasks: 2 (limit: 19060)
     Memory: 31.3M
     CGroup: /system.slice/auto-cpufreq.service
             ├─  2106 /usr/sbin/python /usr/bin/auto-cpufreq --daemon
             └─240652 /bin/sh -c cpufreqctl --driver

okt. 05 17:34:45 linux-desktop systemd[1]: Started auto-cpufreq - Automatic CPU speed & power optimizer for Linux.
CPU max frequency: 3000 MHz
CPU min frequency: 800 MHz

	 Usage  Temperature  Frequency
CPU0:	  3.0%     33 °C      800 MHz
CPU1:	  3.1%     33 °C      800 MHz
CPU2:	  4.9%     34 °C      800 MHz
CPU3:	  2.0%     32 °C      800 MHz
CPU4:	  1.0%     32 °C      800 MHz
CPU5:	  5.9%     32 °C      800 MHz
CPU6:	  4.1%     34 °C      800 MHz
CPU7:	  3.0%     35 °C      800 MHz

---------------------------- CPU frequency scaling ----------------------------

Battery is: discharging

Setting to use: "powersave" governor
Setting to use: "balance_power" EPP

Total CPU usage: 2.4 %
Total system load: 0.87 

Load optimal, setting turbo boost: off

EDIT: I see that it says that the battery is discharging even though I use a desktop-PC?

1 Like

Okay its a bug in auto-cpufreq

Need to report it

Can you do it?

So it will be solved by the dev

2 Likes

Sure thing, my man :sunglasses:

1 Like

I had the same issue, but this fix didn't work for me!

Hi there, welcome to the community.

Please open a new topic. It is over an year old post, and things might have changed since then.

1 Like

Necro bump prohibited.