Crash after Lagging

While watching a video on Chrome, I opened Steam, and then experienced some lagging with the mouse and the video’s sound. I closed Chrome and my external monitor. After using prime-run gamemoderun osu-lazer in the terminal, I switched back to check nvidia-smi. When I returned to the game, the system froze (no response from the mouse, and the NumLock or CapsLk lights on the keyboard were unresponsive), but the game’s music continued to play. Switching back to tty was ineffective, so I directly used fn+alt+s+o to shut down the system. How can I fix this frequent crashing issue?

λ garuda-inxi
System:
Kernel: 6.1.66-1-lts arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
root=UUID=49b0511d-6878-4919-9909-f6f569ab1a2a rw rootflags=subvol=@
quiet resume=UUID=910d388a-9bc3-42b7-b7e5-227f9cd546dd loglevel=3
nvidia-drm.modeset=1 splash sysrq_always_enabled=1
systemd.unified_cgroup_hierarchy=1 nowatchdog nvme_load=YES ibt=off
Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.11 wm: kwin_x11 vt: 2
dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Laptop System: LENOVO product: 82RF v: Legion Y9000P IAH7H
serial: <superuser required> Chassis: type: 10 v: Legion Y9000P IAH7H
serial: <superuser required>
Mobo: LENOVO model: LNVNB161216 v: 31900002 WIN
serial: <superuser required> UEFI: LENOVO v: J2CN54WW date: 07/10/2023
Battery:
ID-1: BAT0 charge: 75.1 Wh (100.0%) condition: 75.1/80.0 Wh (93.9%)
volts: 16.6 min: 15.4 model: Sunwoda L21D4PC1 type: Li-poly serial: <filter>
status: full cycles: 38
CPU:
Info: model: 12th Gen Intel Core i7-12700H bits: 64 type: MST AMCP
arch: Alder Lake gen: core 12 level: v3 note: check built: 2021+
process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 3
microcode: 0x430
Topology: cpus: 1x cores: 14 mt: 6 tpc: 2 st: 8 threads: 20 smt: enabled
cache: L1: 1.2 MiB desc: d-8x32 KiB, 6x48 KiB; i-6x32 KiB, 8x64 KiB
L2: 11.5 MiB desc: 6x1.2 MiB, 2x2 MiB L3: 24 MiB desc: 1x24 MiB
Speed (MHz): avg: 552 high: 912 min/max: 400/4600:4700:3500 scaling:
driver: intel_pstate governor: powersave cores: 1: 691 2: 400 3: 845 4: 400
5: 912 6: 400 7: 872 8: 400 9: 891 10: 400 11: 741 12: 632 13: 536 14: 528
15: 400 16: 400 17: 400 18: 400 19: 400 20: 400 bogomips: 107560
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: Intel Alder Lake-P GT2 [Iris Xe Graphics] vendor: Lenovo
driver: i915 v: kernel arch: Gen-12.2 process: Intel 10nm built: 2021-22+
ports: active: eDP-1 empty: DP-1,DP-2 bus-ID: 0000:00:02.0
chip-ID: 8086:46a6 class-ID: 0300
Device-2: NVIDIA GA104M [Geforce RTX 3070 Ti Laptop GPU] vendor: Lenovo
driver: nvidia v: 545.29.06 alternate: nouveau,nvidia_drm non-free: 545.xx+
status: current (as of 2023-10; EOL~2026-12-xx) arch: Ampere code: GAxxx
process: TSMC n7 (7nm) built: 2020-2023 ports: active: none off: HDMI-A-1
empty: DP-3,DP-4,eDP-2 bus-ID: 0000:01:00.0 chip-ID: 10de:24e0
class-ID: 0300
Display: x11 server: X.Org v: 21.1.9 with: Xwayland v: 23.2.2
compositor: kwin_x11 driver: X: loaded: modesetting,nvidia unloaded: nouveau
alternate: fbdev,intel,nv,vesa dri: iris gpu: i915,nvidia,nvidia-nvswitch
display-ID: :0 screens: 1
Screen-1: 0 s-res: 2560x1600 s-dpi: 96 s-size: 677x423mm (26.65x16.65")
s-diag: 798mm (31.43")
Monitor-1: HDMI-A-1 mapped: HDMI-1-0 note: disabled
model: Lenovo LEN L175A serial: <filter> built: 2009 res: N/A dpi: 96
gamma: 1.2 size: 340x270mm (13.39x10.63") diag: 434mm (17.1") ratio: 5:4
modes: max: 1280x1024 min: 640x480
Monitor-2: eDP-1 pos: primary model: BOE Display 0x0a40 built: 2021
res: 2560x1600 hz: 165 dpi: 189 gamma: 1.2 size: 344x215mm (13.54x8.46")
diag: 406mm (16") ratio: 16:10 modes: 2560x1600
API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
drv: nvidia device: 1 drv: iris device: 3 drv: swrast gbm: drv: iris
surfaceless: drv: nvidia x11: drv: iris inactive: wayland,device-2
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 23.2.1-arch1.2
glx-v: 1.4 direct-render: yes renderer: Mesa Intel Graphics (ADL GT2)
device-ID: 8086:46a6 memory: 14.98 GiB unified: yes
API: Vulkan v: 1.3.269 layers: 8 device: 0 type: integrated-gpu name: Intel
Graphics (ADL GT2) driver: mesa intel v: 23.2.1-arch1.2
device-ID: 8086:46a6 surfaces: xcb,xlib device: 1 type: discrete-gpu
name: NVIDIA GeForce RTX 3070 Ti Laptop GPU driver: nvidia v: 545.29.06
device-ID: 10de:24e0 surfaces: xcb,xlib device: 2 type: cpu name: llvmpipe
(LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.2.1-arch1.2 (LLVM
16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Audio:
Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: Lenovo
driver: snd_hda_intel v: kernel alternate: snd_sof_pci_intel_tgl
bus-ID: 0000:00:1f.3 chip-ID: 8086:51c8 class-ID: 0403
Device-2: NVIDIA GA104 High Definition Audio vendor: Lenovo
driver: snd_hda_intel v: kernel bus-ID: 0000:01:00.1 chip-ID: 10de:228b
class-ID: 0403
Device-3: Shure MV7 driver: hid-generic,snd-usb-audio,usbhid type: USB
rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-4.1:5
chip-ID: 14ed:1012 class-ID: 0300
API: ALSA v: k6.1.66-1-lts status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 0000:00:14.3 chip-ID: 8086:51f0 class-ID: 0280
IF: wlp0s20f3 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Lenovo driver: r8169 v: kernel port: 3000 bus-ID: 0000:32:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp50s0 state: down mac: <filter>
Bluetooth:
Device-1: Intel AX211 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-10:6 chip-ID: 8087:0033
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: <filter> bt-v: 5.3 lmp-v: 12
status: discoverable: no pairing: no
RAID:
Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:467f rev: class-ID: 0104
Drives:
Local Storage: total: 1.4 TiB used: 18.71 GiB (1.3%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:6 vendor: Kingbank model: KP260
size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: SN07443 temp: 48.9 C
scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: SanDisk
model: SKHynix HFS512GEJ9X115N size: 476.94 GiB block-size: physical: 512 B
logical: 512 B speed: 63.2 Gb/s lanes: 4 tech: SSD serial: <filter>
fw-rev: 51010A12 temp: 46.9 C scheme: GPT
Partition:
ID-1: / raw-size: 936.7 GiB size: 936.7 GiB (100.00%) used: 18.7 GiB (2.0%)
fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:8
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 4.7 MiB (1.6%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:7
ID-3: /home raw-size: 936.7 GiB size: 936.7 GiB (100.00%)
used: 18.7 GiB (2.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:8
ID-4: /var/log raw-size: 936.7 GiB size: 936.7 GiB (100.00%)
used: 18.7 GiB (2.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:8
ID-5: /var/tmp raw-size: 936.7 GiB size: 936.7 GiB (100.00%)
used: 18.7 GiB (2.0%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:8
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: partition size: 16.87 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:9
ID-2: swap-2 type: zram size: 15.34 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 20 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 50.0 C mobo: N/A
Fan Speeds (rpm): N/A
Info:
Processes: 386 Uptime: 17m wakeups: 0 Memory: total: 16 GiB note: est.
available: 15.34 GiB used: 4.65 GiB (30.3%) Init: systemd v: 255
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1498 libs: 461 tools: octopi,paru Shell: fish v: 3.6.2
running-in: konsole inxi: 3.3.31
Garuda (2.6.19-2):
System install date:     2023-12-10
Last full system update: 2023-12-10
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       Probably (Run as root to verify)
Failed units:
λ journalctl -b -1 -p3 --no-hostname --no-pager
12月 10 23:20:14 kernel:
12月 10 23:20:14 kernel: NVRM: loading NVIDIA UNIX x86_64 Kernel Module  545.29.06  Thu Nov 16 01:59:08 UTC 2023
12月 10 23:20:18 kernel: spi-nor spi0.1: BFPT parsing failed. Please consider using SPI_NOR_SKIP_SFDP when declaring the flash
12月 10 23:20:19 kernel: Bluetooth: hci0: Malformed MSFT vendor event: 0x02
12月 10 23:20:20 bluetoothd[916]: Failed to set mode: Failed (0x03)
12月 10 23:20:25 systemd[1609]: Failed to start Profile-sync-daemon.
12月 10 23:20:27 bluetoothd[916]: Failed to set mode: Failed (0x03)
12月 11 00:27:44 sudo[8738]:   biaogo : a password is required ; TTY=pts/0 ; PWD=/home/biaogo ; USER=root ; COMMAND=/usr/bin/true
12月 11 00:29:34 sudo[10404]:   biaogo : a password is required ; TTY=pts/0 ; PWD=/home/biaogo ; USER=root ; COMMAND=/usr/bin/true
12月 11 00:29:44 sudo[10609]:   biaogo : a password is required ; TTY=pts/0 ; PWD=/home/biaogo ; USER=root ; COMMAND=/usr/bin/true
12月 11 00:29:51 systemd-coredump[10791]: [🡕] Process 10762 (fastfetch) of user 1000 dumped core.

Stack trace of thread 10768:
#0  0x00007f61c9e8f782 n/a (n/a + 0x0)
ELF object binary architecture: AMD x86-64
12月 11 00:29:51 sudo[10814]:   biaogo : a password is required ; TTY=pts/1 ; PWD=/home/biaogo ; USER=root ; COMMAND=/usr/bin/true
12月 11 00:29:51 sudo[10840]:   biaogo : a password is required ; TTY=pts/1 ; PWD=/home/biaogo ; USER=root ; COMMAND=/usr/bin/true
12月 11 00:29:56 sudo[10941]:   biaogo : a password is required ; TTY=pts/1 ; PWD=/home/biaogo ; USER=root ; COMMAND=/usr/bin/true
12月 11 00:37:14 kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PC00.LPCB.EC0._Q38.PNOT], AE_NOT_FOUND (20220331/psargs-330)
12月 11 00:37:14 kernel: ACPI Error: Aborting method \_SB.PC00.LPCB.EC0._Q38 due to previous error (AE_NOT_FOUND) (20220331/psparse-529)
12月 11 00:38:26 kernel: ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PC00.LPCB.EC0._Q37.PNOT], AE_NOT_FOUND (20220331/psargs-330)
12月 11 00:38:26 kernel: ACPI Error: Aborting method \_SB.PC00.LPCB.EC0._Q37 due to previous error (AE_NOT_FOUND) (20220331/psparse-529)

fastfetch is somehow crashing so consider updating or reinstalling it , and there is some errors related to Bluetooth (can argue the relation with crashing your system, it may contribute to instability) so consider updating and restarting your system using sudo garuda-update

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.