CPU freq governors revert back within seconds

I see Dr460nized has "powersave" as the CPU governor but I want to change that.

So I issued sudo sh -c "echo performance > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor"

It did change immediately, but 2sec later it reverted back to "powersave".

I tried the same for "ondemand" and reverts back.

This change worked on my Kubuntu, it there an extra step to perform with Garuda?
Or maybe it has to be changed somewhere else.

You might want to turn off auto-cpufreq, this automatically adjusts the CPU governor used.

sudo systemctl disable --now auto-cpufreq

Oh, auto-cpufreq is enabled, here.

It works, thanks!

1 Like

It seems "ondemand" governor has been tweaked, at least compared to Kubuntu it is.

And I can tell you "ondemand" works perfect!!! It does EXACTLY what I want. Damn you guys are awesome. :smiley:

1 Like