CPU always Boosting to Max Clock Rate

I daily drive Manjaro KDE and just found out about Garuda so I am trying it out cause I like the philosophy of maximising performance using the given resources. However I noticed my CPU temps were higher and all Cores were Boosting to 4Ghz (i5-9400F btw) even when the System is idle.
Is there a way to turn this off / let the Clock Rates drop when the System is not doing anything? because now the CPU fan is noticeably louder and the Temps are higher

Hi and welcome KamikazeGrandma :wave:

If you go into Garuda Assistand > Settings, you'll see this

Try the Powersave-Tweaks and play with the settings.

In the Application Launcher > Settings, you will find core control and fancontrols also.

4 Likes

Wow thanks for the fast response, I'll fiddle around with settings

1 Like

Yeah - thing with this is make notes as to what you did and the results - experiment. :grin:

3 Likes

Sounds like it’s doing exactly what it’s intending to: maximising performance. :wink:

2 Likes

Kinda silly that the processor clocks are above 4 GHz just when browsing the web or typing emails.