Could not activate remote peer - Apps broken after updating

When opening certain apps like Telegram or Spectacle using the print screen button, I get an error message saying, as an example:

“Could not activate remote peer ‘org.kde.spectacle’: startup job failed”.

I have tried re-installing both, which has not helped.

I tried launching both in a terminal which prompted the following:

alyxx  ~  ♥ 13:44  telegram-desktop
telegram-desktop: error while loading shared libraries: libplacebo.so.338: cannot open shared object file: No such file or directory

alyxx  ~  ♥ 13:44  spectacle
spectacle: error while loading shared libraries: libplacebo.so.338: cannot open shared object file: No such file or directory

I have ensured libplacebo is installed so this is a strange error to get… I guess something broken in the latest version of it…

garuda-inxi output:

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = "",
LC_ALL = (unset),
LC_ADDRESS = "nb_NO.UTF-8",
LC_NAME = "en_GB.UTF-8",
LC_MONETARY = "nb_NO.UTF-8",
LC_PAPER = "en_GB.UTF-8",
LC_IDENTIFICATION = "en_GB.UTF-8",
LC_TELEPHONE = "nb_NO.UTF-8",
LC_MEASUREMENT = "nb_NO.UTF-8",
LC_TIME = "en_GB.UTF-8",
LC_NUMERIC = "en_GB.UTF-8",
LANG = "en_US.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to a fallback locale ("en_US.UTF-8").
System:
Kernel: 6.9.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 14.1.1
clocksource: tsc avail: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=ffaee389-c347-4d17-addc-0485b1ce1aca rw rootflags=subvol=@
loglevel=3 ibt=off
Desktop: KDE Plasma v: 6.1.2 tk: Qt v: N/A info: frameworks v: 6.3.0
wm: kwin_wayland vt: 1 dm: SDDM Distro: Garuda base: Arch Linux
Machine:
Type: Laptop System: ASUSTeK product: ASUS TUF Gaming F15 FX507ZC4_FX507ZC4
v: 1.0 serial: <superuser required>
Mobo: ASUSTeK model: FX507ZC4 v: 1.0 serial: <superuser required>
uuid: <superuser required> UEFI: American Megatrends LLC. v: FX507ZC4.307
date: 10/05/2023
Battery:
ID-1: BAT1 charge: 52.6 Wh (100.0%) condition: 52.6/55.9 Wh (94.1%)
volts: 17.3 min: 15.9 model: ASUS A32-K55 type: Li-ion serial: N/A
status: full
CPU:
Info: model: 12th Gen Intel Core i5-12500H bits: 64 type: MST AMCP
arch: Alder Lake gen: core 12 level: v3 note: check built: 2021+
process: Intel 7 (10nm ESF) family: 6 model-id: 0x9A (154) stepping: 3
microcode: 0x433
Topology: cpus: 1x cores: 12 mt: 4 tpc: 2 st: 8 threads: 16 smt: enabled
cache: L1: 1.1 MiB desc: d-8x32 KiB, 4x48 KiB; i-4x32 KiB, 8x64 KiB
L2: 9 MiB desc: 4x1.2 MiB, 2x2 MiB L3: 18 MiB desc: 1x18 MiB
Speed (MHz): avg: 1721 high: 4326 min/max: 400/4500:3300 scaling:
driver: intel_pstate governor: powersave cores: 1: 1111 2: 1096 3: 4326
4: 400 5: 3114 6: 4131 7: 1342 8: 1016 9: 2374 10: 1710 11: 400 12: 400
13: 2005 14: 400 15: 2092 16: 1629 bogomips: 99532
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Graphics:
Device-1: Intel Alder Lake-P GT2 [Iris Xe Graphics] vendor: ASUSTeK
driver: i915 v: kernel alternate: xe arch: Gen-12.2 process: Intel 10nm
built: 2021-22+ ports: active: eDP-2 empty: DP-2,DP-3 bus-ID: 0000:00:02.0
chip-ID: 8086:46a6 class-ID: 0300
Device-2: NVIDIA GA107M [GeForce RTX 3050 Mobile] vendor: ASUSTeK
driver: nvidia v: 555.58.02 alternate: nouveau,nvidia_drm non-free: 550.xx+
status: current (as of 2024-06; EOL~2026-12-xx) arch: Ampere code: GAxxx
process: TSMC n7 (7nm) built: 2020-2023 ports: active: none
empty: DP-1,HDMI-A-1,eDP-1 bus-ID: 0000:01:00.0 chip-ID: 10de:25a2
class-ID: 0300
Device-3: EVGA XR1 Lite Capture Box Video
driver: hid-generic,snd-usb-audio,usbhid,uvcvideo type: USB rev: 3.0
speed: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 bus-ID: 2-1.2:4
chip-ID: 3842:310a class-ID: 0300 serial: <filter>
Device-4: Sonix USB2.0 HD UVC WebCam driver: uvcvideo type: USB rev: 2.0
speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 3-7:5 chip-ID: 2b7e:b685
class-ID: 0e02
Display: wayland server: X.org v: 1.21.1.13 with: Xwayland v: 24.1.0
compositor: kwin_wayland driver: X: loaded: modesetting,nvidia
unloaded: nouveau alternate: fbdev,intel,nv,vesa dri: iris
gpu: i915,nvidia display-ID: 0
Monitor-1: eDP-2 res: 1745x982 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: intel iris drv: nvidia platforms: device: 0
drv: nvidia device: 2 drv: iris device: 3 drv: swrast gbm: drv: nvidia
surfaceless: drv: nvidia wayland: drv: iris x11: drv: iris
inactive: device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: intel mesa v: 24.1.3-arch1.1
glx-v: 1.4 direct-render: yes renderer: Mesa Intel Graphics (ADL GT2)
device-ID: 8086:46a6 memory: 7.46 GiB unified: yes display-ID: :1.0
API: Vulkan v: 1.3.279 layers: 14 device: 0 type: integrated-gpu
name: Intel Graphics (ADL GT2) driver: mesa intel v: 24.1.3-arch1.1
device-ID: 8086:46a6 surfaces: xcb,xlib,wayland device: 1
type: discrete-gpu name: NVIDIA GeForce RTX 3050 Laptop GPU driver: nvidia
v: 555.58.02 device-ID: 10de:25a2 surfaces: xcb,xlib,wayland device: 2
type: cpu name: llvmpipe (LLVM 18.1.8 256 bits) driver: mesa llvmpipe
v: 24.1.3-arch1.1 (LLVM 18.1.8) device-ID: 10005:0000
surfaces: xcb,xlib,wayland
Audio:
Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel alternate: snd_soc_avs,snd_sof_pci_intel_tgl
bus-ID: 0000:00:1f.3 chip-ID: 8086:51c8 class-ID: 0403
Device-2: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel
bus-ID: 0000:01:00.1 chip-ID: 10de:2291 class-ID: 0403
Device-3: EVGA XR1 Lite Capture Box Video
driver: hid-generic,snd-usb-audio,usbhid,uvcvideo type: USB rev: 3.0
speed: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 bus-ID: 2-1.2:4
chip-ID: 3842:310a class-ID: 0300 serial: <filter>
Device-4: Cooler Master MH752 driver: hid-generic,snd-usb-audio,usbhid
type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-4.3:4
chip-ID: 2516:0093 class-ID: 0300 serial: <filter>
API: ALSA v: k6.9.7-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 1.2.0 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Intel Alder Lake-P PCH CNVi WiFi driver: iwlwifi v: kernel
bus-ID: 0000:00:14.3 chip-ID: 8086:51f0 class-ID: 0280
IF: wlo1 state: up mac: <filter>
Device-2: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK driver: r8169 v: kernel port: 3000 bus-ID: 0000:2c:00.0
chip-ID: 10ec:8168 class-ID: 0200
IF: enp44s0 state: down mac: <filter>
Info: services: NetworkManager, smbd, systemd-timesyncd, wpa_supplicant
Bluetooth:
Device-1: Intel AX201 Bluetooth driver: btusb v: 0.8 type: USB rev: 2.0
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 3-10:7 chip-ID: 8087:0026
class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
rfk-block: hardware: no software: no address: <filter> bt-v: 5.2 lmp-v: 11
status: discoverable: no pairing: no
Device-2: Cambridge Silicon Radio Bluetooth Dongle (HCI mode)
driver: btusb v: 0.8 type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1
bus-ID: 3-5.4:10 chip-ID: 0a12:0001 class-ID: e001
Report: ID: hci1 rfk-id: 1 state: up address: <filter> bt-v: 4.0 lmp-v: 6
status: discoverable: no pairing: no class-ID: 6c010c
RAID:
Hardware-1: Intel Volume Management Device NVMe RAID Controller driver: vmd
v: 0.6 port: N/A bus-ID: 0000:00:0e.0 chip-ID: 8086:467f rev: class-ID: 0104
Drives:
Local Storage: total: 2.29 TiB used: 433.58 GiB (18.5%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNU512GZ
size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 002C temp: 36.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:2 vendor: Crucial model: CT1000P3SSD8
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: P9CR311 temp: 45.9 C
scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: Seagate model: One Touch HDD
size: 931.51 GiB block-size: physical: 4096 B logical: 512 B type: USB
rev: 3.2 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: N/A serial: <filter>
fw-rev: 1708 scheme: MBR
Partition:
ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 433.58 GiB (46.6%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:4
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 584 KiB (0.2%) fs: vfat dev: /dev/nvme1n1p1 maj-min: 259:3
ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 433.58 GiB (46.6%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:4
ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 433.58 GiB (46.6%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:4
ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 433.58 GiB (46.6%) fs: btrfs dev: /dev/nvme1n1p2 maj-min: 259:4
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.28 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 16 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 52.0 C mobo: N/A
Fan Speeds (rpm): cpu: 3000
Info:
Memory: total: 16 GiB available: 15.28 GiB used: 4.57 GiB (29.9%)
Processes: 382 Power: uptime: 0m states: freeze,mem,disk suspend: s2idle
avail: deep wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 6.07 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 256 default: graphical
tool: systemctl
Packages: pm: pacman pkgs: 2148 libs: 609 tools: octopi,paru Compilers:
clang: 18.1.8 gcc: 14.1.1 Shell: garuda-inxi default: fish v: 3.7.1
running-in: konsole inxi: 3.3.35
Garuda (2.6.26-1):
System install date:     2024-06-08
Last full system update: 2024-07-07
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       Probably (Run as root to verify)
Failed units:            run-media-alyxx-SYS2.mount

Hi there, welcome to the forum.
Libplacebo was updated yesteday providing a soname (libplacebo.so.349) newer than the one needed by those two apps (which will have to be updated or rebuilt)
https://archlinux.org/packages/extra/x86_64/libplacebo/
Maybe you could try

downgrade libplacebo 

Consistent with this Arch forum topic
https://bbs.archlinux.org/viewtopic.php?id=297472

3 Likes

I uninstalled mpv and downgraded libplacebo, which solved the issue. Hopefully I can safely upgrade it later on.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.