Correct way to setup chinese input methods

I tried setting up chinese pinyin input with both ibus and fcitx on Garuda Dr490nized KDE. Neither one worked. I'm fairly new to using Linux and I wanted to know if there was a correct way to go about setting up Chinese input with Garuda KDE. Note that it's not an issue with fonts or displaying characters. Chinese characters show up just fine, it's just that I'm unable to type them in Garuda.

UPDATE: I noticed that the ibus pinyin actually works on some applications (like the brave web browser or dolphin, but not in others, like libreoffice, kate, konsole, to name a few). I am able to copy and paste chinese text into those programs just fine. Is there a way to consistently get chinese input across applications?

System Settings -> Input Devices -> Keyboard -> Layouts -> :heavy_check_mark: Configure layouts -> :heavy_plus_sign: add

3 Likes

This didn't work, actually

Neither did this blog, which made me think this is a common problem in KDE environments.

You probably have to confirm the proper environment variables are set.

Follow this guide, depending what you use.
https://wiki.archlinux.org/title/Input_method#Configuration

2 Likes

我找到正确方法了...你还需要吗?