Correct plymouth/boot theme not showing up on boot

You mean like this one?

Yeah, just the ellipses changes size and placement for funzies.

1 Like

Oh..
So you got this issue in your barebones install.
Did you have this in your dragonized install?

Thanks

I don't use Dragonized. I run Garuda XFCE and then did the barebones (since it's KDE) to test if the Garuda KDE build would function on my machine. On my XFCE install most times I get nothing...then once in a while bird'n-spinny-circles. Once I added the Barebones I get the rando ellipses -sometimes-

1 Like

I am using KDE barebone right now and am having the issue.

So my question is, what is it the dev have modified to make the plymouth work in Dragonized edition? :thinking:

They gave it stank eye :wink: The stankiest of DRAGON eyes ;0

How many times do we have to write this?

Garuda Linux Barebones

Garuda Linux Barebones is made for users who do not want extra software and functionalities and complain about bloat. It contains only the bare minimum of packages needed to get started.

(You are on your own, we dont provide any support for Barebones editions!)

3 Likes

Vat in De HEZZ is going on with this thread? ;p It's like Katy Perry up in here, hot then it's cold is open then it's closed. ;p

Glad to see it open though because
#1 it happens on non-barebones (I'm on the XFCE release ;p)

#2 just because barebones is an "on your own" situation doesn't change the fact it only shows intermittantly too, just the ellipses when it does while the XFCE does the bird / circles. Also barebones isn't very bare. I expected NO DE but it's got KDE which was surprising but then given that how was I supposed to know the fancy boot screen wasn't supposed to be there? ;p

#3 I've also noticed comically some times the bird / circles is stretched and ooogleh. i.e. 4:3 image filling a 16.9 screen. Kinda silly if the point is to look pretty while indicating stuff is going on. Hey look stretched out derpbird!

#4 I never reported this as a problem i.e. I'd rather not have these things covering up time wasters like stop jobs and the like. I'd rather see what's going on. I got roped into this as a joke on the silliness chit chat. ;p

1 Like

I want it fixed because, it's working in all other linux installations of mine.
And a good Plymouth is the first impression of a distro.
Though I maybe even ok without a Plymouth, but beginners are going to notice it and noobies might even be startled with the green background stuff on boot :grin:

So why not fix it?

You have GRUB_TIMEOUT=5 twice. This one that I've highlighted is:

# Set to 'countdown' or 'hidden' to change timeout behavior,
# press ESC key to display menu.
GRUB_TIMEOUT_STYLE=menu

In the default barebones installation, that I've just downloaded and installed in a virtio KVM.
I'm really unsure the effect of this change / removal of timeout_style.
N.B. The plymouth has so far worked fine.

1 Like
  • I tried as you suggested, replacing the extra GRUB_TIMEOUT=5 with GRUB_TIMEOUT_STYLE=menu
    No effect
❯ sudo mv /etc/default/grub /etc/default/grub.backup
[sudo] password for austin:      

~
❯ cd /run/media/austin/Void\ Linux/@/etc/default/

/run/media/austin/Void Linux/@/etc/default
❯ ls
drwxr-xr-x    - root  5 Oct 17:54  grub-btrfs
.rw-r--r--  377 root 17 Mar 19:25  efibootmgr-kernel-hook
.rw-r--r--  771 root 15 Nov 12:56  grub
.rw-r--r--  713 root 26 Sep 10:17  grub.bak
.rw-r--r-- 9.8k root 21 May 23:33  libc-locales
.rw-r--r--   14 root 23 Sep 14:09  live.conf
.rw-r--r--  117 root 14 Feb  2020  useradd

/run/media/austin/Void Linux/@/etc/default
❯ sudo cp grub /etc/default/grub

/etc/default
❯ sudo update-grub


  • I tried swapping Garuda's /etc/default/grub with my Void_Linux installation's /etc/default/grub cause the Plymouth was working fine there.
    Still same issue

  • I even tried replacing /etc/default/grub with a minimal one:

  GNU nano 5.9                                                      /etc/default/grub                                                                

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="Garuda"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

Still no luck

I think we can conclude that it has nothing to do with grub and /etc/default/grub


@anon26187667 Do you mean the Plymouth is working fine in a V.M.?

Thank You

Did you have a chance to give a look at the relevant Arch Wiki entry and play around, e.g., with ShowDelay in /etc/plymouth/plymouthd.conf? Or the correct hook set-up.
https://wiki.archlinux.org/title/Plymouth#Configuration

3 Likes

I will check it out and report later this day

Which GPU you have
It's specific to GPU used
Also show your
/etc/mkinitcpio.conf

4 Likes

/etc/mkinitcpio.conf:

# vim:set ft=sh
# MODULES
# The following modules are loaded before any boot hooks are
# run.  Advanced users may wish to specify all system modules
# in this array.  For instance:
#     MODULES=(piix ide_disk reiserfs)
MODULES="crc32c-intel"

# BINARIES
# This setting includes any additional binaries a given user may
# wish into the CPIO image.  This is run last, so it may be used to
# override the actual binaries included by a given hook
# BINARIES are dependency parsed, so you may safely ignore libraries
BINARIES=()

# FILES
# This setting is similar to BINARIES above, however, files are added
# as-is and are not parsed in any way.  This is useful for config files.
FILES=""

# HOOKS
# This is the most important setting in this file.  The HOOKS control the
# modules and scripts added to the image, and what happens at boot time.
# Order is important, and it is recommended that you do not change the
# order in which HOOKS are added.  Run 'mkinitcpio -H <hook name>' for
# help on a given hook.
# 'base' is _required_ unless you know precisely what you are doing.
# 'udev' is _required_ in order to automatically load modules
# 'filesystems' is _required_ unless you specify your fs modules in MODULES
# Examples:
##   This setup specifies all modules in the MODULES setting above.
##   No raid, lvm2, or encrypted root is needed.
#    HOOKS=(base)
#
##   This setup will autodetect all modules for your system and should
##   work as a sane default
#    HOOKS=(base udev autodetect block filesystems)
#
##   This setup will generate a 'full' image which supports most systems.
##   No autodetection is done.
#    HOOKS=(base udev block filesystems)
#
##   This setup assembles a pata mdadm array with an encrypted root FS.
##   Note: See 'mkinitcpio -H mdadm' for more information on raid devices.
#    HOOKS=(base udev block mdadm encrypt filesystems)
#
##   This setup loads an lvm2 volume group on a usb device.
#    HOOKS=(base udev block lvm2 filesystems)
#
##   NOTE: If you have /usr on a separate partition, you MUST include the
#    usr, fsck and shutdown hooks.
HOOKS="base udev autodetect modconf block keyboard keymap consolefont plymouth filesystems"

# COMPRESSION
# Use this to compress the initramfs image. By default, zstd compression
# is used. Use 'cat' to create an uncompressed image.
#COMPRESSION="zstd"
#COMPRESSION="gzip"
#COMPRESSION="bzip2"
#COMPRESSION="lzma"
#COMPRESSION="xz"
#COMPRESSION="lzop"
#COMPRESSION="lz4"

# COMPRESSION_OPTIONS
# Additional options for the compressor
#COMPRESSION_OPTIONS=()

I have AMD radeon R5 M430

  • I found something interesting, this thing in itself is a Plymouth theme namely- text
    Plymouth - ArchWiki
    I tried changing the Plymouth in my Void installation to text ( sudo plymouth-set-default-theme -R text), and it gave me a Plymouth exactly like the pic.

Thank You

Hmmm
Add
modules=(amdgpu radeon)

Then
sudo mkinitcpio -P
update-grub

Reboot

5 Likes

I have a class right now, I will let you know in a couple of hours.

Thank you, @librewish; it worked!
Though one mistake I made was, my AMD Radeon was a discrete GPU, and my integrated GPU was an Intel one, so I just had to replace

with modules=(i915)

And it was mentioned about this in Plymouth - ArchWiki
But I couldn't have figured it out without help :relaxed:

1 Like