Correct plymouth/boot theme not showing up on boot

what does your /etc/default/grub look like? especially the GRUB_CMDLINE_LINUX_DEFAULT=<something> line?

1 Like

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3"

Is this happening with anyone else?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

You know what, I still have one issue unresolved in Garuda :rofl: :sweat_smile: :joy:

https://forum.garudalinux.org/t/correct-plymouth-boot-theme-not-showing-up-on-boot/12823/5

1 Like

yes it was the problem for me when i was using dragonized editon,
but in garuda sway it's not happening like that

1 Like

A post was merged into an existing topic: Show your Artwork :art:

yeah! me too, that's why i never created any thread related to this issue :crazy_face:

1 Like

I just wanted the issue to be solved; it's been almost 2-3 months now, and I was hoping some update would fix it, but alas, nothing has solved it till now.
I indirectly wanted to bring it to your notice, hoping someone would reopen the thread and help me with it.
It seems that everyone has the issue, I suppose.
What good is a beautiful Plymouth when it's not even displayed?
Not everyone wants to see what's going on behind the scenes. Even if they do, they could simply press an arrow key whenever required!

Please, stay on topic.

1 Like

PFtt now my booing him off the stage has no context ;p

I will say though this is a tad ironic because I like my greeters themed and all that but during boot and shutdown I hate things like the splash screens hiding what's going on. This is more so with those GD "Stop Jobs" when they hang your damn machine for up to five minutes some times.

2 Likes

Further down this than what was requested is:

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/path/to/wallpaper"
GRUB_THEME="/usr/share/grub/themes/garuda-dr460nized/theme.txt"

Is this appropriate in your grub, is the index file appropriate and does the image exist and named correctly?

My index:

title-text: ""
title-font: "DejaVu Sans Regular 48"
message-font: "Terminus 16"
message-color: "#7f8c8d"
message-bg-color: "#4d4d4d"
desktop-color: "#000000"
desktop-image: "background.png"
terminal-font: "Terminus 14"
terminal-left: "0"
terminal-top: "0"
terminal-width: "100%"
terminal-height: "100%"
terminal-border: "0"

+ label {
    top = 20%
    height = 35
    left = 0%
    width = 100%
#text = "Welcome to Garuda"
    align = "center"
    font = "DejaVu Sans Regular 48"
    color = "#ffffff"
}

+ boot_menu {
    left = 15%
    #width = 250
    width = 70%
    #top = 50%-125
    #height = 400
    top = 30%
    height = 44%
    item_height = 30
    item_padding = 5
    icon_width = 32
    icon_height = 32
    item_icon_space = 20
    item_spacing = 5
    item_font =  "Terminus 16"
    item_color = "#cccccc"
    #item_color = "#FFA2A2"
    selected_item_font = "Terminus 16"
    selected_item_color = "#02CCFC"
    selected_item_pixmap_style = "select_*.png"
    menu_pixmap_style = "menu_*.png"
}

#+ progress_bar {
#    id = "__timeout__"
#    left = 0
#    top = 100%-32
#    width = 100%
#    height = 32
#    show_text = false
#    bar_style = "progress_bar_*.png"
#    highlight_style = "progress_bar_hl_*.png"
#}

+ progress_bar {
    id = "__timeout__"
    left = 50%-125
    top = 70%
    width = 250
    height = 20
    show_text = true
    font = "Terminus 14"
    text_color = "#ffffff"
    align = "center"
    text = "@[email protected]"
    bar_style = "progress_bar2_*.png"
}

+ vbox {
    left = 50%-125
    top = 80%
    width = 250
    + label { width = 250 height = 20 align = "center" color = "#ffffff" font = "Terminus 16" text = "[↡] Boot selected OS" }
    + label { width = 250 height = 20 align = "center" color = "#ffffff" font = "Terminus 16" text = "[↑ and ↓ Key] Navigation" }
    + label { width = 250 height = 20 align = "center" color = "#ffffff" font = "Terminus 16" text = "[E] Edit Selection" }
    + label { width = 250 height = 20 align = "center" color = "#ffffff" font = "Terminus 16" text = "[C] GRUB Commandline" }
}


I do have background.png in that same directory (along with all the fonts).

But what several else would see is its working in other distros and not in Garuda

It works...it's just like nope, nope, nope, SURPRISE! Then I'm all like esc esc shift GO AWAY!

1 Like

Have you tried changing the splash screen in the Garuda Assistant to see if:
A) it then displays the different splash
B) can then be changed back and display the one you want

E2A: The OP is apparently going to bed and will respond tomorrow.
Dunno why they PM'd me rather than posting here, but I'm posting here to let the thread know.

2 Likes

Everything is just like yours!
And I have a background image too.
But I don't think it has to do anything with the Plymouth/splash?
And my grub is all working fine.

I tried, but it didn't work.

BTW, is the splash/Plymouth showing for you?

Sorry, I should have mentioned it here itself.

Here’s what it looks like when I boot my laptop just after the grub menu:

But while shutting down/rebooting, the Plymouth shows:

This is my /etc/default/grub:

# GRUB boot loader configuration

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="Garuda"
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1 loglevel=3"
GRUB_CMDLINE_LINUX=""

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Set to 'countdown' or 'hidden' to change timeout behavior,
# press ESC key to display menu.
GRUB_TIMEOUT=5

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
#GRUB_COLOR_NORMAL="light-blue/black"
#GRUB_COLOR_HIGHLIGHT="light-cyan/blue"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/path/to/wallpaper"
GRUB_THEME="/usr/share/grub/themes/garuda/theme.txt"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to make GRUB remember the last selection. This requires
# setting 'GRUB_DEFAULT=saved' above.
#GRUB_SAVEDEFAULT=true

# Uncomment to disable submenus in boot menu
#GRUB_DISABLE_SUBMENU=y

GRUB_DISABLE_OS_PROBER=false

1 Like

You know what's strange? When I did my second Garuda install last night (Barebones KDE) I started getting that gray with ellipses while booting. The ... ellipses is always on a different part of the screen but it's there.

1 Like

You mean like this one?