Controller detected as a mouse

i am trying to use my controller to play multiversus but it doesnt work because the joystick is recognise as a mouse and it seem that every game that i play with proton has this issue

garuda-inxi
System:
Kernel: 5.18.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=859b76f8-6f2a-49d6-a2ba-c39197e1548f rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
loglevel=3
Desktop: KDE Plasma v: 5.25.3 tk: Qt v: 5.15.5 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
Mobo: ASUSTeK model: PRIME H410M-A v: Rev 1.xx
serial: <superuser required> UEFI: American Megatrends v: 1402
date: 10/27/2020
Battery:
Device-1: ps-controller-battery-d0:bc:c1:dc:d5:df model: N/A serial: N/A
charge: N/A status: discharging
CPU:
Info: model: Intel Core i3-10100 bits: 64 type: MT MCP arch: Comet Lake
gen: core 10 built: 2020 process: Intel 14nm family: 6 model-id: 0xA5 (165)
stepping: 3 microcode: 0xF0
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 6 MiB desc: 1x6 MiB
Speed (MHz): avg: 4100 min/max: 800/4300 scaling: driver: intel_cpufreq
governor: performance cores: 1: 4100 2: 4100 3: 4100 4: 4100 5: 4100
6: 4100 7: 4100 8: 4100 bogomips: 57600
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities:
Type: itlb_multihit status: KVM: VMX disabled
Type: l1tf status: Not affected
Type: mds status: Not affected
Type: meltdown status: Not affected
Type: mmio_stale_data mitigation: Clear CPU buffers; SMT vulnerable
Type: spec_store_bypass
mitigation: Speculative Store Bypass disabled via prctl
Type: spectre_v1
mitigation: usercopy/swapgs barriers and __user pointer sanitization
Type: spectre_v2
mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
Type: srbds mitigation: Microcode
Type: tsx_async_abort status: Not affected
Graphics:
Device-1: NVIDIA TU116 [GeForce GTX 1660 SUPER] vendor: ZOTAC
driver: nvidia v: 515.57 alternate: nouveau,nvidia_drm non-free: 515.xx+
status: current (as of 2022-06) arch: Turing process: TSMC 12nm
built: 2018-22 pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.0
chip-ID: 10de:21c4 class-ID: 0300
Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 93 s-size: 1049x292mm (41.30x11.50")
s-diag: 1089mm (42.87")
Monitor-1: DP-4 pos: primary,left res: 1920x1080 dpi: 94
size: 521x293mm (20.51x11.54") diag: 598mm (23.53") modes: N/A
Monitor-2: HDMI-0 pos: right res: 1920x1080 hz: 60 dpi: 94
size: 521x293mm (20.51x11.54") diag: 598mm (23.53") modes: N/A
OpenGL: renderer: NVIDIA GeForce GTX 1660 SUPER/PCIe/SSE2
v: 4.6.0 NVIDIA 515.57 direct render: Yes
Audio:
Device-1: Intel Comet Lake PCH-V cAVS vendor: ASUSTeK driver: snd_hda_intel
v: kernel alternate: snd_sof_pci_intel_cnl bus-ID: 00:1f.3
chip-ID: 8086:a3f0 class-ID: 0403
Device-2: NVIDIA TU116 High Definition Audio vendor: ZOTAC
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
bus-ID: 01:00.1 chip-ID: 10de:1aeb class-ID: 0403
Sound Server-1: ALSA v: k5.18.12-zen1-1-zen running: yes
Sound Server-2: PulseAudio v: 16.1 running: no
Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Device-2: NetGear A6150 type: USB driver: rtl88x2bu bus-ID: 1-3:2
chip-ID: 0846:9055 class-ID: 0000 serial: <filter>
IF: wlp0s20f0u3 state: up mac: <filter>
IF-ID-1: docker0 state: down mac: <filter>
Bluetooth:
Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) type: USB
driver: btusb v: 0.8 bus-ID: 1-4:3 chip-ID: 0a12:0001 class-ID: e001
Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
Local Storage: total: 2.75 TiB used: 385.59 GiB (13.7%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung
model: SSD 970 EVO Plus 2TB size: 1.82 TiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 2B2QEXM7 temp: 48.9 C scheme: GPT
ID-2: /dev/sda maj-min: 8:0 vendor: Intenso model: N/A size: 953.87 GiB
block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s type: SSD
serial: <filter> rev: 0A0 scheme: GPT
Partition:
ID-1: / raw-size: 1.39 TiB size: 1.39 TiB (100.00%)
used: 385.57 GiB (27.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 25.9 MiB (8.6%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 1.39 TiB size: 1.39 TiB (100.00%)
used: 385.57 GiB (27.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 1.39 TiB size: 1.39 TiB (100.00%)
used: 385.57 GiB (27.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 1.39 TiB size: 1.39 TiB (100.00%)
used: 385.57 GiB (27.1%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 15.53 GiB used: 1.66 GiB (10.7%)
priority: 100 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 52.0 C mobo: N/A gpu: nvidia temp: 57 C
Fan Speeds (RPM): N/A gpu: nvidia fan: 28%
Info:
Processes: 313 Uptime: 2h 34m wakeups: 2 Memory: 15.53 GiB
used: 6.95 GiB (44.7%) Init: systemd v: 251 default: graphical
tool: systemctl Compilers: gcc: 12.1.0 clang: 14.0.6 Packages: 1966
note: see --pkg apt: 1 pacman: 1965 lib: 543 Shell: fish v: 3.4.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.19
Garuda (2.6.5-1):
System install date:     2022-06-16
Last full system update: 2022-07-25 ↻
Is partially upgraded:   No
Relevant software:       NetworkManager
Windows dual boot:       Probably (Run as root to verify)
Snapshots:               Snapper
Failed units:

What is that, specifically?

Have you looked through https://wiki.archlinux.org/title/Gamepad ?

1 Like

it is a dualsense and i looked at but it doesnt work and if i close steam i dont have the problem

You do have to do more than look at it to make things work...

For example, there is https://wiki.archlinux.org/title/Gamepad#Disable_touchpad_acting_as_mouse (under the PlayStation controller sections) which may be worth trying.

1 Like

i did the thiong to disable mouse input but wheen i try to do the command under the dualsense section i got this error:

xboxdrv 0.8.8 - http://pingus.seul.org/~grumbel/xboxdrv/
Copyright © 2008-2011 Ingo Ruhnke <[email protected]>
Licensed under GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This program comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to redistribute it under certain conditions; see the file COPYING
for details.


-- [ ERROR ] ------------------------------------------------------
/dev/input/by-id/usb-Sony_Interactive_Entertainment_Wireless_Controller-if03-event-joystick: No such file or directory

and here is all the files of the dev/input/by-id:

lrwxrwxrwx 10 root 25 jui 16:44  usb-0c45_USB_Keyboard-event-if01 -> ../event22
lrwxrwxrwx 10 root 25 jui 16:44  usb-0c45_USB_Keyboard-event-kbd -> ../event20
lrwxrwxrwx 10 root 25 jui 16:44  usb-0c45_USB_Keyboard-if01-event-kbd -> ../event23
lrwxrwxrwx 10 root 25 jui 16:44  usb-COMPANY_USB_Device-event-if02 -> ../event19
lrwxrwxrwx 10 root 25 jui 16:44  usb-COMPANY_USB_Device-event-kbd -> ../event16
lrwxrwxrwx 10 root 25 jui 16:44  usb-COMPANY_USB_Device-if01-event-mouse -> ../event17
lrwxrwxrwx  9 root 25 jui 16:44  usb-COMPANY_USB_Device-if01-mouse -> ../mouse0
lrwxrwxrwx 10 root 25 jui 16:44  usb-COMPANY_USB_Device-if02-event-kbd -> ../event18

Did you reboot after creating the 30-ds-disable-mouse.conf file?

yes i reboot

ok i just change the configuration of the controller in steam by error before having this problemm so now it is solved

1 Like

So, it worked, then you made a change and it broke, so you just reverted the change you made and that fixed it?

Why on Earth didn't you try that before opening a thread and taking up other people's time?

3 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.