Context and dropdown menus not working

Hello guys,
For me no context menus or dropdown menus work. In Garuda Assistant I can't use the dropdown menu. In Dolphin I can't open the right click menu anymore and in any other applications too. Anyone knows why this happens (using Sway on Garuda)

Please reboot your machine, then check again. Post the output of garuda-inxi into the thread if you need additional assistance.

3 Likes

Hello fellow Sway user.
Here I don't have this problem, now I'll update/reboot and report back.
You should provide more context, like since when this happens. And post the garuda-inxi.

edit: updated/rebooted and still no problem.

3 Likes

Hi, I rebooted and it still remains like that
edit: I dont know when exactly it happened
Second edit: Everything works fine on hyprland and KDE Plasma, seems to only occur when being on sway

System:
  Kernel: 6.0.2-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=a8f197c1-8de4-42bc-90d0-52e8457a9b26 rw [email protected]
    quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
    loglevel=3
  Desktop: sway v: 1.7 info: waybar vt: 2 dm: SDDM Distro: Garuda Linux
    base: Arch Linux
Machine:
  Type: Desktop System: Gigabyte product: B450 AORUS PRO v: N/A
    serial: <superuser required>
  Mobo: Gigabyte model: B450 AORUS PRO-CF serial: <superuser required>
    UEFI: American Megatrends LLC. v: F62d date: 10/13/2021
CPU:
  Info: model: AMD Ryzen 5 3600 bits: 64 type: MT MCP arch: Zen 2 gen: 3
    level: v3 note: check built: 2020-22 process: TSMC n7 (7nm)
    family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 32 MiB desc: 2x16 MiB
  Speed (MHz): avg: 3598 high: 3600 min/max: 2200/4208 boost: enabled
    scaling: driver: acpi-cpufreq governor: performance cores: 1: 3595 2: 3586
    3: 3600 4: 3600 5: 3600 6: 3600 7: 3600 8: 3600 9: 3600 10: 3600 11: 3600
    12: 3600 bogomips: 86236
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP
    protection
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: Sapphire Nitro+ driver: amdgpu v: kernel arch: GCN-4
    code: Arctic Islands process: GF 14nm built: 2016-20 pcie: gen: 3
    speed: 8 GT/s lanes: 16 ports: active: DP-1,HDMI-A-1
    empty: DP-2,DVI-D-1,HDMI-A-2 bus-ID: 0b:00.0 chip-ID: 1002:67df
    class-ID: 0300 temp: 49.0 C
  Display: wayland server: X.org v: 1.21.1.4 with: Xwayland v: 22.1.4
    compositor: sway v: 1.7 driver: X: loaded: amdgpu unloaded: modesetting
    alternate: fbdev,vesa dri: radeonsi gpu: amdgpu d-rect: 3840x1080
    display-ID: 1
  Monitor-1: DP-1 pos: right model: VG259QM serial: <filter> built: 2021
    res: 1920x1080 hz: 240 dpi: 90 gamma: 1.2 scale: 1
    size: 544x303mm (21.42x11.93") diag: 623mm (24.5") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  Monitor-2: HDMI-A-1 pos: left model: Samsung S22C300 serial: <filter>
    built: 2013 res: 1920x1080 hz: 60 dpi: 102 gamma: 1.2 scale: 1
    size: 477x268mm (18.78x10.55") diag: 547mm (21.5") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  OpenGL: renderer: AMD Radeon RX 580 Series (polaris10 LLVM 14.0.6 DRM
    3.48 6.0.2-zen1-1-zen) v: 4.6 Mesa 22.2.1 direct render: Yes
Audio:
  Device-1: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: Sapphire driver: snd_hda_intel v: kernel bus-ID: 3-2:2
    chip-ID: 0951:16a4 pcie: class-ID: 0300 gen: 1 speed: 2.5 GT/s
    serial: <filter> lanes: 16 link-max: gen: 3 speed: 8 GT/s bus-ID: 0b:00.1
    chip-ID: 1002:aaf0 class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: Gigabyte
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 0d:00.4 chip-ID: 1022:1487 class-ID: 0403
  Device-3: Kingston HyperX 7.1 Audio type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound API: ALSA v: k6.0.2-zen1-1-zen running: yes
  Sound Interface: sndio v: N/A running: no
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.59 running: yes
Network:
  Device-1: Intel I211 Gigabit Network vendor: Gigabyte driver: igb v: kernel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: e000 bus-ID: 08:00.0
    chip-ID: 8086:1539 class-ID: 0200
  IF: eno1 state: up speed: 1000 Mbps duplex: full mac: <filter>
Bluetooth:
  Device-1: TP-Link UB500 Adapter type: USB driver: btusb v: 0.8
    bus-ID: 1-2:2 chip-ID: 2357:0604 class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
  Local Storage: total: 2.27 TiB used: 51.76 GiB (2.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 2B4QFXO7
    temp: 43.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 vendor: Crucial model: CT1000MX500SSD1
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B
    speed: 6.0 Gb/s type: SSD serial: <filter> rev: 033 scheme: GPT
  ID-3: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WD5000AAKX-001CA0 size: 465.76 GiB block-size: physical: 512 B
    logical: 512 B speed: 6.0 Gb/s type: N/A serial: <filter> rev: 1H15
    scheme: MBR
Partition:
  ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 51.76 GiB
    (5.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) used: 612 KiB
    (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 51.76
    GiB (5.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 51.76
    GiB (5.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%) used: 51.76
    GiB (5.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.55 GiB used: 2.2 MiB (0.0%)
    priority: 100 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 52.5 C mobo: N/A gpu: amdgpu temp: 50.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1686
Info:
  Processes: 324 Uptime: 1m wakeups: 0 Memory: 15.55 GiB used: 1.68 GiB
  (10.8%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 Packages: pm: pacman pkgs: 1454 libs: 398
  tools: octopi,paru,yay Shell: Bash v: 5.1.16 running-in: foot inxi: 3.3.22
Garuda (2.6.8-1):
  System install date:     2022-10-14
  Last full system update: 2022-10-22
  Is partially upgraded:   No
  Relevant software:       NetworkManager
  Windows dual boot:       Probably (Run as root to verify)
  Snapshots:               Snapper
  Failed units:            
1 Like

I have no idea if it means anything, but I noticed I have a different output (server):

  Display: wayland server: Xwayland v: 22.1.4 compositor: sway v: 1.7
    driver: gpu: radeon d-rect: 1366x1536 display-ID: 1

Try making a new user and see if it happens there with the default configuration.

3 Likes

Installing multiple desktop environments can easily break things, especially with Sway. Sway does not have much flexibility with environment variables, for example. Things have to be set up in a very specific way to work correctly.

I agree with @meanruse, this does not look right--the Xorg server should not be running in a Sway session.

5 Likes

Tried new user with new home directory, works fine

1 Like

Well I guess I fixed it. Had X11 Plasma first and then went trying out different WMs. I wiped it off and install Garuda Sway directly but it seems to be a lot different. Got greeted with "Welcome to swayr!..." what exactly is Swayr?

I have never heard of it before, to be honest.

https://sr.ht/~tsdh/swayr/

If you like Sway, you should pull down a proper ISO from the download page and give the actual Garuda Sway spin a try. It is the best "out-of-the-box" Sway spin I have ever tried--actually it's what got me hooked on Garuda in the first place.

Instead of stacking DEs on top of one another, consider making a separate partition so you can leave the install alone, and build stuff up without breaking other DEs. You can always set up a symlink for your home folder so you can get to all your stuff no matter what session you are booted into.

3 Likes

Yes thats what I did I prob didnt explain it really good above. I got the actual garuda sway spin now, but got greeted with a message on the top saying "welcome to swayr! I generated a config...." but I never heard of it, also my whole monitor seems to be yellow guess I gotta go trough some settings

It must be a new package they have added to the spin. It looks like it is in the Chaotic AUR:

chaotic-aur/swayr 0.22.0-1 [1.42MiB 3.86MiB]
    Swayr is a window switcher (and more) for sway

It looks interesting, and complicated. Reading through the documentation made me a little dizzy. :joy:

I'm kind of tempted to try it out, although at this point I am very used to my Sway keybindings and I'm not sure I want to get lost down a whole new rabbit hole. :rabbit2:

4 Likes

There is automatic adjustment of colors by time of day, it should be wlsunset if it didn't change.
You should find it in your ~/.config/sway/config.d/autostart_applications configuration file, something like exec ~/.config/sway/scripts/light.sh.

I looked into swayr time ago but then did not find a chance to try it out.
I quote "looks interesting, and complicated".

3 Likes

Oh okay, thank you. I guess imma also remove swayr since I have no idea what it is, also gotta put my keybinds to sways default. Guess the issue is solved thank you guys!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.