Connman ui wifi connection issue

Hi i installed garuda lxqt and i cant connect to any wifi service beacuse when i try to connect i get the error which say passphrase is neccessary but the app does not ask me for passphrase
Error name
net.connman.Error.PasspohraseRequired

https://forum.garudalinux.org/search?expanded=true&q=Connman%20order:latest

2 Likes

Hi i can't connect to wifi with connman ui, connmanctl, iw, iwconfig, is there another way to connect to wifi😥

Try removing connman and downloading networkmanager instead.

4 Likes

Hi i want install garuda lxqt when i plug in bootable usb and boot it i can't connect to wifi i have connection issue even when i installed os should i download again iso file and reinstall system beacuse i think this issue is for iso file

If you have ethernet connectivity or USB tethering, please provide the output of inxi -Faz as text with 3 ~ before and after the text block, for formatting reasons.
Garuda can be installed without internet connection, anyway.

Edit: please do not cross-post. I just noticed you entered another topic for connman

4 Likes

i have merged your three separate threads. 3 threads on one topic in a single day is unacceptable. You're being silenced for a little while to correct this inappropriate behavior.

You now have a few days to work though this issue on your own, so I'll give you some suggestions to try. As in my first link I posted (if you'd read them) here are some of the prior suggestions regarding this issue:

  1. Downgrade Connman.

  2. Replace Connman with Network Manager. Disable all services related to connman and enable services related to Network Manager. This can be made easier with the use of Garuda Assistant.

If neither of these suggestions provide any improvement then post up the following outputs when able:

Post the full inputs and outputs of:

inxi -Faz
(ping -c5 google.com 2>&1 >/dev/null) && echo "*** Google IPv4 Connection established via Domain Name Address ***"  ||   echo "*** Google IPv4 Connection unreachable via Domain Name Address***" ;  (ping -c5 google.com 2>&1 >/dev/null) && echo "*** Google IPv4 Connection established via IP Address"  ||   echo "*** Google IPv4 Connection unreachable via IP Address ***";  (ping -c5 2607:f8b0:4009:800::200e 2>&1 >/dev/null) && echo "*** Google IPv6 Connection established via IP Address ***"  ||  echo "*** Google IPv6 network connection unreachable via IP Address ***" 

You can also try connecting with connman via the terminal:

https://wiki.archlinux.org/title/ConnMan#Connecting_to_a_protected_access_point

https://wiki.archlinux.org/title/Iwd#Connect_to_a_network


Here are some suggestions to ensure your time on our forum is productive:

Do not open threads repeatedly on the same topic. This is called cross posting and it is frowned upon on most every forum that exists.

Respond to every suggestion put to you. Explain fully which fixes you attempted and the results. Post all terminal inputs and outputs of every command you run.

Always post your system specs and any relevant journal logs as these are key to solving most technical help requests.

If you follow these guidelines on each technical help request your time here should be fully productive.

3 Likes

Yes. Connman is a true PIA. And don't forget to enable networkmanager before you are done.
:wink:

3 Likes

thanks lot for your help i find solution i use iwctl and use iwd to connect wifi and it's work

1 Like

You may also want to try these suggestions:

Edit:

Install connman-git as a temporary workaround.

3 Likes

Your way will work, but the true solution is making connman bend to your will.

I should have pointed you in @tbg's direction and I failed to do that. Using NetworkManager or iwctl/iwd, etc. is a hack, and I still fall back into the tendency to hack, hack, hack away at a problem until there is no longer a problem. Those other methods may work, but the correct solution would have been much better.

@tbg's sort of a forum expert on connectivity issues. Mea culpa.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.