Conky multiple windows in dock

Conky displays multiple instances of itself in the dock, and is only shown on desktop when clicking on one of them.
Also, I’m unable to close them

Hello, my post was moved to the 412 category but I can’t figure out why, no reason was specifically given. It’s currently here.
It does not contain the output of garuda-inxi, which I would add for the sake of complying with rules, but am barred from editing the topic - and anyways I don’t see how it’s relevant. I would normally give it for most hardware issues. This is just a fresh install with most defaults still in place.

However, here it is:

Kernel: 6.5.9-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc available: acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=dc229e5a-50c1-478a-b84b-e60401e4d6c0 rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=258393c9-45c2-4f11-9c89-8fb56cf7d7ab loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.27.9 tk: Qt v: 5.15.11 wm: kwin_wayland vt: 1
dm: SDDM Distro: Garuda Linux base: Arch Linux
Type: Laptop System: TUXEDO product: TUXEDO v: N/A
serial: <superuser required> Chassis: Notebook type: 10
serial: <superuser required>
Mobo: TUXEDO model: N141CU serial: <superuser required> UEFI: INSYDE
v: 1.07.07RTR1 date: 11/08/2019
ID-1: BAT0 charge: 33.1 Wh (91.7%) condition: 36.1/35.3 Wh (102.3%)
volts: 12.3 min: 11.4 model: Notebook BAT type: Li-ion serial: <filter>
status: not charging
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M315/M235
serial: <filter> charge: 100% (should be ignored) rechargeable: yes
status: discharging
Info: model: Intel Core i7-10510U bits: 64 type: MT MCP
arch: Comet/Whiskey Lake note: check gen: core 10 level: v3 note: check
built: 2018 process: Intel 14nm family: 6 model-id: 0x8E (142)
stepping: 0xC (12) microcode: 0xF8
Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
L1: 256 KiB desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB
L3: 8 MiB desc: 1x8 MiB
Speed (MHz): avg: 650 high: 801 min/max: 400/4900 scaling:
driver: intel_pstate governor: powersave cores: 1: 800 2: 800 3: 400 4: 801
5: 800 6: 400 7: 400 8: 800 bogomips: 36799
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
Vulnerabilities: <filter>
Device-1: Intel CometLake-U GT2 [UHD Graphics] vendor: CLEVO/KAPOK
driver: i915 v: kernel arch: Gen-9.5 process: Intel 14nm built: 2016-20
ports: active: eDP-1 empty: DP-1,HDMI-A-1,HDMI-A-2 bus-ID: 00:02.0
chip-ID: 8086:9b41 class-ID: 0300
Device-2: Chicony [] driver: uvcvideo type: USB rev: 2.0 speed: 480 Mb/s
lanes: 1 mode: 2.0 bus-ID: 1-7:3 chip-ID: 04f2:b649 class-ID: 0e02
Display: wayland server: v: with: Xwayland v: 23.2.2
compositor: kwin_wayland driver: X: loaded: modesetting
alternate: fbdev,intel,vesa dri: iris gpu: i915 display-ID: 0
Monitor-1: eDP-1 res: 1920x1080 size: N/A modes: N/A
API: EGL v: 1.5 hw: drv: intel iris platforms: device: 0 drv: iris
device: 1 drv: swrast surfaceless: drv: iris wayland: drv: iris x11:
drv: iris inactive: gbm
API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 23.2.1-arch1.2
glx-v: 1.4 direct-render: yes renderer: Mesa Intel UHD Graphics (CML GT2)
device-ID: 8086:9b41 memory: 14.96 GiB unified: yes display-ID: :1.0
API: Vulkan v: 1.3.269 layers: 3 device: 0 type: integrated-gpu name: Intel
UHD Graphics (CML GT2) driver: mesa intel v: 23.2.1-arch1.2
device-ID: 8086:9b41 surfaces: xcb,xlib,wayland device: 1 type: cpu
name: llvmpipe (LLVM 16.0.6 256 bits) driver: mesa llvmpipe
v: 23.2.1-arch1.2 (LLVM 16.0.6) device-ID: 10005:0000
surfaces: xcb,xlib,wayland
Device-1: Intel Comet Lake PCH-LP cAVS vendor: CLEVO/KAPOK
driver: snd_hda_intel v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl
bus-ID: 00:1f.3 chip-ID: 8086:02c8 class-ID: 0403
API: ALSA v: k6.5.9-zen2-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: PipeWire v: 0.3.83 status: active with: 1: wireplumber
status: active 2: pipewire-alsa type: plugin 3: pw-jack type: plugin
tools: pw-cat,pw-cli,wpctl
Server-2: PulseAudio v: 16.1 status: active with: pulseaudio-jack
type: module tools: pacat,pactl
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: CLEVO/KAPOK driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: 5000 bus-ID: 3b:00.1 chip-ID: 10ec:8168 class-ID: 0200
IF: enp59s0f1 state: down mac: <filter>
Device-2: Intel Wireless-AC 9260 driver: iwlwifi v: kernel pcie: gen: 2
speed: 5 GT/s lanes: 1 bus-ID: 40:00.0 chip-ID: 8086:2526 class-ID: 0280
IF: wlp64s0 state: up mac: <filter>
Device-1: Intel Wireless-AC 9260 Bluetooth Adapter driver: btusb v: 0.8
type: USB rev: 2.0 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-10:4
chip-ID: 8087:0025 class-ID: e001
Report: btmgmt ID: hci0 rfk-id: 0 state: down bt-service: enabled,running
rfk-block: hardware: no software: yes address: <filter> bt-v: 5.1 lmp-v: 10
status: discoverable: no pairing: no
Local Storage: total: 953.87 GiB used: 43.44 GiB (4.6%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Intel model: SSDPEKNW010T8
size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 002C temp: 28.9 C scheme: GPT
ID-1: / raw-size: 936.72 GiB size: 936.72 GiB (100.00%)
used: 43.44 GiB (4.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
ID-3: /home raw-size: 936.72 GiB size: 936.72 GiB (100.00%)
used: 43.44 GiB (4.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-4: /var/log raw-size: 936.72 GiB size: 936.72 GiB (100.00%)
used: 43.44 GiB (4.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
ID-5: /var/tmp raw-size: 936.72 GiB size: 936.72 GiB (100.00%)
used: 43.44 GiB (4.6%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 15.32 GiB used: 0 KiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 8 dev: /dev/zram0
ID-2: swap-2 type: partition size: 16.85 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
System Temperatures: cpu: 53.0 C pch: 51.0 C mobo: N/A
Fan Speeds (rpm): N/A
Processes: 272 Uptime: 15m wakeups: 3 Memory: total: 16 GiB note: est.
available: 15.32 GiB used: 4.35 GiB (28.4%) Init: systemd v: 254
default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
pm: pacman pkgs: 1579 libs: 497 tools: octopi,paru Shell: fish v: 3.6.1
default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.30
Garuda (2.6.17-1):
System install date:     2023-10-28
Last full system update: 2023-10-30
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut
Windows dual boot:       No/Undetected
Failed units:

I would like to give the feedback that
1.) Of course, you gotta have rules in place, but when such moves are made (by humans), it would be fair to provide the specific reason rather than a general set of possible ones (like the big platforms like to do it).
2.) Make the rules/guidelines on which such moves/disregard of a post is based very easy to find - as in, “shoved in everyone’s face”-easy.

  • I found the guidelines - under FAQ, not under “Guidelines” (but no questions are answered there, it’s actually just guidelines). They don’t state what informations a support request needs to contain.
  • The set of informations required in a support request is not found pinned a) in the 412 category b) in the Issues & Assistance category c) anywhere else I looked.
    Forgive me if I maybe I overlooked something. If so, other than a failure to look hard enough on my end, that could also be due to it just being hard to find - which I would urge the community to investigate.
  • The only possible shortcoming I could find was lack of garuda-inxioutput, which again, I failed to see its relevance (and am barred from adding them after the fact).
  • I tried to ask the person who moved my thread for the reasons before posting here, but they don’t accept messages.

To summarize: as a newbie, I kind of met a dead end here which - if it’s not just an oversight, but a community mechanism due to rules applied regularly - might warrant looking into for revision. Thanks in advance for any helpful information!

Maybe you did not read the template, you delete now the second time.

Here you can read about.

Hello Garuda users.

Please read the following template before requesting assistance:

Please post the terminal/konsole input and output as text (no pictures) from the following command:


Refusing to post the output of the required “garuda-inxi” on a help request will likely result in you not receiving any help from the Garuda team.

A failure to provide your system specs may also result in your thread being closed without notice, (as without this information providing assistance is often next to impossible).

Before opening a new help request, please search the Arch and Garuda Wiki’s, and read any relevant sections related to your issue. Also, thoroughly search any error messages in the forum’s search engine and on the web. For in depth information on how to search for answers to Linux issues effectively, read the tips on the Garuda Wiki:

Please report in detail everything you have already attempted to solve your problem.

The template above should be deleted before posting your help request.

The processing time to add garuda-inxi must have expired after two days.

You see, from the garuda-inxi we can see you are on wayland, and I’d suggest to check if you have the same behaviour logging into an x11 session. It provides many information that can seem irrelevant but for some people are enlighting. My suggestion was just an example of course


And forever greetings the marmot… (German saying) :wink:

Thank you for the hint. I found out that Wayland support for Conky is a “work in progress.” But what about Xwayland then? Isn’t that supposed to smooth over this kind of issues (switching to Xorg is not an option for me)?

This is something that should be asked to either Conky, Wayland or Xwayland teams…
I personally gave up with conky when I use Wayland since quite some time now. But I’m not a Conky fanatic… When I use it I just copy (ops take inspiration!) from someone somewhere :wink:
PS: I moved all the posts of the new topic to the old one and made it editable, so that we can go back to the problem.
I’m sure Conky is usable in Wayland but we’ll need input from Wayland users having solved Conky problems.
I’ve never seen Conky started from the dock… Just fought to have it automatically started.
Does Conky start correctly from terminal?
Can you provide your conky configuration file?
Again, this is only for future helpers… :slightly_smiling_face:


It starts automatically with Plasma (I think). If I start it also from terminal, this is the output:

╰─λ conky
conky: no personal or system-wide config file found, using builtin default
conky: desktop window (49f) is root window
conky: window type - desktop
conky: drawing to created window (0x2600001)
conky: drawing to double buffer

However, that changes nothing in the Dock - hovering the mouse over its icon, the little preview windows fill the screen from edge to edge.
In Plasma System Monitor, 10 Conky processes are running. Calling conky from terminal adds another. Attempting to close on of the Conky windows from dock does nothing.

There is no config file in the locations listed in Arch Wiki…

If none of these files exist, conky will use the default built-in configuration, which you can print out with:

╭─ben@paul in ~ took 7m46s
╰─λ conky --print-config
-- Conky, a system monitor

conky.config = {
alignment = 'top_left',
background = false,
border_width = 1,
cpu_avg_samples = 2,
default_color = 'white',
default_outline_color = 'white',
default_shade_color = 'white',
double_buffer = true,
draw_borders = false,
draw_graph_borders = true,
draw_outline = false,
draw_shades = false,
extra_newline = false,
font = 'DejaVu Sans Mono:size=12',
gap_x = 60,
gap_y = 60,
minimum_height = 5,
minimum_width = 5,
net_avg_samples = 2,
no_buffers = true,
out_to_console = false,
out_to_ncurses = false,
out_to_stderr = false,
out_to_x = true,
own_window = true,
own_window_class = 'Conky',
own_window_type = 'desktop',
show_graph_range = false,
show_graph_scale = false,
stippled_borders = 0,
update_interval = 1.0,
uppercase = false,
use_spacer = 'none',
use_xft = true,

conky.text = [[
${color grey}Info:$color ${scroll 32 Conky $conky_version - $sysname $nodename $kernel $machine}
${color grey}Uptime:$color $uptime
${color grey}Frequency (in MHz):$color $freq
${color grey}Frequency (in GHz):$color $freq_g
${color grey}RAM Usage:$color $mem/$memmax - $memperc% ${membar 4}
${color grey}Swap Usage:$color $swap/$swapmax - $swapperc% ${swapbar 4}
${color grey}CPU Usage:$color $cpu% ${cpubar 4}
${color grey}Processes:$color $processes  ${color grey}Running:$color $running_processes
${color grey}File systems:
/ $color${fs_used /}/${fs_size /} ${fs_bar 6 /}
${color grey}Networking:
Up:$color ${upspeed} ${color grey} - Down:$color ${downspeed}
${color grey}Name              PID     CPU%   MEM%
${color lightgrey} ${top name 1} ${top pid 1} ${top cpu 1} ${top mem 1}
${color lightgrey} ${top name 2} ${top pid 2} ${top cpu 2} ${top mem 2}
${color lightgrey} ${top name 3} ${top pid 3} ${top cpu 3} ${top mem 3}
${color lightgrey} ${top name 4} ${top pid 4} ${top cpu 4} ${top mem 4}

As a desktop widget, Conky shouldn’t have an icon in the dock at all. I tried to block it in the settings for the dock, but can’t figure out how to get into them. Right click only offers settings for the app that I’m pointing at.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.