Conflict preventing update

For the last few days I’ve been unable to run garuda-update, given the output:

:: Synchronising package databases...
garuda is up to date
core                                                                                 129.9 KiB   991 KiB/s 00:00 [--------------------------------------------------------------------] 100%
extra                                                                                  8.3 MiB  10.4 MiB/s 00:01 [--------------------------------------------------------------------] 100%
chaotic-aur                                                                            2.5 MiB  2.29 MiB/s 00:01 [--------------------------------------------------------------------] 100%

--> Refreshing mirrorlists using rate-mirrors, please be patient..🍵

:: Synchronising package databases...
garuda downloading...
core downloading...
extra downloading...
chaotic-aur downloading...
:: Starting full system upgrade...
warning: kde-servicemenus-pdf-encrypt-decrypt: local (1-1.4) is newer than chaotic-aur (1-1)
warning: reshade-shaders-git: local (r909.2459c73-1) is newer than chaotic-aur (r50.388ef32-1)
warning: vlc-git: local (1:0.0.1-1) is newer than chaotic-aur (4.0.0.r27971.g5006690850-1)
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing libffi (3.4.6-1) breaks dependency 'libffi=3.4.4' required by lib32-libffi

I did see another post having what appears to be the same issue, but couldn’t work out what action I’m meant to take from reading it. Problem updating
I don’t have any weird ignores in my pacman.conf or any testing repos enabled. I thought maybe it was a mirror issue that would resolve in a few days, but that doesn’t appear to be the case so far.
I also tried going back to an earlier snapshot, but it’s left me in the same situation.

my garuda-inxi output:

System:
Kernel: 6.7.4-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
clocksource: tsc avail: hpet,acpi_pm
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=3ab09ee7-0f67-4516-8d72-20498ae5d943 rw rootflags=subvol=@
quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0 loglevel=3
ibt=off
Desktop: KDE Plasma v: 5.27.10 tk: Qt v: 5.15.12 info: frameworks
v: 5.115.0 wm: kwin_x11 with: krunner vt: 2 dm: SDDM Distro: Garuda
base: Arch Linux
Machine:
Type: Desktop System: ASUS product: N/A v: N/A serial: <superuser required>
Mobo: ASUSTeK model: PRIME B550-PLUS v: Rev X.0x
serial: <superuser required> part-nu: SKU uuid: <superuser required>
UEFI: American Megatrends v: 2423 date: 08/09/2021
CPU:
Info: model: AMD Ryzen 9 5950X bits: 64 type: MT MCP arch: Zen 3+ gen: 4
level: v3 note: check built: 2022 process: TSMC n6 (7nm) family: 0x19 (25)
model-id: 0x21 (33) stepping: 0 microcode: 0xA201016
Topology: cpus: 1x cores: 16 tpc: 2 threads: 32 smt: enabled cache:
L1: 1024 KiB desc: d-16x32 KiB; i-16x32 KiB L2: 8 MiB desc: 16x512 KiB
L3: 64 MiB desc: 2x32 MiB
Speed (MHz): avg: 3454 high: 4210 min/max: 2200/5083 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3400 2: 3400
3: 3400 4: 3400 5: 3400 6: 3743 7: 3400 8: 3400 9: 3400 10: 3400 11: 3400
12: 3400 13: 3599 14: 3400 15: 3400 16: 3400 17: 3400 18: 3599 19: 3400
20: 3400 21: 4210 22: 3400 23: 3400 24: 3601 25: 3400 26: 3400 27: 3400
28: 3400 29: 3400 30: 3400 31: 3400 32: 3400 bogomips: 217593
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: NVIDIA GA102 [GeForce RTX 3090] vendor: eVga.com. driver: nvidia
v: 545.29.06 alternate: nouveau,nvidia_drm non-free: 545.xx+ status: current
(as of 2024-02; EOL~2026-12-xx) arch: Ampere code: GAxxx
process: TSMC n7 (7nm) built: 2020-2023 pcie: gen: 4 speed: 16 GT/s
lanes: 16 ports: active: none off: DP-1,HDMI-A-1 empty: DP-2,DP-3
bus-ID: 08:00.0 chip-ID: 10de:2204 class-ID: 0300
Display: x11 server: X.Org v: 21.1.11 with: Xwayland v: 23.2.4
compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting,nouveau
alternate: fbdev,nv,vesa gpu: nvidia,nvidia-nvswitch display-ID: :0
screens: 1
Screen-1: 0 s-res: 3840x2160 s-dpi: 161 s-size: 606x340mm (23.86x13.39")
s-diag: 695mm (27.36")
Monitor-1: DP-1 mapped: DP-0 note: disabled pos: primary model: ASUS PA279
serial: <filter> built: 2021 res: 3840x2160 hz: 60 dpi: 163 gamma: 1.2
size: 597x336mm (23.5x13.23") diag: 685mm (27") ratio: 16:9 modes:
max: 3840x2160 min: 640x480
Monitor-2: HDMI-A-1 mapped: HDMI-0 note: disabled
model: Panasonic Panasonic-TV serial: <filter> built: 2016 res: 3840x2160
dpi: 76 gamma: 1.2 size: 698x392mm (27.48x15.43") diag: 1469mm (57.8")
ratio: 16:9 modes: max: 3840x2160 min: 640x480
API: EGL v: 1.5 hw: drv: nvidia platforms: device: 0 drv: nvidia device: 2
drv: swrast gbm: drv: nvidia surfaceless: drv: nvidia x11: drv: nvidia
inactive: wayland,device-1
API: OpenGL v: 4.6.0 compat-v: 4.5 vendor: nvidia mesa v: 545.29.06
glx-v: 1.4 direct-render: yes renderer: NVIDIA GeForce RTX 3090/PCIe/SSE2
memory: 23.44 GiB
API: Vulkan v: 1.3.276 layers: 12 device: 0 type: discrete-gpu
name: NVIDIA GeForce RTX 3090 driver: nvidia v: 545.29.06
device-ID: 10de:2204 surfaces: xcb,xlib device: 1 type: cpu name: llvmpipe
(LLVM 16.0.6 256 bits) driver: mesa llvmpipe v: 23.3.5-arch1.1 (LLVM
16.0.6) device-ID: 10005:0000 surfaces: xcb,xlib
Audio:
Device-1: NVIDIA GA102 High Definition Audio vendor: eVga.com.
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 08:00.1 chip-ID: 10de:1aef class-ID: 0403
Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
bus-ID: 0a:00.4 chip-ID: 1022:1487 class-ID: 0403
API: ALSA v: k6.7.4-zen1-1-zen status: kernel-api with: aoss
type: oss-emulator tools: N/A
Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
Server-2: PipeWire v: 1.0.3 status: active with: 1: pipewire-pulse
status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
Device-1: Realtek RTL8111/8168/8211/8411 PCI Express Gigabit Ethernet
vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel pcie: gen: 1
speed: 2.5 GT/s lanes: 1 port: f000 bus-ID: 07:00.0 chip-ID: 10ec:8168
class-ID: 0200
IF: enp7s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Info: services: NetworkManager, smbd, sshd, systemd-timesyncd
Bluetooth:
Device-1: TP-Link UB5A Adapter driver: btusb v: 0.8 type: USB rev: 1.1
speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-3:3 chip-ID: 2357:0604
class-ID: e001 serial: <filter>
Report: btmgmt ID: hci0 rfk-id: 0 state: up address: <filter> bt-v: 5.1
lmp-v: 10 status: discoverable: no pairing: no class-ID: 6c0104
Drives:
Local Storage: total: 8.23 TiB used: 1.8 TiB (21.9%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:2 vendor: Samsung model: SSD 980 PRO 1TB
size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 3B2QGXA7 temp: 41.9 C
scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Intel model: SSDPEKNU020TZ
size: 1.86 TiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
lanes: 4 tech: SSD serial: <filter> fw-rev: 002C temp: 33.9 C scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: Seagate model: ST6000NE000-2KR101
size: 5.46 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
tech: HDD rpm: 7200 serial: <filter> fw-rev: EN01 scheme: GPT
Partition:
ID-1: / raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 525.77 GiB (56.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:4
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 584 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:3
ID-3: /home raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 525.77 GiB (56.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:4
ID-4: /var/log raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 525.77 GiB (56.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:4
ID-5: /var/tmp raw-size: 931.22 GiB size: 931.22 GiB (100.00%)
used: 525.77 GiB (56.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:4
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
ID-1: swap-1 type: zram size: 62.71 GiB used: 3 MiB (0.0%) priority: 100
comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 32 dev: /dev/zram0
Sensors:
System Temperatures: cpu: 54.6 C mobo: N/A gpu: nvidia temp: 63 C
Fan Speeds (rpm): N/A gpu: nvidia fan: 36%
Info:
Memory: total: 64 GiB note: est. available: 62.71 GiB
used: 11.24 GiB (17.9%)
Processes: 558 Power: uptime: 1h 38m states: freeze,mem,disk suspend: deep
avail: s2idle wakeups: 0 hibernate: platform avail: shutdown, reboot,
suspend, test_resume image: 25.02 GiB services: org_kde_powerdevil,
power-profiles-daemon, upowerd Init: systemd v: 255 default: graphical
tool: systemctl
Packages: 2576 pm: pacman pkgs: 2562 libs: 609 tools: octopi,paru
pm: flatpak pkgs: 14 Compilers: gcc: 13.2.1 alt: 11/12 Shell: garuda-inxi
default: Bash v: 5.2.26 running-in: konsole inxi: 3.3.33
Garuda (2.6.23-1):
System install date:     2023-03-19
Last full system update: 2024-02-12
Is partially upgraded:   No
Relevant software:       snapper NetworkManager dracut nvidia-dkms
Windows dual boot:       No/Undetected
Failed units:            [email protected]

Try a,

garuda-update -- lib32-libffi libffi

if that doesn’t work,
force remove lib32-libffi

sudo pacman -Rdd lib32-libffi

then

garuda-update

once update’s finished for sake of sanity,

sudo pacman -S lib32-libffi

I think you disabled, maybe unwillingly, the multilib repo in your pacman.conf.
Enable it again and update.

4 Likes

Thanks, I think you may have found my solution!
I just need to download about 5GB of updates now…

I don’t recall ever having actively enabled or disabled the multilib repo, so not sure why it was commented out if I already had stuff relying on it.

I’ll mark this as the solution once updated, but it seems to be progressing. :slight_smile:

@NaN thanks for the help, too. Can you explain what the -- does in your first suggestion? I couldn’t find a man page, a --help entry, or a web page that explains this - I did find this wiki page, but it wasn’t covered Garuda Update | Garuda Linux wiki

It Is enabled by default in Garuda.
Sometimes this happens further to wrong merge with pacnew files. Not necessarily your case, but it happens…

1 Like

That would probably explain it, I tried to be careful with using pacmerge, but it was the first time I used that aspect of vim, so I may have made a mistake.
Thanks again, just got done updating and restarted (just to sooth my paranoia) and all seems good!

1 Like

Personally, I do it with

sudo -H DIFFPROG=kompare pacdiff

(meld instead of kompare is also fine).

2 Likes

It passes on anything provided after -- like flags and stuff to pacman instead of garuda-update.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.