CIFS error "Unable to apply new capability set."

New user of Garuda, really loving it so far. I'm trying to mount a Samba network drive, and I'm getting a strange error: "Unable to apply new capability set."
Looking around, it looks like its caused by trying to mount from within a docker instance? I'm running native on my computer though, so it can't be that.
I'd appreciate some help, I've got no clue what it is.

I have the same problem too, when mounting a SMB Share over fstab.
The weird thing is, it only makes this error in KDE, my Gnome Machine is mounting them without delay.

It is possible to mount smb shares via Settings --> Network Drives, but this is not very good, since you have to mount every Share seperatly and cannot map them to a specific folder

This will be a good place to start:


I'm on the BSPWM version, Unit247, and as for your issue, have you tried messing with version settings? On other distros, including standard Arch, I've just had to change version settings (eg. vers=3) to get fstab working.
Jonathon, thanks, but my issue isn't described there.
From what I can tell it is due to Garuda's custom kernel? There are some posts from people on Slackware, which say that the issue arose after a kernel upgrade, and that downgrading libcap-ng to 0.8 or applying a patch to cifs-utils. I'll look into the libcap-ng downgrade or the cifs-utils patch when I have free time.

That rings a bell:

So, update your system?


Yep, that fixed it. I had updated it earlier and that version wasn't out yet, but its all working now!

1 Like

Great suggesting. That fixed the problem :smiley:
Thank you very much

1 Like