Choppy audio when playing cpu-intensive modpack in minecraft

Hello Garuda users.

System:
  Kernel: 6.4.6-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.1.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=0d041406-fe13-41c0-b9f2-4c294e2a1d84 rw rootflags=subvol=@
    quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0
    resume=UUID=dff8cd6b-a08c-479d-bb33-80f49a2c20cb loglevel=3 ibt=off
  Desktop: KDE Plasma v: 5.27.6 tk: Qt v: 5.15.10 wm: kwin_x11 vt: 2
    dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: Micro-Star model: B460M-A PRO (MS-7C88) v: 1.0
    serial: <superuser required> UEFI: American Megatrends v: 1.60
    date: 11/30/2020
CPU:
  Info: model: Intel Core i5-10400F bits: 64 type: MT MCP arch: Comet Lake
    gen: core 10 level: v3 note: check built: 2020 process: Intel 14nm family: 6
    model-id: 0xA5 (165) stepping: 3 microcode: 0xF6
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 3698 high: 4102 min/max: 800/4300 scaling:
    driver: intel_pstate governor: powersave cores: 1: 4100 2: 4100 3: 2900
    4: 4100 5: 4098 6: 4095 7: 2900 8: 4090 9: 2900 10: 2900 11: 4100 12: 4102
    bogomips: 69597
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
Graphics:
  Device-1: NVIDIA TU106 [GeForce RTX 2060 Rev. A] driver: nvidia v: 535.86.05
    alternate: nouveau,nvidia_drm non-free: 535.xx+
    status: current (as of 2023-07) arch: Turing code: TUxxx
    process: TSMC 12nm FF built: 2018-22 pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.0 chip-ID: 10de:1f08 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.2
    compositor: kwin_x11 driver: X: loaded: nvidia unloaded: modesetting
    alternate: fbdev,nouveau,nv,vesa gpu: nvidia display-ID: :0 screens: 1
  Screen-1: 0 s-res: 4480x1440 s-dpi: 108 s-size: 1054x342mm (41.50x13.46")
    s-diag: 1108mm (43.63")
  Monitor-1: DP-2 pos: bottom-l res: 1920x1080 dpi: 81
    size: 600x340mm (23.62x13.39") diag: 690mm (27.15") modes: N/A
  Monitor-2: DP-4 pos: primary,top-right res: 2560x1440 hz: 60 dpi: 109
    size: 597x336mm (23.5x13.23") diag: 685mm (26.97") modes: N/A
  API: OpenGL v: 4.6.0 NVIDIA 535.86.05 renderer: NVIDIA GeForce RTX
    2060/PCIe/SSE2 direct-render: Yes
Audio:
  Device-1: Intel Comet Lake PCH-V cAVS vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel alternate: snd_soc_avs,snd_sof_pci_intel_cnl
    bus-ID: 00:1f.3 chip-ID: 8086:a3f0 class-ID: 0403
  Device-2: NVIDIA TU106 High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16 bus-ID: 01:00.1
    chip-ID: 10de:10f9 class-ID: 0403
  Device-3: C-Media Blue Snowball driver: hid-generic,snd-usb-audio,usbhid
    type: USB rev: 1.1 speed: 12 Mb/s lanes: 1 mode: 1.1 bus-ID: 1-1.2:6
    chip-ID: 0d8c:0005 class-ID: 0300 serial: <filter>
  API: ALSA v: k6.4.6-zen1-1-zen status: kernel-api tools: N/A
  Server-1: PipeWire v: 0.3.76 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: 3000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 953.87 GiB used: 181.68 GiB (19.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SanDisk
    model: SSDPR-PX500-01T-80 size: 953.87 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 tech: SSD serial: <filter>
    fw-rev: V2.1.3 temp: 46.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 936.45 GiB size: 936.45 GiB (100.00%)
    used: 181.68 GiB (19.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 576 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 936.45 GiB size: 936.45 GiB (100.00%)
    used: 181.68 GiB (19.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-4: /var/log raw-size: 936.45 GiB size: 936.45 GiB (100.00%)
    used: 181.68 GiB (19.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-5: /var/tmp raw-size: 936.45 GiB size: 936.45 GiB (100.00%)
    used: 181.68 GiB (19.4%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 15.56 GiB used: 3.19 GiB (20.5%)
    priority: 100 dev: /dev/zram0
  ID-2: swap-2 type: partition size: 17.11 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:3
Sensors:
  System Temperatures: cpu: 40.0 C mobo: N/A gpu: nvidia temp: 57 C
  Fan Speeds (RPM): N/A gpu: nvidia fan: 0%
Info:
  Processes: 337 Uptime: 6h 13m wakeups: 0 Memory: total: 16 GiB
  available: 15.56 GiB used: 13.35 GiB (85.8%) Init: systemd v: 253
  default: graphical tool: systemctl Compilers: gcc: 13.1.1 clang: 15.0.7
  Packages: pm: pacman pkgs: 1614 libs: 451 tools: octopi,pamac,paru
  Shell: fish v: 3.6.1 default: Bash v: 5.1.16 running-in: konsole
  inxi: 3.3.28
Garuda (2.6.16-1):
  System install date:     2023-07-22
  Last full system update: 2023-08-02 ↻
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut nvidia-dkms
  Windows dual boot:       No/Undetected
  Failed units:            

I have a problem with audio while running some games, mainly minecraft. When i play music from spotify while the game is running the audio is really choppy (every 2-3 seconds there is an extremely short brake in playback). This happens when minecraft is idling and when i'm in a world. Minecraft audio is not interupted but playback of spotify song and video from youtube is. This does not happen when I play other games (league of legends, apex legends).

I am not familiar with pipewire and i don't know how to troubleshoot this issue or how to solve it.

Which Minecraft launcher?
How many mods? For ATM8 (about 370 mods) I made sure to allocate at LEAST 10GB of RAM.
Have you tried using the latest version of Java?

I use prism launcher, and play GTNH while using 10GB of ram for my java instance.
openjdk 17.0.8 2023-07-18 LTS

You could try GDLauncher, it's what I use and it's fantastic. It may or may not resolve the issue but something that can be tried. It will, by default, probably use a slightly different version of Java 17. Since this is Minecraft 1.7.10 it's pretty old so perhaps downgrading Java could help. I actually made a huge, almost 400 mod modpack back in the day on 1.7.10 and it ran on Java 8 for what that's worth.

GTNH uses special mods to allow using java 17, for mc 1.7.10 the default is java 8. I don't think that minecraft launcher is the problem. I had used it for over a year before on windows and a few weeks on linux but the issue started to occur today

It's not that I think a different launcher itself would make a difference, only that if it uses a slightly different version of Java 17 that might help. Also, I almost hate to say it, and I'm not suggesting to use a different pack, but that version of the game is so old and so many issues were fixed since then and optimizations (thus a lot less CPU usage). I don't know anything about pipewire unfortunately.

Yeah i think i will just have to listen to music from my phone then unless there is something i missed, i will keep researching the issue, thanks for help

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.