Change shell from Fish to Zsh

Hello! I want to change my shell from Fish to Zsh but I'm not able to. I checked previous Garuda Forum posts which didn't work for me.
inxi -Faz Output:

System:    Kernel: 5.13.12-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
           root=UUID=ae3d9c19-ae69-40d6-aa60-b7d62b58452e rw [email protected] quiet splash
           rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1
           loglevel=3
           Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 2
           dm: GDM 40.1 Distro: Garuda Linux base: Arch Linux
Machine:   Type: Laptop System: ASUSTeK product: ROG Zephyrus Duo 15 SE GX551QR_GX551QR v: 1.0
           serial: <filter>
           Mobo: ASUSTeK model: GX551QR v: 1.0 serial: <filter> UEFI: American Megatrends LLC.
           v: GX551QR.405 date: 05/13/2021
Battery:   ID-1: BAT0 charge: 30.9 Wh (39.0%) condition: 79.3/90.0 Wh (88.1%) volts: 15.9
           min: 15.9 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A status: Not charging
           Device-1: hid-0018:04F3:2A5A.0001-battery model: ELAN9009:00 04F3:2A5A serial: N/A
           charge: N/A status: N/A
CPU:       Info: 8-Core model: AMD Ryzen 9 5900HX with Radeon Graphics bits: 64 type: MT MCP
           arch: Zen 3 family: 19 (25) model-id: 50 (80) stepping: 0 microcode: A50000C cache:
           L2: 4 MiB
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
           bogomips: 105400
           Speed: 1612 MHz min/max: 1200/3300 MHz boost: enabled Core speeds (MHz): 1: 1612
           2: 1888 3: 1397 4: 1772 5: 2832 6: 3649 7: 3887 8: 3918 9: 3729 10: 3615 11: 3305
           12: 4569 13: 2589 14: 2632 15: 2831 16: 3652
           Vulnerabilities: Type: itlb_multihit status: Not affected
           Type: l1tf status: Not affected
           Type: mds status: Not affected
           Type: meltdown status: Not affected
           Type: spec_store_bypass
           mitigation: Speculative Store Bypass disabled via prctl and seccomp
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, STIBP:
           always-on, RSB filling
           Type: srbds status: Not affected
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: NVIDIA GA104M [GeForce RTX 3070 Mobile / Max-Q] vendor: ASUSTeK
           driver: nvidia v: 470.63.01 alternate: nouveau,nvidia_drm bus-ID: 01:00.0
           chip-ID: 10de:249d class-ID: 0300
           Device-2: AMD Cezanne vendor: ASUSTeK driver: amdgpu v: kernel bus-ID: 06:00.0
           chip-ID: 1002:1638 class-ID: 0300
           Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver:
           loaded: amdgpu,ati,nvidia unloaded: modesetting alternate: fbdev,nouveau,nv,vesa
           display-ID: :1 screens: 1
           Screen-1: 0 s-res: 1920x1080 s-dpi: 75 s-size: 652x366mm (25.7x14.4")
           s-diag: 748mm (29.4")
           Monitor-1: eDP-1-0 res: 1920x1080 hz: 300 dpi: 142 size: 344x194mm (13.5x7.6")
           diag: 395mm (15.5")
           OpenGL: renderer: NVIDIA GeForce RTX 3070 Laptop GPU/PCIe/SSE2
           v: 4.6.0 NVIDIA 470.63.01 direct render: Yes
Audio:     Device-1: NVIDIA GA104 High Definition Audio vendor: ASUSTeK driver: snd_hda_intel
           v: kernel bus-ID: 01:00.1 chip-ID: 10de:228b class-ID: 0403
           Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: ASUSTeK
           driver: N/A alternate: snd_pci_acp3x, snd_rn_pci_acp3x bus-ID: 06:00.5
           chip-ID: 1022:15e2 class-ID: 0480
           Device-3: AMD Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel
           bus-ID: 06:00.6 chip-ID: 1022:15e3 class-ID: 0403
           Sound Server-1: ALSA v: k5.13.12-zen1-1-zen running: yes
           Sound Server-2: JACK v: 1.9.19 running: no
           Sound Server-3: PulseAudio v: 15.0 running: yes
           Sound Server-4: PipeWire v: 0.3.34 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK
           driver: r8169 v: kernel port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
           IF: enp3s0 state: down mac: <filter>
           Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel port: d000 bus-ID: 04:00.0
           chip-ID: 8086:2723 class-ID: 0280
           IF: wlp4s0 state: up mac: <filter>
           IF-ID-1: anbox0 state: down mac: <filter>
Bluetooth: Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-4:4
           chip-ID: 8087:0029 class-ID: e001
           Report: bt-adapter ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
           rfk-block: hardware: no software: yes address: <filter>
Drives:    Local Storage: total: 953.87 GiB used: 69.44 GiB (7.3%)
           SMART Message: Unable to run smartctl. Root privileges required.
           ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZVLB1T0HBLR-00000
           size: 953.87 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4
           type: SSD serial: <filter> rev: EXF7201Q temp: 43.9 C scheme: GPT
Partition: ID-1: / raw-size: 953.61 GiB size: 953.61 GiB (100.00%) used: 69.44 GiB (7.3%)
           fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
           ID-2: /boot/efi raw-size: 260 MiB size: 256 MiB (98.46%) used: 562 KiB (0.2%)
           fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
           ID-3: /home raw-size: 953.61 GiB size: 953.61 GiB (100.00%) used: 69.44 GiB (7.3%)
           fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
           ID-4: /var/log raw-size: 953.61 GiB size: 953.61 GiB (100.00%) used: 69.44 GiB (7.3%)
           fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
           ID-5: /var/tmp raw-size: 953.61 GiB size: 953.61 GiB (100.00%) used: 69.44 GiB (7.3%)
           fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:2
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
           ID-1: swap-1 type: zram size: 30.77 GiB used: 5.2 MiB (0.0%) priority: 100
           dev: /dev/zram0
Sensors:   System Temperatures: cpu: 49.0 C mobo: N/A
           Fan Speeds (RPM): cpu: 2500
           GPU: device: nvidia screen: :1.0 temp: 44 C device: amdgpu temp: 45.0 C
Info:      Processes: 435 Uptime: 11h 49m wakeups: 5 Memory: 30.77 GiB used: 5.1 GiB (16.6%)
           Init: systemd v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages:
           pacman: 1858 lib: 517 Shell: Bash v: 5.1.8 default: Zsh v: 5.8 running-in: alacritty
           inxi: 3.3.06

I changed my Alacritty Config, Konsole Config and its still the same old fish design config. I used chsh and it says its on zsh even after relogging/rebooting.

There should be a setting in alacritty to start with fish

1 Like

Another thing that tells me that zsh is not being used are my home variables.

Welcome :slight_smile:

image
You did.

How do you do?
What you like to change?
Neofetch output, textcolor, ... ?

having a quick look it does seem you changed the shell to zsh !

notice that bash / zsh / fish on garuda all have a very similar look and feeling on garuda !

My .zshenv doesn't work

Yeah thanks I just got to know about that. Before, the zsh config used to be way different.

I reinstalled zsh and fixed it, thanks for the help

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.