Celulloid crashes my UI

inxi -Faz
System:    Kernel: 5.14.16-zen1-1-zen x86_64 bits: 64 compiler: gcc v: 11.1.0
           parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
           root=UUID=1409d596-84e3-4768-b0e5-996dc20bb2a5 rw [email protected] quiet splash
           rd.udev.log_priority=3 vt.global_cursor_default=0 systemd.unified_cgroup_hierarchy=1
           loglevel=3
           Desktop: LXQt 0.17.1 tk: Qt 5.15.2 info: cairo-dock, lxqt-panel wm: kwin_x11 vt: 1
           dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:   Type: Desktop Mobo: INTEL model: HM65DESK serial: <filter> UEFI: American Megatrends
           v: 4.6.5 date: 02/23/2019
CPU:       Info: Dual Core model: Intel Core i7-2620M bits: 64 type: MT MCP arch: Sandy Bridge
           family: 6 model-id: 2A (42) stepping: 7 microcode: 2F cache: L2: 4 MiB
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 21552
           Speed: 3197 MHz min/max: 800/3400 MHz Core speeds (MHz): 1: 3197 2: 3068 3: 2827
           4: 3231
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported
           Type: l1tf mitigation: PTE Inversion
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable
           Type: meltdown mitigation: PTI
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP:
           conditional, RSB filling
           Type: srbds status: Not affected
           Type: tsx_async_abort status: Not affected
Graphics:  Device-1: NVIDIA GM107 [GeForce GTX 750] driver: nvidia v: 495.44
           alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:1381 class-ID: 0300
           Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: nvidia
           display-ID: :0 screens: 1
           Screen-1: 0 s-res: 1360x768 s-dpi: 90 s-size: 384x300mm (15.1x11.8")
           s-diag: 487mm (19.2")
           Monitor-1: HDMI-0 res: 1360x768 hz: 60 dpi: 49 size: 708x398mm (27.9x15.7")
           diag: 812mm (32")
           OpenGL: renderer: NVIDIA GeForce GTX 750/PCIe/SSE2 v: 4.6.0 NVIDIA 495.44
           direct render: Yes
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio driver: snd_hda_intel
           v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1c20 class-ID: 0403
           Device-2: NVIDIA GM107 High Definition Audio [GeForce 940MX] driver: snd_hda_intel
           v: kernel bus-ID: 01:00.1 chip-ID: 10de:0fbc class-ID: 0403
           Sound Server-1: ALSA v: k5.14.16-zen1-1-zen running: yes
           Sound Server-2: sndio v: N/A running: no
           Sound Server-3: JACK v: 1.9.19 running: no
           Sound Server-4: PulseAudio v: 15.0 running: yes
           Sound Server-5: PipeWire v: 0.3.39 running: yes
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169
           v: kernel port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
Drives:    Local Storage: total: 2.78 TiB used: 689.93 GiB (24.2%)
           SMART Message: Required tool smartctl not installed. Check --recommends
           ID-1: /dev/sda maj-min: 8:0 model: SATA SSD size: 55.9 GiB block-size: physical: 512 B
           logical: 512 B speed: 3.0 Gb/s type: SSD serial: <filter> rev: Sb10 scheme: GPT
           ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST3000NM0053 size: 2.73 TiB
           block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s type: HDD rpm: 7200
           serial: <filter> rev: G00A scheme: GPT
Partition: ID-1: / raw-size: 389.6 GiB size: 389.6 GiB (100.00%) used: 294.16 GiB (75.5%)
           fs: btrfs dev: /dev/sdb4 maj-min: 8:20
           ID-2: /boot/efi raw-size: 5.59 GiB size: 5.58 GiB (99.80%) used: 237.7 MiB (4.2%)
           fs: vfat dev: /dev/sda2 maj-min: 8:2
           ID-3: /home raw-size: 389.6 GiB size: 389.6 GiB (100.00%) used: 294.16 GiB (75.5%)
           fs: btrfs dev: /dev/sdb4 maj-min: 8:20
           ID-4: /var/log raw-size: 389.6 GiB size: 389.6 GiB (100.00%) used: 294.16 GiB (75.5%)
           fs: btrfs dev: /dev/sdb4 maj-min: 8:20
           ID-5: /var/tmp raw-size: 389.6 GiB size: 389.6 GiB (100.00%) used: 294.16 GiB (75.5%)
           fs: btrfs dev: /dev/sdb4 maj-min: 8:20
Swap:      Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
           ID-1: swap-1 type: zram size: 3.79 GiB used: 139.5 MiB (3.6%) priority: 100
           dev: /dev/zram0
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 28 C
           Fan Speeds (RPM): N/A gpu: nvidia fan: 33%
Info:      Processes: 240 Uptime: 5h 53m wakeups: 0 Memory: 3.79 GiB used: 2.44 GiB (64.4%)
           Init: systemd v: 249 tool: systemctl Compilers: gcc: 11.1.0 clang: 12.0.1 Packages:
           pacman: 1871 lib: 529 flatpak: 0 Client: Unknown Client: garuda-assistant inxi: 3.3.08

Idk if Celulloid is supported or not, but here's what happened:
Some hours after an update last week, I tried opening a Celulloid playlist, my KDE-Connect was on, and I know I can't open Celulloid while connected to my phone otherwise it won't open at all. Normally, it simply crashes itself and life back to normal.

This time tho, it notified me with some error on managing OpenGL and crashed. I disconnected KDE-C and tried again, but then it not only crashed itself, it froze the entire UI; sound was on, later I noticed mouse and keyboard were functional as well (even tho the screen had no response). I could then quit with ctrl+Q, my UI got back to normal.
Everytime I try to play something on Celulloid now it simply freezes my screen with itself and it takes quite an amount of time for it to quit even with the shortcut.

I tried reinstalling with pacman -Su ceulloid, I tried messing up with the settings, tried opening video, opening audio, playlists, nothing works.

Does anyone have any idea how this could be solved? I'm gonna be honest here, I don't even know how to explain to whoogle what's happening to have a decent search O.O

image

Did you check

?

Typo !?!

sudo pacman -Syu celluloid

Celluloid can read your MPV config file - have set that option and customised the file $HOME/.config/mpv/mpv.conf ?

celluloid is in the repos, and should be more stable than the -git version, e.g. it works fine here.

2 Likes

Yep, I tried seeing the issues on their git, nothing there seems to match on my searchs. If you prefere, I could close this issue on the forum and open a new one there at github (if that's what you meant)

The typo was only on the forum tho, I tried reinstalling it last week, and the terminal have no mercy on typos xD the reinstallation was successful, it just didn't do any difference.

About mpv, I don't even know what it is, so for sure I didn't mess up with that. It could be an mpv problem tho upon the update or some crash(?)

What output do you get if you run celluloid from a terminal (and do the thing that crashes it)?