Can't update system 'cause obs-studio-browser and libva-vdpau-driver are in conflict

Hello everyone,
i'm trying to update my system, but the new version of obs prevent me to update because obs-studio-browser and libva-vdpau-driver are in conflict. I could update the system before this. I tried to remove the package in question, but it's installed by 'garuda-video-linux-config'. What should i do?

This is the update command

[[email protected] ~]$ update
:: Sincronizzazione dei database in corso...
 garuda è aggiornato
 core è aggiornato
 extra è aggiornato
 community è aggiornato
 multilib è aggiornato
 chaotic-aur                                2,2 MiB  2,16 MiB/s 00:01 [---------------------------------------] 100%

--> Refreshing mirrorlists using rate-mirrors, please be patient..
:: Sincronizzazione dei database in corso...
download di garuda in corso...
download di core in corso...
download di extra in corso...
download di community in corso...
download di multilib in corso...
download di chaotic-aur in corso...
spawn pacman -Su
:: Starting full system upgrade...
warning: ttf-google-fonts-git: ignoring package upgrade (1:r4587.c048e845b-1 => 1:r4588.160934bd0-1)
resolving dependencies...
looking for conflicting packages...
:: obs-studio-browser and libva-vdpau-driver are in conflict. Remove libva-vdpau-driver? [y/N] 
n
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: obs-studio-browser and libva-vdpau-driver are in conflict

and here is garuda-inxi

System:
  Kernel: 6.1.5-zen2-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=0eb95736-e32e-43e8-be85-1f050b5d32b6 rw [email protected]
    quiet resume=UUID=4594523c-24c5-451b-8620-1ebd681f5b2e loglevel=3
    pcie_aspm=off ibt=off
  Desktop: KDE Plasma v: 5.26.5 tk: Qt v: 5.15.8 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Laptop System: ASUSTeK product: X541UV v: 1.0
    serial: <superuser required>
  Mobo: ASUSTeK model: X541UV v: 1.0 serial: <superuser required>
    UEFI: American Megatrends v: X541UV.309 date: 04/17/2019
Battery:
  ID-1: BAT0 charge: 28.2 Wh (98.9%) condition: 28.5/34.6 Wh (82.4%)
    volts: 10.8 min: 10.8 model: ASUSTeK ASUS Battery type: Li-ion serial: N/A
    status: not charging cycles: 342
  Device-1: hidpp_battery_0 model: Logitech G305 Lightspeed Wireless Gaming
    Mouse serial: <filter> charge: 100% (should be ignored) rechargeable: yes
    status: discharging
CPU:
  Info: model: Intel Core i5-6198DU bits: 64 type: MT MCP arch: Skylake
    gen: core 6 level: v3 note: check built: 2015 process: Intel 14nm family: 6
    model-id: 0x4E (78) stepping: 3 microcode: 0xF0
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 2588 high: 2800 min/max: 400/2800 scaling:
    driver: intel_pstate governor: performance cores: 1: 2754 2: 2800 3: 2400
    4: 2400 bogomips: 19200
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
Graphics:
  Device-1: Intel HD Graphics 510 vendor: ASUSTeK driver: i915 v: kernel
    arch: Gen-9 process: Intel 14n built: 2015-16 ports: active: HDMI-A-2
    off: eDP-1 empty: DP-1,HDMI-A-1 bus-ID: 00:02.0 chip-ID: 8086:1906
    class-ID: 0300
  Device-2: NVIDIA GM108M [GeForce 920MX] vendor: ASUSTeK driver: nvidia
    v: 525.78.01 alternate: nouveau,nvidia_drm non-free: 525.xx+
    status: current (as of 2022-12) arch: Maxwell code: GMxxx
    process: TSMC 28nm built: 2014-19 pcie: gen: 1 speed: 2.5 GT/s lanes: 4
    link-max: gen: 3 speed: 8 GT/s bus-ID: 01:00.0 chip-ID: 10de:134f
    class-ID: 0302
  Device-3: Chicony USB2.0 VGA UVC WebCam type: USB driver: uvcvideo
    bus-ID: 1-6:3 chip-ID: 04f2:b52b class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.6 with: Xwayland v: 22.1.7
    compositor: kwin_x11 driver: X: loaded: intel,nvidia
    unloaded: modesetting,nouveau alternate: fbdev,nv,vesa dri: i965 gpu: i915
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 507x285mm (19.96x11.22")
    s-diag: 582mm (22.9")
  Monitor-1: HDMI-A-2 mapped: HDMI2 pos: primary model: Acer VG240Y
    serial: <filter> built: 2021 res: 1920x1080 hz: 75 dpi: 92 gamma: 1.2
    size: 530x300mm (20.87x11.81") diag: 604mm (23.8") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  Monitor-2: eDP-1 mapped: eDP1 note: disabled model: ChiMei InnoLux 0x15ca
    built: 2014 res: 1920x1080 dpi: 101 gamma: 1.2 size: 344x193mm (13.54x7.6")
    diag: 394mm (15.5") ratio: 16:9 modes: 1366x768
  API: OpenGL v: 4.6 Mesa 22.3.3 renderer: Mesa Intel HD Graphics 510 (SKL
    GT1) direct render: Yes
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: ASUSTeK
    driver: snd_hda_intel bus-ID: 1-2.3:6 v: kernel chip-ID: 046d:0adf
    alternate: snd_soc_skl,snd_soc_avs class-ID: 0300 bus-ID: 00:1f.3
    chip-ID: 8086:9d70 serial: <filter> class-ID: 0403
  Device-2: Logitech G435 Wireless Gaming Headset type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound API: ALSA v: k6.1.5-zen2-1-zen running: yes
  Sound Interface: sndio v: N/A running: no
  Sound Server-1: PulseAudio v: 16.1 running: no
  Sound Server-2: PipeWire v: 0.3.64 running: yes
Network:
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet vendor: ASUSTeK
    driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1 port: d000
    bus-ID: 02:00.2 chip-ID: 10ec:8136 class-ID: 0200
  IF: enp2s0f2 state: down mac: <filter>
  Device-2: Qualcomm Atheros AR9485 Wireless Network Adapter vendor: Lite-On
    driver: ath9k v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    bus-ID: 03:00.0 chip-ID: 168c:0032 class-ID: 0280
  IF: wlp3s0 state: up mac: <filter>
Drives:
  Local Storage: total: 1.36 TiB used: 611.42 GiB (43.8%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT1000MX500SSD1
    size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 023 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Hitachi model: HTS545050B9A300
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: HDD rpm: 5400 serial: <filter> rev: C64G scheme: GPT
Partition:
  ID-1: / raw-size: 922.42 GiB size: 922.42 GiB (100.00%)
    used: 520.68 GiB (56.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 608 KiB (0.2%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 922.42 GiB size: 922.42 GiB (100.00%)
    used: 520.68 GiB (56.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-4: /var/log raw-size: 922.42 GiB size: 922.42 GiB (100.00%)
    used: 520.68 GiB (56.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
  ID-5: /var/tmp raw-size: 922.42 GiB size: 922.42 GiB (100.00%)
    used: 520.68 GiB (56.4%) fs: btrfs dev: /dev/sda2 maj-min: 8:2
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
  ID-1: swap-1 type: zram size: 7.63 GiB used: 897 MiB (11.5%) priority: 100
    dev: /dev/zram0
  ID-2: swap-2 type: partition size: 8.8 GiB used: 0 KiB (0.0%) priority: -2
    dev: /dev/sda3 maj-min: 8:3
Sensors:
  System Temperatures: cpu: 49.0 C pch: 38.5 C mobo: N/A
  Fan Speeds (RPM): cpu: 2300
Info:
  Processes: 237 Uptime: 5h 33m wakeups: 21 Memory: 7.63 GiB
  used: 3.16 GiB (41.5%) Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.0 alt: 11 clang: 14.0.6 Packages:
  pm: dpkg pkgs: 0 pm: pacman pkgs: 1747 libs: 529 tools: pamac pm: flatpak
  pkgs: 0 Shell: Bash v: 5.1.16 running-in: konsole inxi: 3.3.24
Garuda (2.6.14-1):
  System install date:     2022-11-20
  Last full system update: 2023-01-14 ↻
  Is partially upgraded:   Yes
  Relevant software:       snapper NetworkManager mkinitcpio nvidia-dkms
  Windows dual boot:       No/Undetected
  Failed units:            systemd-networkd-wait-online.service 

Have you tried to Press Y?
The conflict was added in the latest update.
If needed you can replace the other. See latest comment in:
https://aur.archlinux.org/packages/obs-studio-browser

3 Likes

Yes, i did, but unfortunatelly, it won't continue because of conflict of dependences

[[email protected] ~]$ sudo pacman -Syu
[sudo] password di calogero:  
:: Sincronizzazione dei database in corso...
 garuda                                    98,4 KiB  17,4 KiB/s 00:06 [---------------------------------------] 100%
 core                                     152,1 KiB  29,1 KiB/s 00:05 [---------------------------------------] 100%
 extra                                   1739,8 KiB   283 KiB/s 00:06 [---------------------------------------] 100%
 community                                  7,2 MiB   994 KiB/s 00:07 [---------------------------------------] 100%
 multilib                                 163,4 KiB  32,5 KiB/s 00:05 [---------------------------------------] 100%
 chaotic-aur                                2,2 MiB   650 KiB/s 00:04 [---------------------------------------] 100%
:: Aggiornamento del sistema in corso...
attenzione: ttf-google-fonts-git: l'aggiornamento del pacchetto è stato ignorato (1:r4587.c048e845b-1 => 1:r4588.160934bd0-1)
risoluzione delle dipendenze in corso...
ricerca dei pacchetti in conflitto in corso...
:: obs-studio-browser e libva-vdpau-driver vanno in conflitto. Vuoi rimuovere libva-vdpau-driver? [s/N] y
errore: sono stati rilevati dei conflitti irrisolvibili tra i pacchetti
errore: impossibile eseguire l'operazione richiesta (dipendenze in conflitto)
:: obs-studio-browser e libva-vdpau-driver vanno in conflitto

Post Edit:
I did go to the AUR in search of some comments for help and i found this comment in regard of the conflict.
Should i remove my graphics driver, update and then install graphics driver back again?
I'm on a 2 graphics card system, integrated and dedicated, but i use the integrated one to encode and the dedicated to use for software and games...
I think that if i update, it won't install the graphics card driver back again...

Ok, after doing again the update command and, after asking if i want to remove the component in question and typing 'Y', it started the update... Saw the garuda-nvidia-config, garuda-nvidia-prime-config and garuda-video-linux-config to update...maybe these metapacket fixed the issue...
After updating everything, in OBS the nvidia card is removed as VAAPI Device and that's ok since it doesn't even support the NVENC codec.
Closing the post as Resolved. Thanks @filo for the quick response.

2 Likes

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.