Can't open other partitions

I don't often have to do this, but I am used to being able to access partitions from other distros that are on this same machine - without issue. I am running XFCE Garuda, but am not gaming (not good enough! :grin:) I can see the labels of the partitions I want to access in Thunar, but attempts to open them fail.

I ran into this on another Garuda install, but that was easily 'cured' by ensuring that the hijacked (by EasyTag!) mime-type inode/directory was returned to thunar.desktop.
Here is a piece of thunar.desktop

Exec=thunar %F

# vi:set encoding=UTF-8:

so you can see that thunar thinks it's OK too!

The real oddity (to my view) is that thunar correctly requires sudo authorization to open - but then doesn't do it! Any ideas out there on where to look next?

Check the permissions including UID & GID.

1 Like

Hmmm- can't check the partitions (can't open/mount them) but I know what they are in their own distros. My UID is 1000 (as expected) and here's the GID listing:

┌23:45:48 WD= [/etc]
└───[email protected] ─▶$ cat /etc/group | grep freebird

if that tells you anything...

Not that it probably is relevant, but I can't see any gvfs packages missing either.

It works for me to include it in the fstab.
But I am only a painter :wink:

1 Like

If I needed to do it often enough, that would make sense for sure. As it is, I can work around it easily enough - mostly by booting a different distro, and moving the files the other way! Just very weird. Not to waste much effort on it, as it is not major by any means... :grin:

Or perhaps you could open a terminal and mount it via sudo? I mean that's what I do.

Could probably be done, but I don't memorize UUID values for all the partitions I might want to use! Waiting till I'm on something else (another Garuda, an Arch, an EndeavourOS or whatever) where gvfs works normally will do...

You can mount by old style device names like /dev/sda2...don't have to memorize numeric sequences or make aliases.
The old ways aren't necessarily the best, but they are the most portable.

1 Like

Yeah - I guess so. Still a lot of typing for this simple operation, though. All the partitions in question are nvme0n1p# (etc), and I have to run blkid first and hope I can remember which is which...

Can you tell I'm fighting a rearguard action here? It should just work...

Thunar would be able to auto mount via gvfs (and thunar settings).
Maybe you need Optional depends?

pacman -Si thunar

Opt deps: gvfs: trash support, mounting with udisk and remote filesystems
          tumbler: thumbnail previews
          thunar-volman: removable device management
          thunar-archive-plugin: archive creation and extraction
          thunar-media-tags-plugin: view/edit ID3/OGG tags

Does not appear to be the problem, Here's the lists:
Optional depends:
gvfs (8 pkgs)

┌13:29:51 WD= [/usr/share/conkywx]
└───[email protected] ─▶$ yay gvfs | grep stalled
8 extra/gvfs-smb 1.46.2-1 (30.1 KiB 92.2 KiB) [gnome] (Installed)
7 extra/gvfs-nfs 1.46.2-1 (21.5 KiB 53.9 KiB) [gnome] (Installed)
6 extra/gvfs-mtp 1.46.2-1 (49.6 KiB 164.1 KiB) [gnome] (Installed)
5 extra/gvfs-gphoto2 1.46.2-1 (48.8 KiB 168.1 KiB) [gnome] (Installed)
4 extra/gvfs-google 1.46.2-1 (30.0 KiB 77.8 KiB) [gnome] (Installed)
3 extra/gvfs-goa 1.46.2-1 (29.7 KiB 98.2 KiB) [gnome] (Installed)
2 extra/gvfs-afc 1.46.2-1 (44.4 KiB 144.1 KiB) [gnome] (Installed)
1 extra/gvfs 1.46.2-1 (1.0 MiB 5.1 MiB) [gnome] (Installed)

the others:

┌13:30:38 WD= [/usr/share/conkywx]
└───[email protected] ─▶$ yay thunar | grep stalled
4 extra/thunar-volman 4.16.0-1 (130.7 KiB 660.4 KiB) [xfce4] (Installed)
3 extra/thunar-media-tags-plugin 0.3.0-2 (60.3 KiB 264.1 KiB) [xfce4-goodies] (Installed)
2 extra/thunar-archive-plugin 0.4.0-3 (39.4 KiB 149.6 KiB) [xfce4-goodies] (Installed)
1 extra/thunar 4.16.3-1 (1.2 MiB 6.3 MiB) [xfce4] (Installed)

All present and accounted for! It's a weird one. Don't waste any more thought on it though - there are so many ways around it, after all...

Is it possible that one of your other installed OS were hibernated instead of shut down? I have seen this kind of problem before and had to properly shut down the other os before it would work again.

However, usually I would still be able to mount read only so this might not be the same issue. Just another thing to look into if you hadn't found another solution yet.