Cant login after stand-by

hiho,
after being in Standby my PC showed me a strange error msg in Fullscreen.. i shall press shift-strg f2, and enter loginctl unlock-session to fix my problem. After i rebooted my System booted to SDDM and stuck there, i can´t login with my password. I tried root (which worked), and also a test user worked as intended. I tryed the command in admin mode but nothing changed, also using a older snapshot didn´t work. Any Ideas how i can rescue my Account?

heres my inxi data..

System:
Kernel: 6.1.7-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
root=UUID=2f16b873-cb2f-47c8-a98a-8dd51d19c048 rw [email protected]
quiet quiet splash rd.udev.log_priority=3 vt.global_cursor_default=0
resume=UUID=b4bcb446-90a0-4a25-a72b-5c6e4313dcb4 loglevel=3 ibt=off
Desktop: KDE Plasma v: 5.26.5 tk: Qt v: 5.15.8 info: latte-dock
wm: kwin_x11 vt: 1 dm: SDDM Distro: Garuda Linux base: Arch Linux
Machine:
Type: Desktop Mobo: Micro-Star model: MAG B550 TOMAHAWK (MS-7C91) v: 2.0
serial: <superuser required> UEFI: American Megatrends LLC. v: A.B1
date: 08/02/2022
CPU:
Info: model: AMD Ryzen 7 5700G with Radeon Graphics bits: 64 type: MT MCP
arch: Zen 3 gen: 4 level: v3 note: check built: 2021-22
process: TSMC n7 (7nm) family: 0x19 (25) model-id: 0x50 (80) stepping: 0
microcode: 0xA50000D
Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
L3: 16 MiB desc: 1x16 MiB
Speed (MHz): avg: 3749 high: 3800 min/max: 1400/4672 boost: enabled
scaling: driver: acpi-cpufreq governor: performance cores: 1: 3800 2: 3800
3: 3800 4: 2994 5: 3800 6: 3800 7: 3800 8: 3800 9: 3800 10: 3800 11: 3800
12: 3800 13: 3800 14: 3800 15: 3800 16: 3800 bogomips: 121368
Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
Vulnerabilities: <filter>
Graphics:
Device-1: AMD Cezanne [Radeon Vega Series / Radeon Mobile Series]
driver: amdgpu v: kernel arch: GCN-5.1 code: Vega-2 process: TSMC n7 (7nm)
built: 2018-21 pcie: gen: 3 speed: 8 GT/s lanes: 16 link-max: gen: 4
speed: 16 GT/s ports: active: DP-1,HDMI-A-1 empty: DP-2 bus-ID: 30:00.0
chip-ID: 1002:1638 class-ID: 0300 temp: 31.0 C
Device-2: Sunplus Innovation Live Camera type: USB
driver: snd-usb-audio,uvcvideo bus-ID: 3-1.4:4 chip-ID: 1bcf:2284
class-ID: 0102 serial: <filter>
Display: x11 server: X.Org v: 21.1.6 with: Xwayland v: 22.1.7
compositor: kwin_x11 driver: X: loaded: amdgpu unloaded: modesetting
alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: :0 screens: 1
Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1013x285mm (39.88x11.22")
s-diag: 1052mm (41.43")
Monitor-1: DP-1 mapped: DisplayPort-0 pos: right model: BenQ V2200Eco
serial: <filter> built: 2010 res: 1920x1080 dpi: 102 gamma: 1.2
size: 477x268mm (18.78x10.55") diag: 546mm (21.5") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
Monitor-2: HDMI-A-1 mapped: HDMI-A-0 pos: primary,left model: AOC 22V2WG5
serial: <filter> built: 2020 res: 1920x1080 hz: 60 dpi: 102 gamma: 1.2
size: 476x268mm (18.74x10.55") diag: 546mm (21.5") ratio: 16:9 modes:
max: 1920x1080 min: 720x400
API: OpenGL v: 4.6 Mesa 22.3.3 renderer: AMD Radeon Graphics (renoir LLVM
15.0.7 DRM 3.49 6.1.7-zen1-1-zen) direct render: Yes
Audio:
Device-1: AMD Renoir Radeon High Definition Audio driver: snd_hda_intel
v: kernel pcie: bus-ID: 3-1.4:4 chip-ID: 1bcf:2284 gen: 3 class-ID: 0102
speed: 8 GT/s lanes: 16 serial: <filter> link-max: gen: 4 speed: 16 GT/s
bus-ID: 30:00.1 chip-ID: 1002:1637 class-ID: 0403
Device-2: AMD Family 17h/19h HD Audio vendor: Micro-Star MSI
driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
link-max: gen: 4 speed: 16 GT/s bus-ID: 30:00.6 chip-ID: 1022:15e3
class-ID: 0403
Device-3: Sunplus Innovation Live Camera type: USB
driver: snd-usb-audio,uvcvideo
Sound API: ALSA v: k6.1.7-zen1-1-zen running: yes
Sound Server-1: PulseAudio v: 16.1 running: no
Sound Server-2: PipeWire v: 0.3.64 running: yes
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
lanes: 1 port: e000 bus-ID: 22:00.0 chip-ID: 10ec:8168 class-ID: 0200
IF: enp34s0 state: down mac: <filter>
Device-2: Realtek RTL8125 2.5GbE vendor: Micro-Star MSI driver: r8169
v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1 port: d000 bus-ID: 2a:00.0
chip-ID: 10ec:8125 class-ID: 0200
IF: enp42s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
IF-ID-1: br-2ef777660ffa state: up speed: 10000 Mbps duplex: unknown
mac: <filter>
IF-ID-2: br-8597e3665ab8 state: down mac: <filter>
IF-ID-3: br-fbd8f9ca0e8f state: down mac: <filter>
IF-ID-4: docker0 state: up speed: 10000 Mbps duplex: unknown mac: <filter>
IF-ID-5: vethb8d20f2 state: up speed: 10000 Mbps duplex: full
mac: <filter>
IF-ID-6: vethe842155 state: up speed: 10000 Mbps duplex: full
mac: <filter>
Drives:
Local Storage: total: 20.01 TiB used: 7.16 TiB (35.8%)
SMART Message: Unable to run smartctl. Root privileges required.
ID-1: /dev/nvme0n1 maj-min: 259:2 vendor: Samsung
model: SSD 970 EVO Plus 1TB size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 3B2QEXM7 temp: 29.9 C scheme: GPT
ID-2: /dev/nvme1n1 maj-min: 259:0 vendor: Samsung
model: SSD 970 EVO Plus 1TB size: 931.51 GiB block-size: physical: 512 B
logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
rev: 3B2QEXM7 temp: 26.9 C scheme: GPT
ID-3: /dev/sda maj-min: 8:0 vendor: Western Digital
model: WD60EZAZ-00SF3B0 size: 5.46 TiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
rev: 0A80 scheme: GPT
ID-4: /dev/sdb maj-min: 8:16 vendor: Western Digital
model: WD20EFRX-68EUZN0 size: 1.82 TiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5400 serial: <filter>
rev: 0A82 scheme: GPT
ID-5: /dev/sdc maj-min: 8:32 vendor: Western Digital
model: WD60EFZX-68B3FN0 size: 5.46 TiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5640 serial: <filter>
rev: 0A81 scheme: GPT
ID-6: /dev/sdd maj-min: 8:48 vendor: Western Digital
model: WD60EFZX-68B3FN0 size: 5.46 TiB block-size: physical: 4096 B
logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 5640 serial: <filter>
rev: 0A81 scheme: GPT
Partition:
ID-1: / raw-size: 901.18 GiB size: 901.18 GiB (100.00%)
used: 383.07 GiB (42.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:4
ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
used: 608 KiB (0.2%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:3
ID-3: /home raw-size: 901.18 GiB size: 901.18 GiB (100.00%)
used: 383.07 GiB (42.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:4
ID-4: /var/log raw-size: 901.18 GiB size: 901.18 GiB (100.00%)
used: 383.07 GiB (42.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:4
ID-5: /var/tmp raw-size: 901.18 GiB size: 901.18 GiB (100.00%)
used: 383.07 GiB (42.5%) fs: btrfs dev: /dev/nvme0n1p2 maj-min: 259:4
Swap:
Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default)
ID-1: swap-1 type: zram size: 58.75 GiB used: 0 KiB (0.0%) priority: 100
dev: /dev/zram0
ID-2: swap-2 type: partition size: 30.03 GiB used: 0 KiB (0.0%)
priority: -2 dev: /dev/nvme0n1p3 maj-min: 259:5
Sensors:
System Temperatures: cpu: 36.4 C mobo: N/A gpu: amdgpu temp: 32.0 C
Fan Speeds (RPM): N/A
Info:
Processes: 440 Uptime: 1h 49m wakeups: 0 Memory: 58.75 GiB
used: 3.78 GiB (6.4%) Init: systemd v: 252 default: graphical
tool: systemctl Compilers: gcc: 12.2.1 Packages: pm: pacman pkgs: 1776
libs: 517 tools: octopi,paru Shell: fish v: 3.6.0 default: Bash v: 5.1.16
running-in: konsole inxi: 3.3.24
Garuda (2.6.14-1):
System install date:     2022-10-15
Last full system update: 2023-01-22
Is partially upgraded:   No
Relevant software:       snapper NetworkManager mkinitcpio
Windows dual boot:       No/Undetected
Failed units:

?

You mean Ctrl + Alt + F2

Boot live ISO, backup important files, use chroot from garuda-welcome, update your system with "garuda-update".

4 Likes

What was the error message?

Why not? What specifically happens? Incorrect password, or something else?

If you have special characters in your password, are they being output as you expect? Test by typing in the username field (where you can see them).

2 Likes

hmm, next time this happens i make a screenshot with the smartphone, it was a full page in german with instructions to fix it.

no, SDDM just shows wrong password. Admin and Test user worked as intended. I also can change user from test user to main account with the password in the console.

I've never seen this before, but why didn't you follow it, unless it said to delete everything and reinstall?

As sudo/su you can use passwd to reset the password.


Ich habe sowas noch nie gesehen, aber warum hast du das nicht befolgt, außer da stand du sollst alles löschen und neu installieren?

Als sudo/su kannst du mit passwd das Passwort neu setzen.

2 Likes

did that, changed the password during the test session, still not possible. but, like i said the login/change of User from console is possible with the password.

hab ich gemacht, während der test session mit den Test user, brachte aber nichts. Die zugangs daten funktionieren innerhalb der Konsole.

Test if SDDM is using the correct keyboard layout.

2 Likes

tryed that, nope. works normal, also no special characters.

ha, i tried that in SDDM and got a login screen , after entering the Name/Password, it showed a error " change directory failed: No such file or directory. Logging in with home = "/"`" which i fixed with "chown user:user /home/user". Now it works again :smiley: thank you all for you time and Ideas.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.