Can't boot Garuda

Hey guys,

I’m a casual user of Garuda Linux and so far I’ve been loving it.

Since this afternoon I can’t boot in tho.

I ran a couple commands in hope of gaining some space and I messed up real bad :sob:

I think I ended up cleaning something on the /var folder cause now I’m getting those errors :

Failed to mount /var/cache
Dependency failed for local file system

Failed to mount /var/log
Dependency failed for record system boot/shutdown in UTMP
Dependency failed for journal to persistent storage

Failed to mount /var/tmp
Dependency failed for network time synchronization

Can I fix this somehow?

Can you provide the output of garuda-inxi? You probably deleted the template that describes and requires it.

5 Likes

Im new so I can’t post pictures… and I can’t copy paste text since it doesn’t boot… but the end says:

Garuda 2.6.32-1:
System install date: 2023-07-14
Last full system update: 2023-12-27
Is partially upgraded: no
Relevant software: snapper dracut
Windows dual boot: yes
Failed units: var-cache.mount var-log.mount var-tmp.mount

Thanks for trying to help :smiling_face:

Sorry, that’s of no use (to me) at all. Have you tried a recent snapshot? Booting from a LiveISO may help.

Q: Why would you delete the exact template designed to help? Was it plain panic?

Anyone?

4 Likes

I guessed it would not. I might try the iso option.

Like I said I was trying to save space. And for some reason deleting files wasn’t freeing space. So I search with my “best buddy” google and I saw some commands to clear cache and tmp stuff.

But I know now it was a NO NO!

I do understand it makes no sense for you, but for a casual user, a folder named cache, and another called tmp should not be THAT important… :confused:

Oh and I tried the snapshots but it goes the same way :confused:

Are you in a TTY, able to run commands?

Edit (one hour later): Where did you go?

2 Likes

Welcome to the Garuda forums! I recognise your name from the socials haha, so it’s good to see you here! :slight_smile:

No problem, if you can access a tty (which looks like you can since you saw the last bits of the command), run
garuda-inxi | tb
and post the link here. If that doesn’t work due to the alias, try
garuda-inxi | nc termbin.com 9999

I think you removed some partitions with those commands lol.
In the future when you’re looking to free up some space, I recommend using a utility like Stacer or GNOME disk utility (Baobab).

4 Likes

Please, no pictures from terminal or text files, never.

Images can be read worse, are not searchable and copyable for further search.
Should the helpers have to guess everything or laboriously type it in themselves?

4 Likes

I’m from Portugal. So it was 2 AM here. I went to sleep :rofl:

It doesn’t boot but I can enter in emergency mode.

sudo btrfs subvolume list / ?

I can try but I have no idea how to post the result here tho. I’m not in tty (no idea what it means… putty?) But in emergency mode… :confused: thanks for trying to help.

1 Like

Why the irony?

–’

Like I said, I’m in emergency mode. I have no idea how to copy the text :confused:

You’re right… just confirm it reads something like

ID 257 gen 1718670 top level 5 path @home
ID 258 gen 1805838 top level 5 path @root
ID 259 gen 1718670 top level 5 path @srv
ID 260 gen 1815184 top level 5 path @cache
ID 261 gen 1815196 top level 5 path @log
ID 262 gen 1814928 top level 5 path @tmp
ID 263 gen 1814572 top level 1382 path .snapshots
ID 1382 gen 1815196 top level 5 path @ 

that is, @cache and @tmp are still there.

It does look like this but with no (@)cache (@)tmp and (@)log…

I only get (@) (@)home (@)root (@)srv and snapshots…

About this command (garuda-inxi) - could not resolve host termbin.com

As @lum1nuss suspected, they’re gone.
The good news is that new ones can be made.
Now I don’t want to advise anything wrong, so I have to look it up…

Thank you. I tried something (made a backup first copying the file).

I edited /etc/fstab and removed those entry (cache, log and tmp) there and Garuda booted well :open_mouth:

I don’t know if this might bring more issues tho…

2 Likes

I haven’t though of that.
Good, as it’s now easier to work rather than the emergency console.
I’d also be wary of issues down the line.
I think it should now be a matter of sudo btrfs subvolume create the three missing ones and enabling them back in fstab, but I am still unsure of details.

1 Like

Hey have you changed the /etc/fstab (file)??
For example: Automount Drive (After update Garuda messed up some stuff for me, so that was the sollution)

  1. cd /etc
  2. nano fstab

Remove the unnecessary “own code”
Save it, reboot.
Q: Live USB repair not working?
Q: Grub Loading?
Q: Can you attach more details? (something messy with your Desc)
Ty :3