Can't boot after bios update

So I updated my computers bios this morning, worked great but now I can't boot back into Garuda.
I went threw all my bios settings, and get everything setup again, but when attempting to boot to Garuda I'm met with a screen titled GNU Grub Version 2.04.
I'm just starting to learn the Arch system, after having used Mint for years. So I'm not really sure how to fix this.


Its not a graphic problem. I'm just not getting to the os at all. I thought it was a grub problem, so I tried doing a repair and reinstall. Neither attempts worked. Also of note is I'm dual booted with windows and I'm able to boot into that partition just fine.

Can you explain specifically what you tried with more detail? Share the terminal output in the thread if you don't mind giving it another shot.

1 Like

I booted off a live usb, and used the boot repair that comes with Garuda.

It may be necessary to reinstall Grub following these instructions: Grub fails after update - #3 by librewish


After bios updates usually it's necessary to reinstall grub and note that secure boot may need to be turned off again as well.
Anyway, check your bios settings first.


That did the trick, and for some unknown to me reason. The boot directory is install on my second drive which was super confusing. But I'm back into my os now so that's a possible future me problem.
Thanks for the help! Never would have figured that one out on my own.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.