Can't access gui— Direct terminal after boot

I recently installed Garuda and was going through programs I didn't want and was uninstalling them, with the programs the dependencies were also getting deleted. While doing this, I uninstalled something which led me to a notification which said that "couldn't go to the lock screen.... something" idk what I deleted. The first thing I did was a reboot, after the reboot I can't access gui and I get thrown into the terminal. The only thing I have access to is terminal. Everything is working, but I can't see the gui. While trying to run an app from terminal, the error says: "Gtk-WARNING: can't open display" and "qt.qpa.xcb: could not connect to display"

What am I supposed to install again, because I can access the terminal

If you uninstalled many programs and relevant dependencies, I'd go for the restore of a snaphot (from the terminal, of course):

Hello, I did try that- well all the snapshots are doing the same thing

Have you tried if startx works.
And maybe a look at the arch linux forum, e.g.

Other hints are here:


Thanks for the answers man, I just clean flashed garuda again :smiley:

1 Like

I mark-it-solved !


Timeshift is not a complete backup system, so I would highly recommend you start doing full system backups before you uninstall important system dependencies.

Reinstalling teaches you nothing about fixing your system. If you can't be bothered learning how to repair the messes you've created, then a full backup regimen is what you need to implement.

Reinstalling is a poor way to learn Linux, always try to learn from your mistakes. In this case always check the dependencies before confirming an uninstall of potentially important components.


yup, thanks for replying. i figured it out myself btw, i think i uninstalled something called the gnome color manager

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.