Can't acces Windows Dropbox folder

Hello,
When I try to open Dropbox folder (installed in windows) I see 'Link "Dropbox" is broken. Move it to trash?' error. (Link target: unsupported reparse tag 0x9000701a, Type: link (broken) (inode/symlink)). I can reach all other file in that hdd. Problem happens when I mount that partition in fstab. I was seeing, searching Dropbox in past without problem.
I couldn't find a way to resolve it. I use gnome-disks to mount partitions. I checked "user session defaults" in gnome-disks and I can use Dropbox folder. Everything is there. If I return to fstab method it's
only link again.
I'm dual booting with windows. Both OSes are on same 120GB ssd. Dropbox is in hdd. Dropbox is set to download all files for offline usage. I used scandisk and get no errors.
In past month, this happened with Onedrive and I uninstalled it. But I need Dropbox.
I want to mount partition with fstab. What should I do? Thanks.

System:
  Kernel: 6.4.12-zen1-1-zen arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-zen
    root=UUID=ad5bdfa9-cf88-4870-a1f4-fc1ab8eb3f17 rw rootflags=subvol=@
    quiet quiet rd.udev.log_priority=3 vt.global_cursor_default=0
    nvidia-drm.modeset=1 loglevel=3 ibt=off
  Desktop: Cinnamon v: 5.8.4 tk: GTK v: 3.24.38 wm: muffin vt: 7 dm: LightDM
    v: 1.32.0 Distro: Garuda Linux base: Arch Linux
Machine:
  Type: Desktop Mobo: MSI model: B150M BAZOOKA (MS-7982) v: 3.0
    serial: <superuser required> UEFI: American Megatrends v: I.F0
    date: 12/05/2017
CPU:
  Info: model: Intel Core i5-6500 bits: 64 type: MCP arch: Skylake-S
    gen: core 6 level: v3 note: check built: 2015 process: Intel 14nm family: 6
    model-id: 0x5E (94) stepping: 3 microcode: 0xF0
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
    desc: 1x6 MiB
  Speed (MHz): avg: 2600 high: 3200 min/max: 800/3600 scaling:
    driver: intel_pstate governor: powersave cores: 1: 3200 2: 3200 3: 3200
    4: 800 bogomips: 25599
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities: <filter>
Graphics:
  Device-1: NVIDIA GM206 [GeForce GTX 950] vendor: Micro-Star MSI
    driver: nvidia v: 535.104.05 alternate: nouveau,nvidia_drm non-free: 535.xx+
    status: current (as of 2023-08) arch: Maxwell code: GMxxx
    process: TSMC 28nm built: 2014-19 pcie: gen: 3 speed: 8 GT/s lanes: 16
    ports: active: none off: HDMI-A-1 empty: DP-1, DP-2, DP-3, DVI-I-1
    bus-ID: 01:00.0 chip-ID: 10de:1402 class-ID: 0300
  Display: x11 server: X.Org v: 21.1.8 driver: X: loaded: nvidia
    unloaded: modesetting,nouveau alternate: fbdev,nv,vesa
    gpu: nvidia,nvidia-nvswitch display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x2160 s-dpi: 80 s-size: 1219x686mm (47.99x27.01")
    s-diag: 1399mm (55.07")
  Monitor-1: HDMI-A-1 mapped: HDMI-0 note: disabled model: Samsung
    serial: <filter> built: 2020 res: 3840x2160 hz: 60 dpi: 52 gamma: 1.2
    size: 1872x1053mm (73.7x41.46") diag: 1388mm (54.6") ratio: 16:9 modes:
    max: 3840x2160 min: 640x480
  API: OpenGL Message: Unable to show GL data. Required tool glxinfo
    missing.
Audio:
  Device-1: NVIDIA GM206 High Definition Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:0fba class-ID: 0403
  API: ALSA v: k6.4.12-zen1-1-zen status: kernel-api tools: N/A
  Server-1: PipeWire v: 0.3.79 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    4: pw-jack type: plugin tools: pactl,pw-cat,pw-cli,wpctl
Network:
  Message: No PCI device data found.
  Device-1: ASIX AX88772B driver: asix type: USB rev: 2.0 speed: 480 Mb/s
    lanes: 1 mode: 2.0 bus-ID: 1-10:3 chip-ID: 0b95:772b class-ID: ff00
    serial: <filter>
  IF: enp0s20f0u10 state: up speed: 100 Mbps duplex: full mac: <filter>
Drives:
  Local Storage: total: 1.03 TiB used: 398.86 GiB (37.7%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WDS120G2G0A-00JH30 size: 111.79 GiB block-size: physical: 512 B
    logical: 512 B speed: 6.0 Gb/s tech: SSD serial: <filter> fw-rev: 0400
    scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WD10EZEX-00BBHA0 size: 931.51 GiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 7200 serial: <filter>
    fw-rev: 1A01 scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: SanDisk model: Cruzer Glide 3.0
    size: 14.59 GiB block-size: physical: 512 B logical: 512 B type: USB
    rev: 3.0 spd: 5 Gb/s lanes: 1 mode: 3.2 gen-1x1 tech: N/A serial: <filter>
    fw-rev: 1.00 scheme: GPT
Partition:
  ID-1: / raw-size: 39.09 GiB size: 39.09 GiB (100.00%)
    used: 11.19 GiB (28.6%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
  ID-2: /boot/efi raw-size: 100 MiB size: 99.2 MiB (99.21%)
    used: 32.3 MiB (32.5%) fs: vfat dev: /dev/sda1 maj-min: 8:1
  ID-3: /home raw-size: 39.09 GiB size: 39.09 GiB (100.00%)
    used: 11.19 GiB (28.6%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
  ID-4: /var/log raw-size: 39.09 GiB size: 39.09 GiB (100.00%)
    used: 11.19 GiB (28.6%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
  ID-5: /var/tmp raw-size: 39.09 GiB size: 39.09 GiB (100.00%)
    used: 11.19 GiB (28.6%) fs: btrfs dev: /dev/sda3 maj-min: 8:3
Swap:
  Kernel: swappiness: 133 (default 60) cache-pressure: 100 (default) zswap: no
  ID-1: swap-1 type: zram size: 7.72 GiB used: 0 KiB (0.0%) priority: 100
    comp: zstd avail: lzo,lzo-rle,lz4,lz4hc,842 max-streams: 4 dev: /dev/zram0
Sensors:
  System Temperatures: cpu: 39.0 C pch: 55.5 C mobo: N/A gpu: nvidia
    temp: 60 C
  Fan Speeds (rpm): N/A gpu: nvidia fan: 0%
Info:
  Processes: 222 Uptime: 15m wakeups: 0 Memory: total: 8 GiB
  available: 7.72 GiB used: 2.19 GiB (28.3%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 Packages:
  pm: pacman pkgs: 1320 libs: 355 tools: pamac,paru Shell: fish v: 3.6.1
  default: Bash v: 5.1.16 running-in: gnome-terminal inxi: 3.3.29
Garuda (2.6.16-1):
  System install date:     2023-09-04
  Last full system update: 2023-09-04
  Is partially upgraded:   No
  Relevant software:       snapper NetworkManager dracut nvidia-dkms
  Windows dual boot:       Probably (Run as root to verify)
  Failed units:

Can we see the fstab entry?

Sure,

/dev/disk/by-uuid/01D8A7F6EE347BC0 /mnt/data auto defaults 0 0

What filesystem is in use on this device?

It's ntfs.

Try mounting with the ntfs-3g type (instead of auto).

https://wiki.archlinux.org/title/NTFS-3G#Default_settings

/dev/disk/by-uuid/01D8A7F6EE347BC0 /mnt/data ntfs-3g defaults 0 0
2 Likes

No. Dropbox shows as a link. I also tried ntfs.

Try mounting with Linux-compatible permissions, for example like this:

/dev/disk/by-uuid/01D8A7F6EE347BC0 /mnt/data ntfs-3g uid=1000,gid=1000,dmask=022,fmask=133 0 0

Of course adjust uid and gid as needed. If you configured autologin through Calamares your uid and gid may be different from each other.

1 Like

I used autologin and still using. I googled it. I ran id in terminal so my guid is different (1001) as you guessed. Still no Dropbox folder with fstab mounting.
I can see Dropbox folder if I choose "use session defaults" in Disks app. That's why I have hope.
Otherwise it is explained on net ntfs-3g can not do everything native ntfs does.
I've read many people had problems with reparse links with Onedrive.
I guess If I install an older Dropbox it will solve this issue.
If all fails I can install Dropbox for Linux.
Thank you

I would be curious to see how the Disks app is mounting the volume.

This item looks related to your issue:

https://wiki.archlinux.org/title/NTFS-3G#Unsupported_reparse_point

Unsupported reparse point

When mounting an NTFS filesystem for Windows 10, and reading files or directories, you may

  1. see broken symbolic links to ‘unsupported reparse point’, or
  2. see the error message cannot access some_file: Input/output error (in this case you see Could not load plugin /usr/lib64/ntfs-3g/ntfs-plugin-80000017.so: Success in the journal).

The reason for this are NTFS reparse points, used by Microsoft to extend the file system. NTFS-3G does not support some types of reparse points by default. NTFS-3G plugins may be used to provide compatibility with a part of the features defined by the following reparse points

  • System compression: also known as “Compact OS”, this feature provides a stronger, executable-optimized type of conversion than NTFS’s old LZ77. Use the ntfs-3g-system-compression-gitAUR plugin for read-only support, or run compact.exe /CompactOS:never in Windows to disable.
  • Deduplicated files: this is a Windows Server 2012 feature providing block-level offline deduplication. Not yet packaged in AUR.
  • OneDrive files: OneDrive files are stored as a special volume on Windows. The ntfs-3g-onedrive-binAUR plugin gives read-write access only for files marked “available locally”.

See this page for further details, and archive.org for downloads.

Setting that compact.exe /CompactOS:never option in Windows seems like it might be worth a shot. Obviously the Disks app is using some other method; I’d still be curious to hear about that if you can find out what it is doing.

4 Likes

I run compact.exe /CompactOS:never in Win 10. It took longer than 70 minutes.
No change for Dropbox folder. Now I remember I booted Garuda or EndeavourOS
live image to see if they show Dropbox folder. It was accesible.
Thank you.

PS C:\Windows\system32> compact.exe /CompactOS:never
Completed uncompressing OS binaries.

6102 files within 32952 directories were uncompressed.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.