Can't able install or update anything via pacman

While updating or installing anything via pacman receives this error at the end..

First run mode (config file not found)
Selected default snapshot type: RSYNC
Using system disk as snapshot device for creating snapshots in BTRFS mode

/dev/dm-1 is mounted at: /run/timeshift/backup, options: rw,relatime

E: The system partition has an unsupported subvolume layout. Only ubuntu-type layouts with @ and @home subvolumes are currently supported.

Application will exit.

Unable to run timeshift-autosnap! Please close Timeshift and try again. Script will now exit...
error: command failed to execute correctly
error: failed to commit transaction (failed to run transaction hooks)
Errors occurred, no packages were upgraded.

Please i have never worked with timeshift-autosnap......! I use Gnome desktop

We recommend you to install garuda on btrfs filesystem

Or remove

sudo pacman -R timeshift-autosnap grub-btrfs

Thanks a lot my friend actually i replaced arch with garuda. Previously i used Arch on ext64 partition in the same i installed the garuda...! It worked.. Thanks my brother for your help.. I opted second method